LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-25-2013, 05:18 AM   #1
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
[PATCH] make scim work with qt


For slackware 14.1-rc2:
Code:
--- scim.SlackBuild     2013-10-25 12:16:56.261624664 +0200
+++ scim.SlackBuild.new 2013-10-25 12:17:07.161440362 +0200
@@ -95,6 +95,7 @@
             --sysconfdir=/etc \
             --disable-static \
             --with-gtk-version=2 \
+            --with-qt4-im-module-dir=/usr/lib${LIBDIRSUFFIX}/qt/plugins/inputmethods \
             --program-prefix= \
             --program-suffix= \
             --build=$ARCH-slackware-linux
@@ -123,8 +124,8 @@
   # Let GTK applications like Firefox/Thunderbird use scim as
   # default immodule:
   export GTK_IM_MODULE="scim"
-  ## Enable Qt/KDE applications to use scim (not working with kde4):
-  #export QT_IM_MODULE="scim"
+  ## Enable Qt/KDE applications to use scim:
+  export QT_IM_MODULE="scim"
   # Make scim start automatically if the "magic key" Ctrl-Space is pressed:
   export XIM_PROGRAM="/usr/bin/scim -d"
 fi
@@ -136,21 +137,6 @@
 #  /usr/bin/scim -d
 #fi
 
-# GTK+ environments such as XFce should support SCIM automatically, BUT
-# if the first app you run is a Qt one, you'll run into problems.  This
-# can be avoided by going into Menu -> Settings -> Autostarted Applications
-# and adding SCIM:  /usr/bin/scim -d
-
-# KDE will not start SCIM automatically, so you will need a script such as
-# this one in your $HOME/.kde/Autostart:
-
-#!/bin/bash
-#if [ -x /usr/bin/scim ]; then
-#  /usr/bin/scim -d &
-#fi
-
-# Obviously, uncomment all but the first line.  :-)
-
 EOT
 
 cat <<EOT > $PKG/etc/profile.d/scim.csh.new
 
Old 10-25-2013, 10:42 PM   #2
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
It looks like it's been patched in the ChangeLog:

Code:
Fri Oct 25 22:05:38 UTC 2013
x/scim-1.4.14-x86_64-4.txz:  Rebuilt.
  Put the Qt module in the proper inputmethods directory, and enable the
  plugin in /etc/profile.d/scim.{csh,sh}.  Thanks to guanx.
x/xterm-297-x86_64-1.txz:  Upgraded.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scim-bridge bug which result in text lost, patch available, official apply? grissiom Slackware 2 04-20-2009 08:40 AM
How to make Scim started at boot satimis Ubuntu 1 07-30-2007 05:19 AM
How to make SCIM to work satimis Fedora 24 02-17-2005 09:41 AM
how to make scim look bigger? damienduff Linux - Software 1 10-30-2004 10:53 PM
How to Apply patch for Mass Storage device to work? (uss725-2.4.20-rc2.patch) cevjr Linux - Hardware 3 04-20-2004 11:14 PM


All times are GMT -5. The time now is 09:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration