LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [PATCH] make scim work with qt (http://www.linuxquestions.org/questions/slackware-14/%5Bpatch%5D-make-scim-work-with-qt-4175482102/)

guanx 10-25-2013 06:18 AM

[PATCH] make scim work with qt
 
For slackware 14.1-rc2:
Code:

--- scim.SlackBuild    2013-10-25 12:16:56.261624664 +0200
+++ scim.SlackBuild.new 2013-10-25 12:17:07.161440362 +0200
@@ -95,6 +95,7 @@
            --sysconfdir=/etc \
            --disable-static \
            --with-gtk-version=2 \
+            --with-qt4-im-module-dir=/usr/lib${LIBDIRSUFFIX}/qt/plugins/inputmethods \
            --program-prefix= \
            --program-suffix= \
            --build=$ARCH-slackware-linux
@@ -123,8 +124,8 @@
  # Let GTK applications like Firefox/Thunderbird use scim as
  # default immodule:
  export GTK_IM_MODULE="scim"
-  ## Enable Qt/KDE applications to use scim (not working with kde4):
-  #export QT_IM_MODULE="scim"
+  ## Enable Qt/KDE applications to use scim:
+  export QT_IM_MODULE="scim"
  # Make scim start automatically if the "magic key" Ctrl-Space is pressed:
  export XIM_PROGRAM="/usr/bin/scim -d"
 fi
@@ -136,21 +137,6 @@
 #  /usr/bin/scim -d
 #fi
 
-# GTK+ environments such as XFce should support SCIM automatically, BUT
-# if the first app you run is a Qt one, you'll run into problems.  This
-# can be avoided by going into Menu -> Settings -> Autostarted Applications
-# and adding SCIM:  /usr/bin/scim -d
-
-# KDE will not start SCIM automatically, so you will need a script such as
-# this one in your $HOME/.kde/Autostart:
-
-#!/bin/bash
-#if [ -x /usr/bin/scim ]; then
-#  /usr/bin/scim -d &
-#fi
-
-# Obviously, uncomment all but the first line.  :-)
-
 EOT
 
 cat <<EOT > $PKG/etc/profile.d/scim.csh.new


TommyC7 10-25-2013 11:42 PM

It looks like it's been patched in the ChangeLog:

Code:

Fri Oct 25 22:05:38 UTC 2013
x/scim-1.4.14-x86_64-4.txz:  Rebuilt.
  Put the Qt module in the proper inputmethods directory, and enable the
  plugin in /etc/profile.d/scim.{csh,sh}.  Thanks to guanx.
x/xterm-297-x86_64-1.txz:  Upgraded.



All times are GMT -5. The time now is 09:30 PM.