LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [Kernel Oops - Slackware 14.0] User space mounting (http://www.linuxquestions.org/questions/slackware-14/%5Bkernel-oops-slackware-14-0%5D-user-space-mounting-4175443455/)

alienbat 12-30-2012 07:08 AM

[Kernel Oops - Slackware 14.0] User space mounting
 
I have Slackware 14.0 (3.2.29-smp) installed on a i686 AMD Sempron(tm) Processor 3000+. I use the XFCE 4.10 that comes with the distribution.
I'm getting a kernel Oops in the following situation:
Every time I try to mount a file-system with non-root privileges, for example inserting a usb drive or a cd and opening thunar to browse it.
The same does not happen if i mount the device using root and access the files trough the terminal or mc.

Here is the syslog (hostname is defiant):

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840464] CR2: 00000000f88e0d29

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840342] Stack:

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840362] Call Trace:

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840460] EIP: [<c153194e>] strnlen+0xe/0x20 SS:ESP 0068:f2e45e50

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840339] Process pool (pid: 2583, ti=f2e44000 task=f2ebd140 task.ti=f2e44000)

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840426] Code: 57 3e 8d 74 26 00 85 c9 89 c7 74 07 89 d0 f2 ae 75 01 4f 89 f8 5f 5d c3 90 8d 74 26 00 55 89 e5 3e 8d 74 26 00 89 c1 89 c8 eb 06 <80> 38 00 74 07 40 4a 83 fa ff 75 f4 29 c8 5d c3 90 90 55 89 e5

Message from syslogd@defiant at Sun Dec 30 09:49:52 2012 ...
defiant kernel: [ 1344.840276] Oops: 0000 [#1] SMP

I need help solving this.
If here is not the appropriate place to post this, please PM me telling what exactly is the appropriate place.

Thanks in advance,
Alienbat

malekmustaq 12-31-2012 12:23 AM

Since you are in Xfce4, that is easy to configure, just login as normal user (not root) then:

Click Menu -> Settings -> Removable Drives and Media -> then tick whatever choices you want...

You have choices like 'mount removable media when hotplug', run programs, etc. Also configure Menu -> Settings -> Session and Startup -> under General tab tick 'Automatically Save Sessions at logout' to save your configuration for future logins. Then logout from X and login again as the same user. Check if it works; if not, come back for further help.

Hope that helps.

Good luck.

longus 12-31-2012 01:59 AM

Hi! Here Thunar is not able to mount some kind of removeble devices like my mikroSD kard from my phone. Every other file manager do it without any question. In the same time Thunar mounts my usb memory stick. I dont have a sollution for this.


PS: It's not related to the kernel. It's presented since the upgrade of XFCE.

alienbat 01-07-2013 02:26 PM

Solved
 
Thank you. Marking the options to mount automatically at xfce settings worked, but I am still worried about the kernel Oops. It need to be corrected somehow, doesn't it? I mean, it can be exploited as a security issue.

Thanks.


All times are GMT -5. The time now is 09:04 PM.