LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-17-2013, 05:24 AM   #1
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 63

Rep: Reputation: Disabled
[KDE 4.10.5/4.11.3] wrong timezone in system settings


Hello everybody,

I've noticed the following KDE's behaviour both in stock Slackware 14.1, that is with KDE 4.10.5, and with AlienBob's KDE 4.11.3.

In System Settings -> Date & Time -> Time Zone I can see:
Current local time zone: Europe/Rome (CEST).

In Italy we're currently in CET (winter time) timezone, but there's no way (to my knowledge so far) to get that in KDE.

Some details from the cli:
Code:
root@darkstar:~# date
Sun Nov 17 11:11:01 CET 2013
root@darkstar:~# hwclock
Sun 17 Nov 2013 11:11:05 AM CET  -0.206320 seconds
root@darkstar:~# md5sum /etc/localtime /usr/share/zoneinfo/Europe/Rome 
9828f4466350e4529d97c04e85554430  /etc/localtime
9828f4466350e4529d97c04e85554430  /usr/share/zoneinfo/Europe/Rome
Does this happen to someone else? Is there any open bug report about this, that you know about?

Screenshots attached.

Thanks!
Attached Images
File Type: png snapshot1.png (78.3 KB, 28 views)
File Type: png snapshot2.png (65.2 KB, 23 views)
 
Old 11-18-2013, 11:19 AM   #2
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current, custom kernel, amd64, Beyond LinuxFromScratch
Posts: 130
Blog Entries: 1

Rep: Reputation: Disabled
Central European Time is UTC+1 during the winter and UTC+2 in the summer. The definition for Rome should do that automagically.
Central European Time changes to Central Europe Summer Time, CEST, Sunday 31 March 2013 01:00 GMT, then back to CET Sunday 27 October 2013 01:00 GMT.

The European NTP pool should know that. Put these lines in /etc/ntp.conf:
server 0.europe.pool.ntp.org
server 1.europe.pool.ntp.org
server 2.europe.pool.ntp.org
server 3.europe.pool.ntp.org

I don't know why your system thinks it is still in CEST. Might try deleting /etc/localtime, then copy /usr/share/zoneinfo/Europe/Rome to /etc/localtime. Add a softlink:
`ln -s /usr/share/zoneinfo/Europe/Rome localtime-copied-from` for future reference.

/etc/rc.d/rc.ntpd stop
/usr/sbin/ntpdate 3.europe.pool.ntp.org
/sbin/hwclock --systohc
/etc/rc.d/rc.ntpd start

(all those as root)
 
Old 11-18-2013, 11:26 AM   #3
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 63

Original Poster
Rep: Reputation: Disabled
Hi, thanks for your answer.
Actually, just KDE thinks it's still in CEST: if you look at the CLI commands I included, the rest of the system is fine with the new timezone.
I'm at work now and can't test your suggestions, I will as soon as I can; I really doubt that that's the solution, though.

Thanks again!
 
Old 11-18-2013, 04:04 PM   #4
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 63

Original Poster
Rep: Reputation: Disabled
Filed a bug report to KDE: https://bugs.kde.org/show_bug.cgi?id=327734
 
Old 11-18-2013, 05:04 PM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 147Reputation: 147
Hello, in my system settings the time zone is Berlin and it works fine.
 
Old 11-19-2013, 11:53 AM   #6
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 63

Original Poster
Rep: Reputation: Disabled
I've followed hpfeil's steps to to avail. Still CEST in KDE and CET in the CLI.
@guanx: Berlin gives CEST as well in KDE. Just to know, what do you get if you set Rome?

Thanks!
 
Old 11-19-2013, 12:48 PM   #7
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 147Reputation: 147
Rome also gives UTC+1, same as Berlin.

Did you restart KDE after 27.Oct.2013 ? If not, try restart KDE and see.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The KDE 4.3 System Settings - Part 5 - System LXer Syndicated Linux News 0 02-14-2010 12:00 PM
ntpd sync wrong, timezone is ok zomane Linux - Server 2 09-20-2008 10:13 AM
wrong timezone in system tray mithya Linux - Newbie 1 01-28-2006 02:31 AM
[SOLVED] kde clock's local timezone is wrong arobinson74 Linux - Software 4 12-01-2004 10:54 AM
Gnome Clock 2.6.2 - Wrong timezone dotxp Linux - Software 1 10-06-2004 11:08 AM


All times are GMT -5. The time now is 10:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration