LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-26-2007, 02:49 PM   #1
Hyakutake
Member
 
Registered: Apr 2004
Location: 127.0.0.1
Distribution: Slackware
Posts: 149

Rep: Reputation: 16
[ipw2200 & WPA] Need help to connect to WPA enabled router.


Hello all.

I'm trying to connect to a WPA router wihtout success.

So here's what i've done so far.

I'm using Slack 11 with 2.6.20.1 kernel. Wireless is working fine. It's an Intel PRO Wireless 2200BG.

Code:
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.0k
ipw2200: Copyright(c) 2003-2006 Intel Corporation
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ipw2200: Radio Frequency Kill Switch is On:
ipw2200: Detected geography ZZR (14 802.11bg channels, 0 802.11a channels)
As modules i have this:

Code:
Module                  Size  Used by
i915                   19200  1 
drm                    63132  2 i915
snd_seq_oss            26368  0 
snd_seq_midi_event      5504  1 snd_seq_oss
snd_seq                39280  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          6028  2 snd_seq_oss,snd_seq
snd_pcm_oss            36672  0 
snd_mixer_oss          13440  1 snd_pcm_oss
ide_scsi               12684  0 
pcmcia                 28332  0 
snd_intel8x0           26816  0 
snd_ac97_codec         83748  1 snd_intel8x0
ac97_bus                2048  1 snd_ac97_codec
snd_pcm                60048  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              16904  2 snd_seq,snd_pcm
snd                    38756  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
ipw2200               118496  0 
ieee80211              26952  1 ipw2200
ieee80211_crypt         4352  1 ieee80211
ohci1394               28596  0 
b44                    20752  0 
intel_agp              19612  1 
yenta_socket           22044  1 
rsrc_nonstatic         10252  1 yenta_socket
pcmcia_core            31416  3 pcmcia,yenta_socket,rsrc_nonstatic
snd_page_alloc          7304  2 snd_intel8x0,snd_pcm
agpgart                25648  3 drm,intel_agp

iwlist eth1 scanning gives:
Code:
eth1      Scan completed :
          Cell 01 - Address: 00:0F:3D:B8:A8:C2
                    ESSID:"XXXXXXXXXXXXXXX"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Channel:11
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Quality=51/100  Signal level=-70 dBm  
                    IE: WPA Version 1
                        Group Cipher : TKIP 
                        Pairwise Ciphers (1) : TKIP 
                        Authentication Suites (1) : PSK  
                    Extra: Last beacon: 230ms ago
I've downloaded wpa_supplicant (wpa_supplicant-0.4.9-i486-1) from slackware packages (http://packages.slackware.it/)

I dont know if this is the way to connect but i'm trying this:

Code:
wpa_supplicant -ieth1 -Dipw -c/etc/wpa_supplicant.conf

ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Failed to set encryption.
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Trying to associate with 00:0f:3d:b8:a8:c2 (SSID='XXX' freq=0 MHz)
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Trying to associate with 00:0f:3d:b8:a8:c2 (SSID='XXX' freq=0 MHz)
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Trying to associate with 00:0f:3d:b8:a8:c2 (SSID='XXX' freq=0 MHz)
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
Trying to associate with 00:0f:3d:b8:a8:c2 (SSID='XXX' freq=0 MHz)
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
ioctl[IPW_IOCTL_WPA_SUPPLICANT]: Operation not supported
This is my /etc/wpa_supplicant.conf
Code:
# See /usr/doc/wpa_supplicant-0.4.9/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="XXXXX"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="XXX"
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
# You'll need a recent version of wireless-tools for this!
network={
  ssid="any"
  key_mgmt=NONE
  priority=2	
}
I don't know what to do next. Can someone help me out on this?

Thanks in advance.
 
Old 02-26-2007, 05:04 PM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,292

Rep: Reputation: Disabled
Try
Code:
wpa_supplicant -ieth1 -Dwext -c/etc/wpa_supplicant.conf
The "ipw" driver is no longer used with these recent 2.6 kernels - please use the "wext" driver.

Btw, there was already a wpa_supplicant package waiting for you in the Slackware 11.0 /testing directory of the DVD.

Eric

Edit: ah, I just noticed that in fact you do use that package from /testing

Last edited by Alien Bob; 02-26-2007 at 05:06 PM.
 
Old 03-02-2007, 09:58 AM   #3
Hyakutake
Member
 
Registered: Apr 2004
Location: 127.0.0.1
Distribution: Slackware
Posts: 149

Original Poster
Rep: Reputation: 16
Thanks Alien Bob. It's working now.

Sorry for such a late response but I haven't had the time to test it until today.

Many thanks once more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost with ipw2200 & wpa skubik Linux - Wireless Networking 6 02-24-2006 07:02 AM
wpa problems with ipw2200 inhalentbroom Slackware 1 12-04-2005 12:08 PM
WPA-TKIP ipw2200 havelino Linux - Wireless Networking 0 04-24-2005 10:24 AM
WPA & ipw2200 havelino Linux - Wireless Networking 5 03-26-2005 06:57 PM
Connect to a WPA-encrypted router in Slackware garnser Linux - Wireless Networking 0 08-22-2004 02:12 PM


All times are GMT -5. The time now is 11:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration