LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-17-2011, 05:18 PM   #1
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
[Bug] UTF-8 man pages cannot be viewed


There are a few very important man pages having UTF-8 translations. Those UTF-8 man pages cannot be viewed unless a groff wrapper (http://www.haible.de/bruno/packages-groff-utf8.html) is also installed.

Please either remove those man pages or include that groff-utf8 wrapper in slackware.
[Edit] I believe removing those man pages is better since the translations are often incomplete and inaccurate.

Thanks!

P.S. I've posted this bug long ago but I could not find it now.

Last edited by guanx; 04-17-2011 at 05:22 PM.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 04-17-2011, 06:52 PM   #2
lq2000
LQ Newbie
 
Registered: Apr 2011
Posts: 4

Rep: Reputation: 2
They can be viewed if you set GROFF_ENCODING=UTF-8 and possibly LESSCHARSET=UTF-8.
 
2 members found this post helpful.
Old 04-17-2011, 08:48 PM   #3
grissiom
Member
 
Registered: Apr 2008
Location: China, Beijing
Distribution: Slackware
Posts: 410

Rep: Reputation: 45
Make sure you have updated /usr/lib64/man.conf with /usr/lib64/man.conf.new . Yes, the config is in lib dir and slackpkg could not find it.

(I've submitted a patch for this but Piter didn't reply it... ;( )
 
Old 04-17-2011, 09:31 PM   #4
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
I think thats the reason many other distributions use man-db instead of man nowadays.
I might be wrong though. The reasons are certainly relevant to language/encoding support though.
 
Old 04-19-2011, 02:03 PM   #5
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Original Poster
Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by lq2000 View Post
They can be viewed if you set GROFF_ENCODING=UTF-8 and possibly LESSCHARSET=UTF-8.
Thanks! Setting GROFF_ENCODING=UTF-8 (and optionally LESSCHARSET=UTF-8) can let groff display utf-8 characters. However, the non-english man pages are still ill-formatted.

The groff-utf8 wrapper also shows the itf-8 characters but badly formatted pages.

So at present it may be better to simply not install the utf-8 man pages (from the shadow package, etc.).

---------- Post added 04-20-11 at 03:04 AM ----------

Quote:
Originally Posted by grissiom View Post
Make sure you have updated /usr/lib64/man.conf with /usr/lib64/man.conf.new . Yes, the config is in lib dir and slackpkg could not find it.

(I've submitted a patch for this but Piter didn't reply it... ;( )
I have a fresh install. Man did load the correct config file.
 
Old 04-19-2011, 06:01 PM   #6
lq2000
LQ Newbie
 
Registered: Apr 2011
Posts: 4

Rep: Reputation: 2
European languages seem to be formatted satisfactorily, but not CJK and double width scripts.
 
Old 04-20-2011, 08:31 AM   #7
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 372

Rep: Reputation: 55
Quote:
Originally Posted by guanx View Post
Thanks! Setting GROFF_ENCODING=UTF-8 (and optionally LESSCHARSET=UTF-8) can let groff display utf-8 characters. However, the non-english man pages are still ill-formatted.
Quote:
Originally Posted by lq2000 View Post
European languages seem to be formatted satisfactorily, but not CJK and double width scripts.
http://img821.imageshack.us/img821/6972/uman.jpg

I tried /usr/man/zh_TW/man8/useradd.8.gz and it looks ok to me (if you don't take the ^H in account). Does the format look similar in your case ?
 
Old 04-20-2011, 04:08 PM   #8
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Original Poster
Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by imitheos View Post
http://img821.imageshack.us/img821/6972/uman.jpg

I tried /usr/man/zh_TW/man8/useradd.8.gz and it looks ok to me (if you don't take the ^H in account). Does the format look similar in your case ?
It looks different in konsole. If I use less as pager, the ^H eats up the first character. If pager is most, there is no ^H but in both cases the formatting is wrong.
Attached Images
File Type: png chsh_zh.png (23.3 KB, 30 views)
File Type: png chsh_most.png (31.1 KB, 31 views)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to use man pages babu198649 Linux - Newbie 15 10-12-2007 09:17 AM
man documents, how is it viewed. pranavojha Linux - Newbie 5 03-26-2006 09:31 AM
About Man pages and Bug reports szofiel Linux - Newbie 2 10-29-2005 08:13 PM
What do you mean by MAN pages? inspectreo Linux - Newbie 2 05-08-2005 02:12 PM
can't see man pages Elbolton Linux - Newbie 5 03-06-2002 11:14 PM


All times are GMT -5. The time now is 02:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration