LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-23-2013, 07:34 AM   #1
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 269

Rep: Reputation: 82
[BUG] lftp 4.4.10 too slow


There is some bug on lftp 4.4.10 (slackware64-current).

The transfer rate is too slow when I use that version (sometime < 1kb), specially in function 'mirror' during the retrieve file listing (the single file transfer somtime obtains a good speed).

Is not the adsl problem.
I tried to roll-back to 4.4.9 and I obtain a fastest connection.

We (users of slacky.eu community) found the problem during download alienbob's multilib
# lftp -c 'open http://slackware.com/~alien/multilib/ ; mirror current'
about 45min to give directory content

the same command with lftp 4.4.9: about 2 seconds to get directory content.
 
Old 10-23-2013, 08:34 AM   #2
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 164

Rep: Reputation: 129Reputation: 129
Quote:
Originally Posted by zerouno View Post
There is some bug on lftp 4.4.10 (slackware64-current).

The transfer rate is too slow when I use that version (sometime < 1kb), specially in function 'mirror' during the retrieve file listing (the single file transfer somtime obtains a good speed).

Is not the adsl problem.
I tried to roll-back to 4.4.9 and I obtain a fastest connection.

We (users of slacky.eu community) found the problem during download alienbob's multilib
# lftp -c 'open http://slackware.com/~alien/multilib/ ; mirror current'
about 45min to give directory content

the same command with lftp 4.4.9: about 2 seconds to get directory content.
Not that I know if there is a bug here, but what I'd do is first issue 'deb 9' inside lftp to turn on max debugging.
It could be that the functionality has changed in the newer version, such that it's issuing different FTP commands than the previous one which is adding delay. I would be more descriptive, but it's been ages since I had to debug FTP so I can't recall - but if you do deb 9 on both versions and see a difference in the FTP commands being issued, it might allow you to revert to the previous behaviour.
 
Old 10-23-2013, 08:40 AM   #3
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 269

Original Poster
Rep: Reputation: 82
I will try to debug. However I tested lftp with http protocol only.

lftp -c 'open http://slackware.com/~alien/multilib/ ; mirror current'
 
Old 10-23-2013, 12:08 PM   #4
TommyC7
Member
 
Registered: Mar 2012
Distribution: Slackware, CentOS, OpenBSD, FreeBSD
Posts: 438

Rep: Reputation: Disabled
Have you tried using lftp for anything else other than alien's multilib packages?

If you could, can you also do:

Code:
echo "debug" >> ~/.lftprc
And then give us the output when you attempt to use lftp? It should help out a bit.
 
Old 10-23-2013, 03:11 PM   #5
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 269

Original Poster
Rep: Reputation: 82
es, I tried with other sites, with the same result.

The ftp protocol have not problems.

In debug mode I can notice the high latency (but the debug mode does not show time of request) and a large number of disconnections for timeout.
Now I've not the pc, so I can't post output, but that output isn't really significant becouse lftp 4.4.9 generate exactly the same (that is the http header of all requests)
 
Old 10-23-2013, 05:24 PM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,577

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
i can confirm that this bug is reproduceable, even though i can't find any git commits that are relevant to this regression. I have tested to revert some of their commits, but still it has the same effect.
 
Old 10-23-2013, 05:33 PM   #7
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware
Posts: 485

Rep: Reputation: Disabled
Here is a debug output from lftp 4.4.10, while I was trying to mirror Alien Bob's openjdk build. Note the "**** Hit EOF while fetching headers". I've reverted back to 4.4.9.

Code:
---- Resolving host address...
---- 1 address found: 98.158.153.254                   
---- Connecting to taper.alienbase.nl (98.158.153.254) port 80
---- Sending request...                                                                   
---> HEAD /mirrors/people/alien/slackbuilds/openjdk/ HTTP/1.1
---> Host: taper.alienbase.nl
---> User-Agent: lftp/4.4.10
---> Accept: */*
---> Connection: keep-alive
---> 
<--- HTTP/1.1 200 OK                                                                                
<--- Date: Wed, 23 Oct 2013 01:37:34 GMT
<--- Server: Apache/2.2.24 (Unix) DAV/2 PHP/5.3.23
<--- Keep-Alive: timeout=5, max=100
<--- Connection: Keep-Alive
<--- Content-Type: text/html;charset=ISO-8859-1
<--- 
---- Sending request...
---> HEAD /mirrors/people/alien/slackbuilds/openjdk/build/ HTTP/1.1
---> Host: taper.alienbase.nl
---> User-Agent: lftp/4.4.10
---> Accept: */*
---> Connection: keep-alive
---> 
<--- HTTP/1.1 200 OK                  
<--- Date: Wed, 23 Oct 2013 01:37:34 GMT
<--- Server: Apache/2.2.24 (Unix) DAV/2 PHP/5.3.23
<--- Keep-Alive: timeout=5, max=99
<--- Connection: Keep-Alive
<--- Content-Type: text/html;charset=ISO-8859-1
<--- 
---- Closing HTTP connection
---- Connecting to taper.alienbase.nl (98.158.153.254) port 80
---- Sending request...                         
---> GET /mirrors/people/alien/slackbuilds/openjdk/build/ HTTP/1.1
---> Host: taper.alienbase.nl
---> User-Agent: lftp/4.4.10
---> Accept: */*
---> Pragma: no-cache
---> Cache-Control: no-cache
---> Connection: keep-alive
---> 
<--- HTTP/1.1 200 OK                                      
<--- Date: Wed, 23 Oct 2013 01:37:34 GMT
<--- Server: Apache/2.2.24 (Unix) DAV/2 PHP/5.3.23
<--- Content-Length: 3290
<--- Keep-Alive: timeout=5, max=100
<--- Connection: Keep-Alive
<--- Content-Type: text/html;charset=ISO-8859-1
<--- 
---- Receiving body...
---- Received all
---> HEAD /mirrors/people/alien/slackbuilds/openjdk/build/../ HTTP/1.1
---> Host: taper.alienbase.nl
---> User-Agent: lftp/4.4.10
---> Accept: */*
---> Connection: keep-alive
---> 
<--- HTTP/1.1 200 OK                                      
<--- Date: Wed, 23 Oct 2013 01:37:34 GMT
<--- Server: Apache/2.2.24 (Unix) DAV/2 PHP/5.3.23
<--- Keep-Alive: timeout=5, max=99
<--- Connection: Keep-Alive
<--- Content-Type: text/html;charset=ISO-8859-1
<--- 
**** Hit EOF while fetching headers                       
---- Closing HTTP connection
Getting files information (7%) [Delaying before reconnect: 22]
 
Old 10-23-2013, 09:10 PM   #8
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
Looks like Pat has reverted back to 4.4.9 as well in the ChangeLog.txt.
 
1 members found this post helpful.
Old 10-24-2013, 12:48 AM   #9
hba
LQ Newbie
 
Registered: May 2012
Location: Oaxaca, México
Distribution: Slackware Linux
Posts: 18

Rep: Reputation: Disabled
I was getting the same message "Delaying before reconnect", but i solved it with echoing 'set net:reconnect-interval-base 0' to ~/.lftprc

https://github.com/nihilismus/bob-in...bob-sources.sh
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to file bug-free bug report in KDE LXer Syndicated Linux News 0 04-06-2013 09:03 PM
regarding lftp santhosh-e Linux - Software 3 01-03-2012 09:22 AM
lftp mikeshn Linux - Software 11 07-20-2011 12:44 PM
Bug#314905 bug fix for Ubuntu and gcc is 4.4.1 bostan Linux - General 1 12-11-2010 12:35 PM
LXer: 2008 CES: Bug Labs Introduces BUG, BUGbase. So Cool! LXer Syndicated Linux News 0 01-09-2008 01:21 AM


All times are GMT -5. The time now is 03:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration