LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-28-2012, 07:57 PM   #1
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
[Bug] hplip missing cups_ppd_install


The slackbuild script for hplip has the "--enable-cups-ppd-install" configure option missing. Quite some nice printers don't work without this.

Can this be fixed in the next build? Thanks!
 
Old 11-29-2012, 10:55 PM   #2
ReaperX7
Senior Member
 
Registered: Jul 2011
Location: California
Distribution: LFS-7.6, Slackware 14.1, FreeBSD 10.1
Posts: 3,623
Blog Entries: 15

Rep: Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094Reputation: 1094
You can always edit the SlackBuild script and rebuild the package yourself with the option enabled.
 
Old 11-30-2012, 11:27 AM   #3
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Original Poster
Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by ReaperX7 View Post
You can always edit the SlackBuild script and rebuild the package yourself with the option enabled.
That's what I did. I only wonder if there is a reason to not enabling this, e.g. because of license problems or experimental code, etc..
 
Old 01-28-2013, 06:32 PM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Original Poster
Rep: Reputation: 146Reputation: 146
Bump because hplip is upgraded and "--enable-cups-ppd-install" is still missing.
 
Old 02-06-2013, 10:10 AM   #5
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,593

Rep: Reputation: 434Reputation: 434Reputation: 434Reputation: 434Reputation: 434
Now the problems should be solved
Code:
ap/hplip-3.12.11-i486-2.txz
       Recompiled with --enable-cups-ppd-install. Thanks to guanx.
 
Old 02-06-2013, 12:39 PM   #6
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Original Poster
Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by willysr View Post
Now the problems should be solved
Code:
ap/hplip-3.12.11-i486-2.txz
       Recompiled with --enable-cups-ppd-install. Thanks to guanx.
Thank you, willysr! This makes using several Officejet printer/all-in-one devices easier.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HPlip woes on --current ; Sharing printer gets broken if the hplip gui is launched Old_Fogie Slackware 2 10-28-2010 11:23 AM
hplip 3.9.2 missing DeskJet printer ppd's (-current) the3dfxdude Slackware 4 03-22-2009 03:47 PM
Missing dependency & Hplip Mulligun Slackware 4 09-06-2007 04:00 AM
Missing dependency & Hplip Mulligun Linux - Hardware 2 09-06-2007 02:31 AM


All times are GMT -5. The time now is 07:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration