LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-12-2010, 06:46 AM   #1
el_jauzaa
Member
 
Registered: Jun 2010
Location: indonesia
Distribution: Slackware 14.1
Posts: 101

Rep: Reputation: 17
Unhappy [ASK]enabling compiz in slackware 13.1


hi slackware users !

i have a problem with my slack box.
i want an eye candy desktop (actually i didn't need this, but i want to show my friends that linux distro eye candy desktop can beat windows).

I'm using KDE desktop effect, but i didn't satisfy with this, cause i have been test compiz in my PC (using ubuntu), the effects is more smooth than KDE desktop effect.

my Xorg config is using vesa (i didn't know that linux kernel didn't have my 'Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)' driver. How do i enable the driver? (cause in ubuntu, works like a charms)

in my slack box compiz version : compiz-0.8.6-i486-1

how do i enable compiz (cause i want to use XFCE + compiz too)

please enlighten me...

 
Old 06-12-2010, 09:05 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,577
Blog Entries: 3

Rep: Reputation: 218Reputation: 218Reputation: 218
make it simple insatll sbopkg. or go to slackbuild.org the then install all the compiz-fusion stuff and dependencies. then install fusion icon so you can go back and forth.
Sbopkg is good stuff.
 
Old 06-12-2010, 09:20 PM   #3
el_jauzaa
Member
 
Registered: Jun 2010
Location: indonesia
Distribution: Slackware 14.1
Posts: 101

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Drakeo View Post
make it simple insatll sbopkg.
or go to slackbuild.org the
then install all the compiz-fusion stuff and dependencies. then install fusion icon so you can go back and forth.
Sbopkg is good stuff.
in slackbuild there isn't compiz* package for 13.1?
 
Old 06-12-2010, 10:55 PM   #4
veeall
Member
 
Registered: May 2007
Location: Estonia
Distribution: Slackware 12.1, slackware64-current
Posts: 255

Rep: Reputation: 43
And lately there were no compiz-fusion releases for compiz 0.8.6 released. Latest were of version 0.8.4 so best bet is to recompile stock compiz also. http://releases.compiz-fusion.org/0.8.4/

Build order is important:
Code:
 
compiz 
bcop 
libcompizconfig 
compizconfig-python 
ccsm 
compiz-fusion-plugins-main
everything else
There should also be links to slackbuilds lying around in slackware LQ somewhere or use src2pkg. Hopefully all builds well, i remember having installed ccsm using its install script, because package creation with slackbuild and src2pkg failed and i'm no pro, but i am on an another computer now so cannot check.

For autostart read this from arch wiki. Though personally xfce4-session.xml bit confused me a bit. For example how to pass extra options like '--something-technical' into compiz launch.

I never had any intel graphics, so cannot help on configuring xorg.conf. Here's a compiz wiki entry, which, though, may be outdated.
 
1 members found this post helpful.
Old 06-13-2010, 03:56 AM   #5
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
Quote:
Originally Posted by el_jauzaa View Post
in slackbuild there isn't compiz* package for 13.1?
I'm working on them as we speak, should be ready to submit tomorrow.
 
1 members found this post helpful.
Old 06-13-2010, 06:21 AM   #6
el_jauzaa
Member
 
Registered: Jun 2010
Location: indonesia
Distribution: Slackware 14.1
Posts: 101

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by Daedra View Post
I'm working on them as we speak, should be ready to submit tomorrow.
thx...i can't hardly wait...

 
Old 06-13-2010, 09:44 PM   #7
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
We'll I finished and submitted them, Hopefully they'll be approved and released soon
 
Old 06-18-2010, 12:35 AM   #8
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,577
Blog Entries: 3

Rep: Reputation: 218Reputation: 218Reputation: 218
Well I built it with my xfce4 slackware13.1. As usual there was no borders this is a very old problem I worked on 3 years ago but for the life of me no fix so far.
I am not drawing conclusion this only happens with the none kde install. I understand the Xorg well with the nvidia settings but no borders it was like that with the last build and I just did not want to go back three years and start over for xfce4 and nvidia.
Anyway the build works but borders and dragging is not going to work with the 9400 nvidia card Amd64 with xfce4 This has been a issue that has been resolved and returns all the time. Oh well.
Because My heart just isn't in it to go through the new xorg rendering and composite stuff again with NVIDIA.
It works fine on all the other Slackware full installs and the other distro's.
this is just input for others out there.
theses do not help.
Quote:
Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Etc etc etc
 
Old 06-18-2010, 12:59 AM   #9
BILLYKANE
Member
 
Registered: Feb 2008
Location: Hefei,Anhui,China
Distribution: Slackware;chakra
Posts: 96

Rep: Reputation: 22
Quote:
Originally Posted by Drakeo View Post
Well I built it with my xfce4 slackware13.1. As usual there was no borders this is a very old problem I worked on 3 years ago but for the life of me no fix so far.
I am not drawing conclusion this only happens with the none kde install. I understand the Xorg well with the nvidia settings but no borders it was like that with the last build and I just did not want to go back three years and start over for xfce4 and nvidia.
Anyway the build works but borders and dragging is not going to work with the 9400 nvidia card Amd64 with xfce4 This has been a issue that has been resolved and returns all the time. Oh well.
Because My heart just isn't in it to go through the new xorg rendering and composite stuff again with NVIDIA.
It works fine on all the other Slackware full installs and the other distro's.
this is just input for others out there.
theses do not help.
With my ATI hd 4570 card, there was no borders yet.here is my xorg.conf:

Code:
Section "Extensions"
    Option "Composite" "Enable"
EndSection


Section "ServerLayout"

	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Mouse1" "CorePointer"
	InputDevice    "Keyboard1" "CoreKeyboard"
        Option "AIGLX" "True"
EndSection

Section "Files"

	RgbPath      "/usr/share/X11/rgb"
	FontPath     "/usr/share/fonts/local/"
	FontPath     "/usr/share/fonts/misc/"
	FontPath     "/usr/share/fonts/OTF/"
	FontPath     "/usr/share/fonts/TTF/"
	FontPath     "/usr/share/fonts/Type1/"
	FontPath     "/usr/share/fonts/CID/"
	FontPath     "/usr/share/fonts/Speedo/"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/75dpi/"
	FontPath     "/usr/share/fonts/100dpi/"
	FontPath     "/usr/share/fonts/cyrillic/"
EndSection

Section "Module"

	Load  "dbe"  	
	SubSection "extmod"
	Option	    "omit xfree86-dga"   
	EndSubSection
	Load  "type1"
	Load  "freetype"
	Load  "glx"
EndSection

Section "InputDevice"

	Identifier  "Keyboard1"
	Driver      "kbd"
EndSection

Section "InputDevice"

	Identifier  "Mouse1"
	Driver      "mouse"
	Option	    "Protocol" "PS/2"
	Option	    "Device" "/dev/mouse"

EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
    Option "MigrationHeuristic" "greedy"
    Option "AccelMethod" "exa"
    Option "ExaNoComposite" "false"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	Option	    "RenderAccel" "true"
	Option	    "AddARGBGLXVisuals" "true"
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
 
Old 06-18-2010, 01:02 AM   #10
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
did you enable "window decorations" under ccsm?

Also I had a problem with KDE crashing if using KDE-Window decorator. Recompiling and installing compiz fixed the problem for me. I made a note of that to the slackbuilds team. But that could be just be my machine.

Last edited by Daedra; 06-18-2010 at 01:11 AM.
 
Old 06-18-2010, 02:26 AM   #11
veeall
Member
 
Registered: May 2007
Location: Estonia
Distribution: Slackware 12.1, slackware64-current
Posts: 255

Rep: Reputation: 43
I compiled and installed these packages in salix 13.1 with radeon open-source (radeon 9550 card) drivers and everything worked fine when launched through 'fusion-icon', even without xorg.conf, with emerald windeco and slackwares stock compiz. On Athlon XP 1800+ with xfce4 it flies. Thanks a bunch!

Last edited by veeall; 06-18-2010 at 02:38 AM.
 
Old 06-18-2010, 03:50 AM   #12
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
Also with the border, if it fails or crashes or no border appears try using the "emerald" window decorator. You can easily switch between it and kde using "fusion-icon"
 
Old 06-18-2010, 04:36 AM   #13
el_jauzaa
Member
 
Registered: Jun 2010
Location: indonesia
Distribution: Slackware 14.1
Posts: 101

Original Poster
Rep: Reputation: 17
thx daedra...for your slackbuild script..now i can use compiz!
 
Old 01-06-2013, 11:09 AM   #14
dan_san_1
LQ Newbie
 
Registered: Jan 2013
Posts: 3

Rep: Reputation: Disabled
Slackware already comes with compiz installed.
To enable compiz you don't need to install anything, you just need to execute this commands:
LIBGL_ALWAYS_INDIRECT=TRUE
/usr/bin/compiz --replace png svg decoration annotate water blur clone wobbly fade minimize cube rotate zoom scale move resize place switcher &
/usr/bin/kde-window-decorator --replace &

and there you have compiz! To disable compiz you just need this command
kwin --replace &

Now you can enable and disable compiz whenever you want!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Desktop icons tiny after enabling 3d effects (compiz) Mompy Linux - Newbie 2 04-08-2010 05:14 AM
F10 nVidia Driver installation and Enabling Compiz peeths003 Fedora 0 12-02-2008 05:34 AM
compiz not enabling love_ghost Fedora 1 07-27-2008 07:15 AM
6.06 enabling compiz fusion spagoti13 Ubuntu 8 03-28-2008 07:10 AM
Enabling Compiz Fusion in Mandriva 2008 satyakb Mandriva 3 12-03-2007 12:15 AM


All times are GMT -5. The time now is 07:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration