LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [ASK]enabling compiz in slackware 13.1 (http://www.linuxquestions.org/questions/slackware-14/%5Bask%5Denabling-compiz-in-slackware-13-1-a-813708/)

el_jauzaa 06-12-2010 07:46 AM

[ASK]enabling compiz in slackware 13.1
 
hi slackware users !

i have a problem with my slack box.
i want an eye candy desktop (actually i didn't need this, but i want to show my friends that linux distro eye candy desktop can beat windows).

I'm using KDE desktop effect, but i didn't satisfy with this, cause i have been test compiz in my PC (using ubuntu), the effects is more smooth than KDE desktop effect.

my Xorg config is using vesa (i didn't know that linux kernel didn't have my 'Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)' driver. How do i enable the driver? (cause in ubuntu, works like a charms)

in my slack box compiz version : compiz-0.8.6-i486-1

how do i enable compiz (cause i want to use XFCE + compiz too)

please enlighten me...

:)

Drakeo 06-12-2010 10:05 AM

make it simple insatll sbopkg. or go to slackbuild.org the then install all the compiz-fusion stuff and dependencies. then install fusion icon so you can go back and forth.
Sbopkg is good stuff.

el_jauzaa 06-12-2010 10:20 PM

Quote:

Originally Posted by Drakeo (Post 4001150)
make it simple insatll sbopkg.
or go to slackbuild.org the
then install all the compiz-fusion stuff and dependencies. then install fusion icon so you can go back and forth.
Sbopkg is good stuff.

in slackbuild there isn't compiz* package for 13.1?

veeall 06-12-2010 11:55 PM

And lately there were no compiz-fusion releases for compiz 0.8.6 released. Latest were of version 0.8.4 so best bet is to recompile stock compiz also. http://releases.compiz-fusion.org/0.8.4/

Build order is important:
Code:


compiz
bcop
libcompizconfig
compizconfig-python
ccsm
compiz-fusion-plugins-main
everything else

There should also be links to slackbuilds lying around in slackware LQ somewhere or use src2pkg. Hopefully all builds well, i remember having installed ccsm using its install script, because package creation with slackbuild and src2pkg failed and i'm no pro, but i am on an another computer now so cannot check.

For autostart read this from arch wiki. Though personally xfce4-session.xml bit confused me a bit. For example how to pass extra options like '--something-technical' into compiz launch.

I never had any intel graphics, so cannot help on configuring xorg.conf. Here's a compiz wiki entry, which, though, may be outdated.

Daedra 06-13-2010 04:56 AM

Quote:

Originally Posted by el_jauzaa (Post 4001674)
in slackbuild there isn't compiz* package for 13.1?

I'm working on them as we speak, should be ready to submit tomorrow.

el_jauzaa 06-13-2010 07:21 AM

Quote:

Originally Posted by Daedra (Post 4001863)
I'm working on them as we speak, should be ready to submit tomorrow.

thx...i can't hardly wait...

:)

Daedra 06-13-2010 10:44 PM

We'll I finished and submitted them, Hopefully they'll be approved and released soon :)

Drakeo 06-18-2010 01:35 AM

Well I built it with my xfce4 slackware13.1. As usual there was no borders this is a very old problem I worked on 3 years ago but for the life of me no fix so far.
I am not drawing conclusion this only happens with the none kde install. I understand the Xorg well with the nvidia settings but no borders it was like that with the last build and I just did not want to go back three years and start over for xfce4 and nvidia.
Anyway the build works but borders and dragging is not going to work with the 9400 nvidia card Amd64 with xfce4 This has been a issue that has been resolved and returns all the time. Oh well.
Because My heart just isn't in it to go through the new xorg rendering and composite stuff again with NVIDIA.
It works fine on all the other Slackware full installs and the other distro's.
this is just input for others out there.
theses do not help.
Quote:

Option "AddARGBGLXVisuals" "True"
Option "RenderAccel" "True"
Etc etc etc

BILLYKANE 06-18-2010 01:59 AM

Quote:

Originally Posted by Drakeo (Post 4007176)
Well I built it with my xfce4 slackware13.1. As usual there was no borders this is a very old problem I worked on 3 years ago but for the life of me no fix so far.
I am not drawing conclusion this only happens with the none kde install. I understand the Xorg well with the nvidia settings but no borders it was like that with the last build and I just did not want to go back three years and start over for xfce4 and nvidia.
Anyway the build works but borders and dragging is not going to work with the 9400 nvidia card Amd64 with xfce4 This has been a issue that has been resolved and returns all the time. Oh well.
Because My heart just isn't in it to go through the new xorg rendering and composite stuff again with NVIDIA.
It works fine on all the other Slackware full installs and the other distro's.
this is just input for others out there.
theses do not help.

With my ATI hd 4570 card, there was no borders yet.here is my xorg.conf:

Code:

Section "Extensions"
    Option "Composite" "Enable"
EndSection


Section "ServerLayout"

        Identifier    "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
        InputDevice    "Mouse1" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
        Option "AIGLX" "True"
EndSection

Section "Files"

        RgbPath      "/usr/share/X11/rgb"
        FontPath    "/usr/share/fonts/local/"
        FontPath    "/usr/share/fonts/misc/"
        FontPath    "/usr/share/fonts/OTF/"
        FontPath    "/usr/share/fonts/TTF/"
        FontPath    "/usr/share/fonts/Type1/"
        FontPath    "/usr/share/fonts/CID/"
        FontPath    "/usr/share/fonts/Speedo/"
        FontPath    "/usr/share/fonts/75dpi/:unscaled"
        FontPath    "/usr/share/fonts/100dpi/:unscaled"
        FontPath    "/usr/share/fonts/75dpi/"
        FontPath    "/usr/share/fonts/100dpi/"
        FontPath    "/usr/share/fonts/cyrillic/"
EndSection

Section "Module"

        Load  "dbe"         
        SubSection "extmod"
        Option            "omit xfree86-dga" 
        EndSubSection
        Load  "type1"
        Load  "freetype"
        Load  "glx"
EndSection

Section "InputDevice"

        Identifier  "Keyboard1"
        Driver      "kbd"
EndSection

Section "InputDevice"

        Identifier  "Mouse1"
        Driver      "mouse"
        Option            "Protocol" "PS/2"
        Option            "Device" "/dev/mouse"

EndSection

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID      "PCI:1:0:0"
    Option "MigrationHeuristic" "greedy"
    Option "AccelMethod" "exa"
    Option "ExaNoComposite" "false"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth    24
        Option            "RenderAccel" "true"
        Option            "AddARGBGLXVisuals" "true"
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection


Daedra 06-18-2010 02:02 AM

did you enable "window decorations" under ccsm?

Also I had a problem with KDE crashing if using KDE-Window decorator. Recompiling and installing compiz fixed the problem for me. I made a note of that to the slackbuilds team. But that could be just be my machine.

veeall 06-18-2010 03:26 AM

I compiled and installed these packages in salix 13.1 with radeon open-source (radeon 9550 card) drivers and everything worked fine when launched through 'fusion-icon', even without xorg.conf, with emerald windeco and slackwares stock compiz. On Athlon XP 1800+ with xfce4 it flies. Thanks a bunch!

Daedra 06-18-2010 04:50 AM

Also with the border, if it fails or crashes or no border appears try using the "emerald" window decorator. You can easily switch between it and kde using "fusion-icon"

el_jauzaa 06-18-2010 05:36 AM

thx daedra...for your slackbuild script..now i can use compiz!

dan_san_1 01-06-2013 12:09 PM

Slackware already comes with compiz installed.
To enable compiz you don't need to install anything, you just need to execute this commands:
LIBGL_ALWAYS_INDIRECT=TRUE
/usr/bin/compiz --replace png svg decoration annotate water blur clone wobbly fade minimize cube rotate zoom scale move resize place switcher &
/usr/bin/kde-window-decorator --replace &

and there you have compiz! To disable compiz you just need this command
kwin --replace &

Now you can enable and disable compiz whenever you want!


All times are GMT -5. The time now is 07:52 AM.