LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   [13.1-x86_64] alien-multilib enabled : VirtualBox OSE : LIBDIRSUFFIX="???" (http://www.linuxquestions.org/questions/slackware-14/%5B13-1-x86_64%5D-alien-multilib-enabled-virtualbox-ose-libdirsuffix%3D-815924/)

linuxs64 06-23-2010 09:42 AM

[13.1-x86_64] alien-multilib enabled : VirtualBox OSE : LIBDIRSUFFIX="???"
 
I've got multilib enabled as per alien's wiki, now I want to compile VirtualBox OSE using SBo's script. What should be the value for LIBDIRSUFFIX=""?

Do I remove the "64"? Thanks.

Code:

You will be able to use standard SlackBuilds to build 32-bit packages for
Slackware64.  There are two things to keep in mind:
(1) You will have to define the ARCH variable as 'x86_64' even though you
    are compiling a 32-bit program!
(2) You will have to edit the SlackBuild and if it wants to use 'lib64/'
    directories for "$ARCH = x86_64", you will have to force it to use 'lib/'
    directories instead.  Usually, this is accomplished by finding a definition
    like:
      LIBDIRSUFFIX="64"
    and change this line to
      LIBDIRSUFFIX=""


hkothari 06-23-2010 12:54 PM

Yes, I believe that is the case, your libdirsuffix should be blank.

Martinezio 06-24-2010 02:35 AM

But I don't think so. If You blank LIBDIRSUFFIX variable, all compiled libraries goes to /usr/lib directory, which under Slackware64 is intended for 32-bit libraries. Maybe it will work, but You may have some troubles with upgrade or compatibility.

My advice: leave this variable intact - all 64-bit libraries in Slackware64 (no mather if multilib is enabled or disabled) should go to /usr/lib64 directory.

But if You need to compile V-box as 32-bit, change the ARCH variable instead and run 32-bit env setting script from Alien before You start compilation process.


All times are GMT -5. The time now is 03:32 AM.