LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-06-2003, 04:57 PM   #1
abs
Member
 
Registered: Oct 2003
Posts: 203

Rep: Reputation: 30
'startx' command unavailable to normal users


hi
i managed to do a reasonably decent X setup with xf86config. got the res, etc. that i wanted. did that as root. 'startx &' worked.

i created a user and when i tried sta[TAB], all i got was startxfce, which didn't work anywat coz it couldn't find xinit. any reason why i can't startx for normal users? or is that expected behaviour?

ty
 
Old 11-06-2003, 06:57 PM   #2
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
That is not normal... how did you create your user account? You should use the adduser script, it will make you have less headaches.
 
Old 11-07-2003, 02:06 PM   #3
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
i used useradd (the one which asks the series of questions...forgot whether it was useradd or adduser. i think it was useradd.

and while i'm on the subject, which file do i need to copy from /etc to get the dir colours and aliases that root has? i copied DIR-COLORS but didn't know quite what to do with it. i guess if i put a .xsession in /etc/skel, that'll handle the default wm's but what else?

ty

(and is there a way to extend the inactive timeout thing?...for the forum)
 
Old 11-07-2003, 08:48 PM   #4
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Quote:
Originally posted by abs
and while i'm on the subject, which file do i need to copy from /etc to get the dir colours and aliases that root has?
This is handled by the /etc/profile file... check it out. On all my Slack installations (and there are tens of em), users always have dircolors. I think there might be a profile sourcing problem with your user accounts, or that there's something in your skel dir that's overriding the default profile.

Maybe you can try clearing all things in your /etc/skel dir except for the .screenrc file. And then try to create another user.

(I never have timeout issues with the forum, I'm the only user of this PC so I let it remember my login permanently)
 
Old 11-08-2003, 01:55 AM   #5
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
this is what's in my /etc/profile:
gtk+.csh
gtk+.sh
htdig.csh
htdig.sh
j2sdk.csh
j2sdk.sh
lang.csh
lang.sh
mc.csh
mc.sh
metacity.csh
metacity.sh
t1lib.csh
t1lib.sh

/etc/skel was already empty

wrt to users, other than their home dir and /etc/passwd (and shadow) are there any other places where a users info pr details are stored?
 
Old 02-08-2004, 09:37 PM   #6
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
ok, this time i'm sure i did it right. did 'adduser'. added a non-root. but startx aint available to it. now when i press 'star'[TAB], i get 'startxfce4'. that's it.

i don't wanna keep using X as root. pls help.

ty
abs
 
Old 02-13-2004, 09:06 PM   #7
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
although it's still unavailable to normal users (maybe that's how it was meant to be), if i start at runlevel 4, normal users can log in.

can someone confirm if this is the only way normal users have access to X?
 
Old 02-14-2004, 01:15 AM   #8
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
abs, no, it is NOT the only way normal uses have access to X.

And your /etc/profile looks wrong as well.

Are you sure you're even using Slackware?

--Shade
 
Old 02-14-2004, 04:47 AM   #9
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
lol, quite sure. slack 9.1.

and woah, i must've been real sleepy when i posted those contents. that was of /etc/profile.d/ and not /etc/profile. the latter has stuff like
Code:
# /etc/profile: This file contains system-wide defaults used by
# all Bourne (and related) shells.

# Set the values for some environment variables:
export MINICOM="-c on"
export MANPATH=/usr/local/man:/usr/man:/usr/X11R6/man
export HOSTNAME="`cat /etc/HOSTNAME`"
export LESSOPEN="|lesspipe.sh %s"
export LESS="-M"
...
what else should i check up on? (for startx)

ps: /etc/skel/ has a .screenrc in it (only) since i'd mentioned it was empty in post #5

Last edited by abs; 02-14-2004 at 04:52 AM.
 
Old 02-14-2004, 12:39 PM   #10
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Basically, you just want to ensure that startx is in the users' path.

Code:
/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games:/opt/www/htdig/bin:/usr/lib/java/bin:/usr/lib/java/jre/bin:/opt/kde/bin:/usr/lib/qt-3.2.3/bin:.
That's the full path of one of my users.
Find out your path with the command

echo $PATH

/usr/X11R6/bin is the ticket

--Shade
 
Old 02-14-2004, 06:54 PM   #11
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
it's already there in the path.
Code:
# Set the default system $PATH:
PATH="/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games"
that's a line in /etc/profile. what else could be wrong?
 
Old 02-14-2004, 08:52 PM   #12
Douwe
Member
 
Registered: Jun 2002
Location: the Netherlands
Distribution: Slackware, Zenwalk
Posts: 38

Rep: Reputation: 15
You can choose with the script xwmconfig (it is in /usr/X11R6/bin in Slackware 9.1, forgot the place of previous Slackware versions) which (installed :-) WindowManager to start with the startx command. Run it, highlight your WM (with up-down arrow),choose that WM with the Space Bar and give return.
Now issue startx and the chosen WM will be started in X. Some hidden dirs should be present in the users home-dir. Read the xwmconfig bash-script about that. It is not very difficult. And you can modify it to add a downloaded WM you want to try. (e.g. ratpoison). Be aware that xwmconfig is specific for the Slackware distro.
 
Old 02-14-2004, 09:11 PM   #13
skog
Member
 
Registered: Sep 2003
Location: TX
Distribution: slackware
Posts: 301

Rep: Reputation: 30
you might try /usr/X11R6/bin/startx ... that will remove the path from the problem and let you know if it is a path problem or a permission problem.
 
Old 02-14-2004, 10:52 PM   #14
abs
Member
 
Registered: Oct 2003
Posts: 203

Original Poster
Rep: Reputation: 30
arrggh!!! i have no idea what's going on with my system.

when i did '$ /usr/X11R6/bin/startx' (as u said) it was available to normal users.

then i did '$ echo $PATH' and '/usr/X11R6/bin/' was part of it.

i was wondering what else could be causing the problem since the path and the whole command were available to the normal user. then i tried doing '$ start[TAB]' and it worked! it gave 'startx' as an option. i got the X is already running message...coz this session was on. so i know i works now.

i haven't changed anything! dunno how or why it's working now. i am glad it is but if it should happen again, i won't know how to fix it. i'll probably just post here, again!

anyways, thanks a ton skog and Shade.

@Douwe: choosing a window manager is not the problem. 'startx' itself was not available for normal users. fixed now though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with normal users SabaumLinux Linux - Software 5 02-15-2005 02:18 AM
startx does not load when logged in as a normal user? xunzi Linux - Newbie 0 06-29-2004 09:37 AM
Permission for normal users Vizy Linux - General 1 03-16-2004 12:39 PM
Traceroute command unavailable to users (Suse 9.0) m15a4 Linux - General 2 11-23-2003 06:03 AM
command unavailable for root? okok Linux - General 1 02-14-2002 09:19 AM


All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration