LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-22-2007, 01:03 PM   #1
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Rep: Reputation: 15
'route' versus 'inet_route': Slackware-12.0


With the firmware in the proper directory, the wireless card comes up on eth1. However, while there is a localnet route for eth1 in the routing table, there is no default route for that interface, and the network is unreachable.

When I enter (as root) 'route add -net default netmask 0.0.0.0 Gw 192.168.55.4 eth1' I see a usage report that directs me to use 'inet_route ...'. However, I don't have that on the system. There is /sbin/route, but no inet_route.

What have I missed?

Rich
 
Old 10-22-2007, 01:42 PM   #2
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 504

Rep: Reputation: Disabled
You should post the exact error message. Also, while we're at it, can you try "route add default gw 192.168.55.4", please?
 
Old 10-22-2007, 01:57 PM   #3
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rg3 View Post
You should post the exact error message. Also, while we're at it, can you try "route add default gw 192.168.55.4", please?
Exact error message:

[root@lemna ~]# route add -net default netmask 0.0.0.0 Gw 192.168.55.4 eth1
Usage: inet_route [-vF] del {-host|-net} Target[/prefix] [gw Gw] [metric M] [[dev] If]
inet_route [-vF] add {-host|-net} Target[/prefix] [gw Gw] [metric M]
[netmask N] [mss Mss] [window W] [irtt I]
[mod] [dyn] [reinstate] [[dev] If]
inet_route [-vF] add {-host|-net} Target[/prefix] [metric M] reject
inet_route [-FC] flush NOT supported

Here are the routing tables:
[root@lemna ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.192 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default router1.appl-ec 0.0.0.0 UG 1 0 0 eth0

On wireless connection (eth1):

[root@lemna ~]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.192 U 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth1
loopback * 255.0.0.0 U 0 0 0 lo
default router1.appl-ec 0.0.0.0 UG 1 0 0 eth0

When I ran 'route add default Gw 192.168.55.4' a second default for eth0 was added. When I re-ran it appending eth1, a default for eth1 was added. But, I still cannot ping other hosts on the network, "network is unreachable."

Thanks,

Rich
 
Old 10-22-2007, 04:42 PM   #4
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 504

Rep: Reputation: Disabled
I think your problem is a mere syntax error. I don't know why the program name is printed as "inet_route" and not simply "route", but that's not the problem. The problem seems to be that you are using "Gw" instead of "gw" as the keyword to indicate the gateway. Apart from that, can you post your route table using the -n flag so we can see the actual numbers and what you are trying to do?
 
Old 10-23-2007, 09:52 AM   #5
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
rg3,

Yes, I picked up that error myself; mis-read the route man page.

However, that wasn't the real issue. Turns out that even though eth0 was not running, there were routes for it in the routing table and packets preferred to try that interface rather than the eth1 interface. This was pointed out to me by a local wireless guru who admitted that he sometimes gets tripped up by the same issue.

Running 'ifconfig eth0 down' cleared those routes, and the notebook is able to ping and connect to other hosts (and the 'Net) wirelessly now. I'm sure that I'll remember this the next time I want to use the notebook other than here in the office with the wired connection.

Many thanks to all who responded,

Rich
 
Old 10-23-2007, 11:15 AM   #6
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 504

Rep: Reputation: Disabled
I'm glad you solved the problem. It's also interesting that with Linux it's possible to have both the wired and wireless connections active at the same time, each one with its own default route, and balance connections between the two. But that's an advanced topic that usually requires reading a book and consulting the LARTC HOWTO.
 
Old 10-23-2007, 03:40 PM   #7
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
I didn't mean to have them both active concurrently. I thought that only the interface that ifconfig reported as RUNNING was active. However, the routes are present even if the interface is not active. That's the part I had not before encountered.

Rich
 
  


Reply

Tags
default, eth1, networking, route


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware Current versus Slackware 10.2 davimint Slackware 3 07-26-2006 03:52 PM
Minislack versus Slackware Grongle Slackware 7 04-09-2006 12:56 AM
I am not able to add a new route to my route table using route command prashanth s j Linux - Networking 2 09-03-2005 04:34 AM
Slackware 10 route issue odysseynetwork Linux - Networking 2 10-06-2004 08:13 AM
Gentoo versus Slackware kaon Slackware 17 07-21-2004 10:00 PM


All times are GMT -5. The time now is 02:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration