LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   $ startx stopped working, was working fine when I shut it down last night (http://www.linuxquestions.org/questions/slackware-14/%24-startx-stopped-working-was-working-fine-when-i-shut-it-down-last-night-4175472882/)

BogoMIPS_1962 08-10-2013 07:46 AM

$ startx stopped working, was working fine when I shut it down last night
 
Dual boot Dell laptop with slack 14.0 installed.
Everything was working fine, and last night I was configuring slack to access my shared printer on the windows network. was able to get to printing a test page with no errors on the linux machine, but the printer was just sitting there with "printing" on the display but nothing printing. so I shut everything down and was going to try again this morning.

Went to startx and have the following message: (similar message as root).

I apologize for the quality of the following text, I was using vi and highlighting text from one terminal window into another terminal with vi open. then copying that into the windows directory on this laptop. (since I don't have x).

******** startx with xfce as wm *******

bogomips@slack:~$ startx
xauth: file /home/bogomips/.serverauth.2563 does not exist


X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.0 Slackware Linux Project
Current Operating System: Linux slack 3.2.29-smp #2 SMP Mon Sep 17 13:16:43 CDT 2012 i686
Kernel command line: BOOT_IMAGE=Linux ro root=803 vt.default_utf8=0 video=1024x800
Build Date: 23 August 2012 02:27:55PM

Current version of pixman: 0.26.2
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 10 07:50:41 2013
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] Kernel modesetting enabled.
/usr/bin/startxfce4: X server already running on display :0
xfce4-session: error while loading shared libraries: libstartup-notification-1.so.0: cannot open shared object file: No such file or directory
xinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.

****What I did notice was /usr/bin/startxfce4: X server already running on display :0
and tried $startx -- :1 but it still won't load the xwindow

**** I can change the window manager to twm and get that to display, so somethings working.

****When I shutdown slack last night I used the logout button in xfce instead of ctrl+alt+BS and typing $"shutdown -h now" as #.

Since this is a fresh install it would be easier for me to just wipe the partition and reinstall, but I would rather fix the problem and learn from it.

Slackware sure has changed from when I was introduced with ver. 7.2

If you need any more info please let me know.
Thanks in advance.
Bill

cynwulf 08-10-2013 12:44 PM

First try
Code:

$ rm ~/.Xauth*
and try to startx

TommyC7 08-10-2013 01:04 PM

The first thing I noticed was this:
Code:

xfce4-session: error while loading shared libraries: libstartup-notification-1.so.0: cannot open shared object file: No such file or directory
Seems like you might be missing the startup-notification package:
Code:

$ grep -r "libstartup-notification-1.so.0" /var/log/packages
/var/log/packages/startup-notification-0.12-x86_64-1:usr/lib64/libstartup-notification-1.so.0.0.0

It seems like xfce4-session is attempting to use it, hence other desktop environments or window managers (e.g. twm as you saw) work but xfce4 does not.


All times are GMT -5. The time now is 12:27 PM.