LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices



Reply
 
Search this Thread
Old 02-12-2014, 05:21 AM   #1
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 555

Rep: Reputation: 75
Installing SlackARM 14.1 on my Raspberry Pi (model B)


Using the step-by-step instructions on http://rpi.fatdog.eu, I tried to install Slackware 14.1
Even after 19 years of using Slackware on the PC (x86 and x86_64 and multilib) I'm a bit puzzled that after the package selection going on to the installation it's "done" in a second or two.

That could never be right; fast as Slackware is, it's still not THAT fast :-)

Indeed, nothing had been installed, but neither could I capture what has gone wrong. (Next time I'll give it a shot with
Code:
setup 2>/dev/tty2
or so, might be I capture the problem)

Since /mnt was still mounted and I got a bit curious what I could figure out what the issue might be, I went ahead and try to install it "by hand":
Code:
ROOT=/mnt installpkg /floppy/slackarm/14.1/slackware/a/*.t?z
I went on with a few more sets, and then my time was up, so will start from scratch next time.

Yet, I wonder if someone else has an idea what could be wrong and how they worked around the issue, or if you have other ideas how I could go about and fix it. Might be that I have to do the whole installation process by hand; If so, I'm curious what things I should think about and set right before I have to iterate over silly mistakes :-)

What I am thinking of doing next:
Perform all actions, including formatting the root partition, since ... oh well, why not :-) with 'setup' up to and including installation of packages. I will redirect std error to a place where I can capture and read it (unless someone has a better idea )

If possible resolve the issue that is reported (from stderr) or else continue like this:
Code:
for series in $(echo "a ap d e f k kde l t tcl x xap y")
do
ROOT=/mnt installpkg /floppy/slackarm/14.1/slackware/${series}/*.t?z
done
Figure out the finishing touches, remove the initrd.gz; cross my fingers and reboot.
 
Old 02-12-2014, 06:15 AM   #2
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 224

Rep: Reputation: 10
On x86 it's the hardware clock keeps track of time even when the PC is off .. on ARM hardware it's common that the hardware clock (if present) is not battery backed so it does not have the correct time right after boot (it will default to the unix epoch time).
What's the date on your your Pi at the time you are trying to install ?

I don't use the installer to install my ARM systems (I go the miniroot way) but I suppose that the date needs to be set correctly or tar will lament about future timestamps and thus possibly installpkg will fail to install slackware packages.
 
Old 02-12-2014, 06:17 AM   #3
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 555

Original Poster
Rep: Reputation: 75
I admit that I forgot to set the date/time at first (one of those steps in the step-by-step howto); admitted that that might have been the issue, so I did set it before launching setup after the 3rd try and actually for once NOT forgetting to do just that :-) So, at time of install, date and time were yesterday 21:50 or so.
 
Old 02-12-2014, 06:56 AM   #4
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 224

Rep: Reputation: 10
So your last attempt produces a successful installation ?
 
Old 02-12-2014, 08:14 AM   #5
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 555

Original Poster
Rep: Reputation: 75
no; or I would've flagged this as [SOLVED] ;-)
Something isn't working as it should, but I cannot figure out what, how or why.
 
Old 02-12-2014, 03:10 PM   #6
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 224

Rep: Reputation: 10
If you do menu or expert mode installation do you get prompted with the package selection in each package series ?
 
Old 02-13-2014, 05:51 AM   #7
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 555

Original Poster
Rep: Reputation: 75
Hadn't tried that; however, redirecting stderr to /dev/tty2 learned that the problem resides in /mnt/etc/fstab not being there at that certain point. After creating it, the installation complainted that /mnt/etc/shadow doesn't exist.

The workaround applied was doing just what I stated above: the package selection (for series in...) and running installpkg with ROOT=/mnt worked just fine, which I ran from tty2 (and remained in 'setup' during the installation on tty1)

After that I went back to tty1 and ran "installation" again, which was done very quickly again (but no harm :-)) the configuration steps (like setting root password and selecting which wm to use by default etc etc) did just the thing that was required so after leaving the setup ran the finishing steps as described in the step-by-step instruction manual. I probably made a typo as I did not seem to have xfce installed, but will look into that a bit later...

At least my RasPi boots Slackware 14.1 now!
 
Old 02-14-2014, 09:24 AM   #8
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 178

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by Ramurd View Post
Hadn't tried that; however, redirecting stderr to /dev/tty2 learned that the problem resides in /mnt/etc/fstab not being there at that certain point. After creating it, the installation complainted that /mnt/etc/shadow doesn't exist.

The workaround applied was doing just what I stated above: the package selection (for series in...) and running installpkg with ROOT=/mnt worked just fine, which I ran from tty2 (and remained in 'setup' during the installation on tty1)

After that I went back to tty1 and ran "installation" again, which was done very quickly again (but no harm :-)) the configuration steps (like setting root password and selecting which wm to use by default etc etc) did just the thing that was required so after leaving the setup ran the finishing steps as described in the step-by-step instruction manual. I probably made a typo as I did not seem to have xfce installed, but will look into that a bit later...

At least my RasPi boots Slackware 14.1 now!
Sounds very strange to me.
The installer keeps a log of each package installation in a single file which ends up being called /tmp/installpkg-report.log upon the OS' file system. I don't recall if this is written directly to /mnt/tmp or written to the /tmp ram disk and moved afterwards (I suspect the former). There might be something useful in there which will indicate at which point the installation went wrong.
 
Old 02-17-2014, 02:08 AM   #9
Ramurd
Member
 
Registered: Mar 2009
Location: Rotterdam, the Netherlands
Distribution: Slackwarelinux
Posts: 555

Original Poster
Rep: Reputation: 75
Had looked about everywhere; At the moment I noticed the error (/mnt/etc/fstab not being present for example) I checked the filesystem mounted on /mnt, and noticed it was indeed empty, except for the lost+found directory that comes with the filesystem. So /mnt/tmp did not exist either, not really sure if I looked in /tmp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Raspberry Pi Model B Wifi -> No DHCPOFFERS received Raspberry Linux - Networking 9 01-03-2014 11:14 AM
Raspberry Pi Model A released one year later onebuck Linux - Embedded & Single-board computer 0 02-07-2013 07:44 PM
LXer: Raspberry Pi Model A released one year later LXer Syndicated Linux News 0 02-04-2013 08:00 PM
LXer: Raspberry Pi Model A now on sale in Europe LXer Syndicated Linux News 0 02-04-2013 04:41 PM
LXer: Raspberry Pi Model B in production LXer Syndicated Linux News 0 01-11-2012 01:10 PM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration