LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-13-2013, 05:59 AM   #16
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled

if you go advanced you can see the # symbol but I find it quicker to do this
wrap the words code and /code with square brackets []

2)
Quote:
cat /proc/asound/cards---your result only one
damn

can you look into your bios please and see if there is something there to change to something other than hdmi

(b) can you temporarily disable skype in case its interfering by grabbing your analog device.....grrrr.....grins

if nothing I accept your reluctance to use a model=string so lets move on

#################

confirm dbus is running pls (on debian) try
Code:
 /etc/init.d/dbus status
if above bios no good try this

open terminal type pacmd and press enter as a local user pls

type help and press enter

type list-modules

look for the udev detect module if found or not pls report

I may have to goole to see if skype is holding and not releasing your analog device.....and yes I know you have 2 devices
 
Old 10-13-2013, 06:05 AM   #17
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
yeah a quick google shows this link
https://help.ubuntu.com/community/SkypeTroubleshooting

I suggest you delete your .asoundrc first

next do as link suggests
Quote:
Skype has been known to mess up the mixer settings. So disable the automatic configuration of the mixer controls in Skype: right-click with your mouse on the Skype icon in the system tray - Options - Sound Devices - remove the tick at: Allow Skype to automatically adjust my mixer levels. Click Apply. Then close Skype (right-click with your mouse on the Skype icon - Quit).
 
Old 10-13-2013, 10:34 AM   #18
andymck
Member
 
Registered: Aug 2006
Location: Garland, TX, USA
Distribution: Fedora
Posts: 74

Original Poster
Rep: Reputation: 15
Here is something else I've noticed just now: If I have something plugged into the headphones port on the front panel (e.g., a set of headphones) everything works fine except that pavucontrol still thinks that the front headphones jack is the only port available. Sound comes out of both the headphones and the speakers, I can do a speaker test, everything. I'm beginning to think that the only problem is that, for some reason, the pulseaudio subsystem doesn't know that the backplane speaker port exists. ALSA doesn't seem to care whether anything is plugged in or not, so doesn't care about the second port (and may, in fact, not be aware of it either, but it doesn't matter).

Maybe we're wasting our time chasing the wrong problem.
 
Old 10-13-2013, 10:41 AM   #19
andymck
Member
 
Registered: Aug 2006
Location: Garland, TX, USA
Distribution: Fedora
Posts: 74

Original Poster
Rep: Reputation: 15
Also, again, on the target system (Fedora 19) I don't even have Skype installed yet. That's only on the Fedora 18 partitions, which I don't have booted. I truly don't think that's the issue.
 
Old 10-13-2013, 11:07 AM   #20
andymck
Member
 
Registered: Aug 2006
Location: Garland, TX, USA
Distribution: Fedora
Posts: 74

Original Poster
Rep: Reputation: 15
If by the "bios" you mean the bios screen I can pull up after powering on, I don't find anything about HDMI in there. Also, I don't know what you mean by
Code:
/etc/init.d/dbus status
There is a /run/dbus, but no /etc/init.d/dbus.

Thanks for pointing out the "#" button, BTW.
 
Old 10-13-2013, 11:13 AM   #21
andymck
Member
 
Registered: Aug 2006
Location: Garland, TX, USA
Distribution: Fedora
Posts: 74

Original Poster
Rep: Reputation: 15
Finally, yes, module-udev-detect is running.
 
Old 10-13-2013, 01:01 PM   #22
andymck
Member
 
Registered: Aug 2006
Location: Garland, TX, USA
Distribution: Fedora
Posts: 74

Original Poster
Rep: Reputation: 15
I GOT IT!

I got it, I got it, I got it.

I've been doing some Googling and found the following: https://bugs.launchpad.net/ubuntu/+s...io/+bug/946232. Then, I went down to comment #32 as mentioned in the bug description, opened /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf (as root), commented out all of the "required-any" lines, and saved it. Finally, I rebooted, opened the "System Settings / Sound" control, and Voila: All was golden.

Now I just need to decide what to do next. Report it to Pulseaudio? Print off and save a copy of the above-mentioned bug report for future use? Forget the whole thing? Decisions, decisions, ...

Thanks for your help, aus9.

ADDED LATER:

I tried the above on my Fedora 18 install, but instead of rebooting I simply killed and restarted pulseaudio. That worked as well.

Last edited by andymck; 10-13-2013 at 01:34 PM.
 
Old 10-13-2013, 06:43 PM   #23
aus9
Guru
 
Registered: Oct 2003
Posts: 5,060

Rep: Reputation: Disabled
well done you found it not me

BTW comment 151 shows PA is a blinkin mess.

I can now restore my old image and go back to a compliant alsa.
I image with fsarchiver
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Headset isn't producing sound and internal speakers stay on. luxury2266 Fedora 4 10-14-2011 08:25 AM
Why won't my usb speakers play any sound? bow-wow Linux - Newbie 2 10-12-2011 04:11 PM
Sound Heard in external headphones but not in internal speakers of laptop @skm3nt Linux - Newbie 8 08-28-2010 08:26 PM
Speakers have high-pitched sound that won't go away. marietechie Linux - Hardware 2 12-23-2007 07:14 PM
sound from laptop speakers although external speakers are connected! superpingu Linux - Laptop and Netbook 1 10-18-2007 07:32 AM


All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration