LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-21-2003, 04:37 PM   #1
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Rep: Reputation: 15
Unhappy Changing XF86Config file


I need help changing my monitor and GPU settings. Well the problem is that when i boot up linux (redhat 9), i get all the [OK] 's but when it comes to firstboot my monitor switches off. i know how to get in to runlevel 3 and i have read the log file, it states no [EE] files.

When i try to run:

/etc/X11/XF86Config

it states permission denide.

If any one knows how to fix this reply.

or

If any one how has a GeForce FX 5200. tell me what settings you used at installation.
 
Old 09-21-2003, 04:40 PM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Xconfigurator OR xf86config is the syntax you are likely looking for

Cool
 
Old 09-21-2003, 07:56 PM   #3
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
I think in redhat9, you want the redhat-config-xfree86 command. Also you'll need to be root to run the X-configurator. If you can't get any of the graphical configurators to work, you might have to manually edit the XFree86 file. Just make sure to look up the specs and then try a low resolution setting on your monitor, at least till you get X up.
 
Old 09-22-2003, 06:02 AM   #4
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
i have tried Xconfigurator, it states that it is not a command and i have used upper and lower case correctly. I have not tried X-configurator.

I tried the redhat-config-xfree86 command and it stated after i pressed <ctrl> <alt> <f1> because my monitor switched off:

bogus values

id: "sorry i can not remember"

name: none

Hsync: none

Vsync: none

I will try X-configurator ut in the mean time does anyone else know what to do?
 
Old 09-22-2003, 10:27 AM   #5
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
X-configurator is the utility that is run by the redhat-config-xfree86 command. So trying to execute the command X-configurator won't help.

Look up the specifications for your monitor in the manual or at the manufacturers website. There are 3 important values you will need: horizontal and vertical refresh rates and maximum resolution. Make sure that you find the correct ones, if you have an older monitor and you put in values that are wrong you could cook your monitor (think smoke and flames). Once you found the right values, open the /etc/X11/XF86Config file using a text editor like pico or vi. Towards the bottom of the file, you will see a section called monitor. You will see places to enter the horizontal and vertical refresh rates. Put in the proper values. It will look similar to this:

Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "MonitorVendor"
        ModelName    "Monitor"
        HorizSync    30.0 - 107.0   
        VertRefresh  48.0 - 120.0
        Option      "dpms"
Now below that section, there will be one titled Screen. Make sure it lists your video card and that for Monitor, it points to the Monitor section that you just edited before. For the Modes entry, put in a low resolution to start out. It should look similar to this:
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "RIVA TNT2"   <----This will be your videocard
        Monitor    "Monitor0"     <----This should point to your monitor section
        DefaultDepth     16
        SubSection "Display"
                Depth     16
                Modes    "800x600" "640x480"
        EndSubSection
Now go to the top of the file and look for the section titled Server Layout . It will look like this:
Code:
Section "ServerLayout"
        Identifier     "AnacondaConfigured"
        Screen      0  "Screen0" 0 0    <---make sure this points to the Screen section you just edited
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Mouse1" "SendCoreEvents"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
Don't worry about anything but the line that says Screen. Make sure that the Screen entry says Screen0

Once you have edited the file, save it and try to start the Xserver, using the startx command. Once you get X working, you can change the maximum resolution and color depth to whatever your monitor/videocard can support using the redhat display manager or you can run the redhat-config-xfree86 command.
 
Old 09-23-2003, 01:53 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Rep: Reputation: Disabled
Good morning, Capt_Caveman

Just a quick one: I want to reduce the refresh rate (from 120 to 90 hz). In what section should I look? I didn't find it like mentioned in DISCUSSION: Configuring XFree86 for a Non-Specific Linux Distribution. (And this guy is looking for it, too Test Hz settings for display).

So, do you have any ideas?
 
Old 09-23-2003, 07:28 AM   #7
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
From the other posts, I'm assuming that you want to change the vertical refresh rate. So under the Monitor Subsection of the /etc/X11/XF86Config file:

Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "MonitorVendor"
        ModelName    "Monitor"
        HorizSync    30.0 - 107.0   
        VertRefresh  48.0 - 120.0    <-----Change This
        Option      "dpms"

Code:
 
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "MonitorVendor"
        ModelName    "Monitor"
        HorizSync    30.0 - 107.0   
        VertRefresh  48.0 - 90.0    <-----To This
        Option      "dpms"
The Monitor subsection will be towards the bottom of the XF86Config file. You can use a text editor to make the changes to the file, remember to save the file and that you'll have to be root to save any changes you have made.
HTH
 
Old 09-23-2003, 07:39 AM   #8
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
as i said in your post in http://www.linuxquestions.org/questi...adid=94493,you try 'xf86config'.i am sure that it can solve your problems.
 
Old 09-23-2003, 03:18 PM   #9
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
I have changed the monitor settigns,

when i was looking at the videocard settings, they are not the setting i put in. the settings were for the generic vesa card.

i have a geforce fx 5200 what shoud i change in the config settings?
 
Old 09-23-2003, 05:39 PM   #10
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
For the Geforce 5200, you want your XF86Config file to look like this:

code:Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce FX (generic)"
VideoRam 131072
EndSection

Check out this thread for more info:

http://www.linuxquestions.org/questi...threadid=92073
 
Old 09-24-2003, 02:52 PM   #11
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks all.

every thing is working fine. after i changed the video card settings, my monitor when nuts, saying the refresh rates are out of range, so i went to the website abd got the correct settings.

it was:

HF: 30.0 - 70.0
VF: 50.0 - 150.0

Now every thing is working groovy.
So once again thank you.
 
Old 09-24-2003, 06:26 PM   #12
dillybat
Member
 
Registered: Sep 2003
Location: Minnesota
Distribution: Red Hat 7.3, RHEL4 WS, FC 1-6, Ubuntu
Posts: 51

Rep: Reputation: 15
Bill Hicks,

now that you have the config set correctly go to http://www.nvidia.com and get the latest Linux nvidia drivers. This give a little better perfomance...

You willl have to install them with the X server not running so you may want to reboot into init level 3 for this.

Also check out the docs for the drivers because there are some X server modules that you will want to comment out in the config file and you will also want to change Driver "nv" to Driver "nvidia"

If you are going to keep this machine going for an extended period then you will be happy with the results...
 
Old 09-24-2003, 07:42 PM   #13
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
Just an FYI:

When monkeying with your XF86Config file, ALWAYS, ALWAYS, ALWAYS check that you have the right settings for the horizontal and vertical refresh rates of your model of monitor. If you have an older monitor and you put the wrong settings in, you can destroy your monitor. It can literally smoke and burst into flames (seriously). So don't just randomly stick any old number in there.
 
Old 10-09-2003, 03:20 AM   #14
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Rep: Reputation: Disabled
@Capt_Caveman
Code:
VertRefresh  48.0 - 90.0    <-----Change To This
worked.

For detailed explanation see this post
 
Old 10-09-2003, 07:05 AM   #15
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
Glad I could help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XF86Config file masterweaver Linux - Software 3 09-16-2004 01:34 PM
where is the XF86config-4 or XF86config file in the fedora? u2911 Fedora 4 07-24-2004 08:38 PM
How to tell what XF86config file I'm using? XORsist Linux - Hardware 4 01-02-2004 11:32 AM
Changing the XF86Config outside GUI Bevith Linux - Software 1 07-23-2003 08:22 PM
Can i see someone XF86Config File? Kane Linux - Software 1 08-18-2002 11:00 AM


All times are GMT -5. The time now is 07:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration