Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Slackware - ARM This forum is for the discussion of Slackware ARM.


  Search this Thread
Old 08-09-2017, 01:16 PM   #1
LQ Newbie
Registered: Aug 2017
Posts: 4

Rep: Reputation: Disabled
Enable "monitor mode" for wireless interface in RPi3

I am running my RPi3 on slackware-current (14.2 at the moment).
While trying to enable monitor mode (using airmon-ng start wlan0), it gave me an error which ultimately lead me to a post saying monitor mode is not supported on the broadcom provided drivers of BCN43438 chipset... later talking about the nexmon project which can make it happen.

The instructions in the nexmon rpi project are mostly for raspbian, with (thankfully) a section talking about "Creating your own firmware patch"

Now i am mostly conversant with basics of linux (mostly admin-ish work), but have only made the most basic SlackBuild.. Can someone guide me (1) if one can create a slackbuild out of the instructions there? and does one already exist? (2) which is the slackware arm/sarpi equivalent of "raspberrypi-kernel-headers"? (3) which package provides libgmp3-dev ?

edit: I also need to know how to confirm mine is BCM43438.. 'coz after running "airmod-ng start" i remember seeing BCM43430

Last edited by njathan; 08-09-2017 at 01:18 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 01:16 PM
Why my wireless card "atheros" run only as an acces point in "Master" mode. jardiamj Linux - Wireless Networking 3 11-11-2007 12:12 AM
iwconfig mode monitor Error: "Set Mode" (8B06) WOP1337 Linux - Wireless Networking 2 04-03-2007 08:13 AM
ADSL Problems: "cannot enable interface ppp0" funkymunky Linux - Networking 3 05-24-2005 06:19 AM
How to enable "laptop mode" on 2.6.5 Slackware 9.1 ming0 Linux - Laptop and Netbook 0 06-06-2004 02:31 PM > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 07:16 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration