LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-15-2014, 09:56 PM   #1
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 57

Rep: Reputation: 16
help with wifi driver Intel® Dual Band Wireless-AC 3160


"#ip" a only gives me a eth0 no wifi
is my nic is
Intel® Dual Band Wireless-AC 3160

I think this is the firmware driver.
iwlwifi-3160-8.ucode
http://www.intel.com/support/wireles.../CS-034398.htm

I put it in /lib/firmware
root@vita:/lib/firmware# ls
iwlwifi-3160-8.ucode
root@vita:/lib/firmware#


root@vita:/home/cwc# uname -a
Linux vita 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u1 x86_64 GNU/Linux

lspci


08:00.0 Network controller: Intel Corporation Device 08b4 (rev 93)

I've done a # sudo modprobe -r iwlwifi ; modprobe iwlwifi
with no luck.

Please throw me a bone.
I'm trying to use command line to bring up the nic
I'm not how the kernel is set.

Last edited by cwc; 08-16-2014 at 12:21 AM.
 
Old 08-15-2014, 11:49 PM   #2
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, CentOS & Android
Posts: 3,073
Blog Entries: 1

Rep: Reputation: Disabled
Hi:

The good news is; you already have the right firmware. I doubled checked to make sure.
Code:
iwlwifi-3160-ucode-22.15.8.0.tgz
When I was running Debian I had to install the driver for my chipset and also 'wireless-tools' in order to get my wireless working. Your chipset should be in the output of lspci:-

I see in your post the network controller you have. Sorry I'm not familiar with that card.

You can run ifconfig to show the internet address, subnet, loop back and wireless extensions.
And you can use ifconfig -a to show even the networks that are down.

To start the network in the terminal you can run
Code:
/etc/initid/networking start
But it may not work w/o the driver, firmware and maybe the driver for you chipset installed and 'wireless-tools'

Try looking in your /etc/network/interfaces file and make sure that Wired is commented out with a (#) and see if Wireless is uncommented.

Quote:
I'm trying to use command line to bring up the nic.he ke.rnel
Sorry I'm not sure what you mean:-- If your mean network interface card try:
Code:
lspci | grep -i network
http://www.tecmint.com/ip-command-examples/

https://wiki.debian.org/WiFi
https://packages.debian.org/search?k...wireless-tools
https://launchpad.net/debian/+source/wireless-tools
https://wiki.debian.org/NetworkConfiguration

Hope that helps-
 
Old 08-16-2014, 12:32 AM   #3
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 57

Original Poster
Rep: Reputation: 16
Thanks for lines

make that:
I'm trying to use command line to bring up the nic

I put firmware in /lib/firmware/

root@vita:/lib/firmware# ls -l
total 652
drwxr-xr-x 2 root root 4096 May 23 2012 hp
-rw-r--r-- 1 root root 662032 Aug 15 19:32 iwlwifi-3160-8.ucode
root@vita:/lib/firmware#

Now the question is? How to get it to work. This is a new kernel so I have no idea where the .conf file is. I'm running debian. Ive only compiled kernels using gentoo.
I need to see if CONFIG_FW_LOADER is set.

root@vita:/lib/firmware# grep -r "CONFIG_FW_LOADER" /
/boot/config-3.2.0-4-amd64:CONFIG_FW_LOADER=y
/root/.bash_history:grep -l "CONFIG_FW_LOADER"
/root/.bash_history:grep -l "CONFIG_FW_LOADER" /*
/root/.bash_history:grep -l "CONFIG_FW_LOADER"
/root/.bash_history:grep -l "CONFIG_FW_LOADER" /*
/usr/share/kernel-package/Config/config.um:# CONFIG_FW_LOADER is not set
/usr/share/kernel-package/Config/config.ixp4xx:CONFIG_FW_LOADER=m
/usr/share/kernel-package/Config/config.s3c2410:CONFIG_FW_LOADER=m
/usr/share/kernel-package/Config/config.footbridge:CONFIG_FW_LOADER=m
/usr/share/kernel-package/Config/config.xenu:# CONFIG_FW_LOADER is not set
/usr/share/kernel-package/Config/config.rpc:CONFIG_FW_LOADER=m
/usr/share/kernel-package/Config/config.m32r:# CONFIG_FW_LOADER is not set
/usr/share/kernel-package/Config/config.xen0:# CONFIG_FW_LOADER is not set

/boot/config-3.2.0-4-amd64:CONFIG_FW_LOADER=y is loaded in boot

How do I install the driver. modprobe ?

thanks again

Last edited by cwc; 08-16-2014 at 12:44 AM.
 
Old 08-16-2014, 12:44 AM   #4
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Wallowing in a pit of despair.
Distribution: Slackware, OpenBSD
Posts: 1,223
Blog Entries: 4

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
I do not know if you are using Debian or a derivative, but with Debian, and probably the derivatives, after installing firmware the network must be configured. The easiest way is to add this to /etc/network.interfaces:
Code:
# my wifi device 
auto wlan0 
iface wlan0 inet dhcp
         wireless-essid [ESSID]
         wireless-mode [MODE]
I did not use the wireless-mode line (I did not add it to the file.) Adding the essid line was sufficient. Depending on your hardware, it may or may not be necessary to change wlan0 to wlan1. This and lots more information is available on the wiki.

Last edited by Randicus Draco Albus; 08-16-2014 at 12:46 AM.
 
Old 08-16-2014, 01:07 AM   #5
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 57

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Randicus Draco Albus View Post
I do not know if you are using Debian or a derivative, but with Debian, and probably the derivatives, after installing firmware the network must be configured. The easiest way is to add this to /etc/network.interfaces:
Code:
# my wifi device 
auto wlan0 
iface wlan0 inet dhcp
         wireless-essid [ESSID]
         wireless-mode [MODE]
I did not use the wireless-mode line (I did not add it to the file.) Adding the essid line was sufficient. Depending on your hardware, it may or may not be necessary to change wlan0 to wlan1. This and lots more information is available on the wiki.
thanks
no luck

root@vita:/etc/network# modprobe -r iwlwifi
root@vita:/etc/network# /etc/init.d/networking start
[....] Configuring network interfaces...Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Cannot find device "wlan0"
Bind socket to interface: No such device
Failed to bring up wlan0.
done.
root@vita:/etc/network# more interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback
# my wifi device
auto wlan0
iface wlan0 inet dhcp
#wireless-essid [ESSID]
#wireless-mode [MODE]
root@vita:/etc/network#
 
Old 08-16-2014, 01:18 AM   #6
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Wallowing in a pit of despair.
Distribution: Slackware, OpenBSD
Posts: 1,223
Blog Entries: 4

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
You need to replace [ESSID] with your host. Example; [me.org]. Whatever name you chose for your machine when you set up the network.

Quote:
Cannot find device "wlan0"
Have you tried wlan1?
 
Old 08-16-2014, 08:55 AM   #7
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 57

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Randicus Draco Albus View Post
You need to replace [ESSID] with your host. Example; [me.org]. Whatever name you chose for your machine when you set up the network.

Have you tried wlan1?
no luck

I'm not sure if I'm checking the correct .conf kernel file to see if the /lib/firmware/ is loaded

Actually I'm not sure where that file is located.
 
Old 08-16-2014, 01:00 PM   #8
Ztcoracat
Senior Member
 
Registered: Dec 2011
Distribution: Slackware, CentOS & Android
Posts: 3,073
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by cwc View Post
no luck

I'm not sure if I'm checking the correct .conf kernel file to see if the /lib/firmware/ is loaded

Actually I'm not sure where that file is located.
On my CentOS machine the configuration kernel file is in sys> kernel> config:-

If you still can't find it open the terminal and use the "whereis" cmd or "find"

https://lists.debian.org/debian-user.../msg04448.html

Does your network show at all in the Network MGR?
 
Old 08-17-2014, 08:26 AM   #9
cwc
Member
 
Registered: Nov 2004
Location: Tri-Cities, WA
Distribution: Gentoo, Ubuntu, Mint,Fedora
Posts: 57

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by Ztcoracat View Post
On my CentOS machine the configuration kernel file is in sys> kernel> config:-

If you still can't find it open the terminal and use the "whereis" cmd or "find"

https://lists.debian.org/debian-user.../msg04448.html

Does your network show at all in the Network MGR?
No luck with my network gui.

Here is my config file from boot
http://68.186.77.53/debian/amd64_laptop_config.txt

I think I might have to compile a new kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Intel Dual Band Wireless-N 7260 headache in 14.1 FireBlast Slackware 9 05-24-2014 12:28 PM
Updated firmware for Intel 3160/7260 xflow7 Slackware 0 12-17-2013 04:44 PM
Ndiswrapper and Dell Wireless 1450 Dual-Band USB 2.0 Adapter bharrison4 Linux - Software 6 11-07-2005 04:18 PM
Dual Band Wireless Pc Card 32-bit CardBus WAG511 on linux blackv1rus Linux - Wireless Networking 0 08-16-2005 01:32 AM
Wireless with RH9 and Linksys Dual Band WPC55AG adapter costasm Linux - Wireless Networking 6 02-01-2004 12:36 PM


All times are GMT -5. The time now is 05:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration