LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 07-07-2013, 03:17 PM   #1
zetrotrack000
Member
 
Registered: Dec 2011
Posts: 120

Rep: Reputation: Disabled
Ralink 539b (RT2800PCI) very slow internet


Hi
I have bough an HP G6 laptop with these network cards:
Code:
           driver: r8169 ver: 2.3LK-NAPI port: 3000 bus-ID: 08:00.0
           IF: eth0 state: down mac: 38:ea:a7:e1:1b:ec
           Card-2: Ralink Device 539b driver: rt2800pci ver: 2.3.0 bus-ID: 07:00.0
           IF: wlan0 state: up speed: N/A duplex: N/A mac: a4:17:31:58:40:95
The problem is that: on this laptop the wired network is working very well but browsing andn downloading speed on wireless netword is very slow.
I did some research and found that my wifi card "Ralink 539b (RT2800PCI) had some speed and connectivity issues in the past. Almost all the solutions recommend to upgrade the kernel to 3.2 or higher. So, this problem should be there in my kernel which is 3.8.
Can anyone help me to solve this problem?
PS: I am using Linux Mint 15. The WIFI router is 10 feet from my laptop and there is no blockage b/w the laptop and wifi.
Presently, wifi inidicator is showing signal strength of 51%
Also, on the same laptop on windows 7, wifi is working very well.
Regards
 
Old 07-07-2013, 06:09 PM   #2
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,217

Rep: Reputation: 139Reputation: 139
all i can suggest is to disable encryption on router and that if that solves problem, however you can always get lucky with other distribution like ubuntu or some distro that uses other network manager.
 
Old 07-07-2013, 06:20 PM   #3
zetrotrack000
Member
 
Registered: Dec 2011
Posts: 120

Original Poster
Rep: Reputation: Disabled
Some people are talking about disabling power saving. Does that help? How can I disable it?
 
Old 07-07-2013, 06:23 PM   #4
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,217

Rep: Reputation: 139Reputation: 139
Quote:
sudo iw wlan0 power_save off
this maybe?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Railink 539b works on some distros but not others why? skilo47 Linux - Networking 23 10-03-2013 02:48 PM
Slow Wireless with Rosewill RNX G300 (RALINK 2561) PaladinXT Linux - Wireless Networking 0 03-23-2013 10:44 AM
Debian testing, RT5390 / RT2800PCI t0n1 Linux - Wireless Networking 12 04-28-2012 07:48 PM
Cannot connect to Internet using Ralink rt2500 wireless NIC dsuratman Linux - Wireless Networking 2 09-04-2005 06:32 AM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM


All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration