LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-27-2013, 03:43 PM   #1
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Rep: Reputation: Disabled
Unform + stunnel with gmail


Linux RedHat


/appl/unform/prog/mailcall.ini:
server=127.0.0.1
port=259

login=******@gmail.com
password=************

/etc/stunnel.conf
client = yes
debug = debug

[pop3s]
accept = 127.0.0.1:1109
connect = pop.gmail.com:995

[smtps]
accept = 127.0.0.1:259
connect = smtp.gmail.com:465

# /usr/sbin/stunnel /etc/stunnel.conf
2013.09.27 12:35:05 LOG7[14850:47641354141888]: RAND_status claims sufficient en
tropy for the PRNG
2013.09.27 12:35:05 LOG6[14850:47641354141888]: PRNG seeded successfully
2013.09.27 12:35:06 LOG7[14850:47641354141888]: SSL context initialized for serv
ice pop3s
2013.09.27 12:35:07 LOG7[14850:47641354141888]: SSL context initialized for serv
ice smtps


Send e-mail and I get this:

12:36:28 Started
12:36:28 Connecting to server 127.0.0.1
12:36:28 Could not open socket to 127.0.0.1, port 259


.

Last edited by T-Dub116; 09-27-2013 at 03:48 PM.
 
Old 09-28-2013, 07:55 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,561
Blog Entries: 54

Rep: Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927
Quote:
Originally Posted by T-Dub116 View Post
12:36:28 Could not open socket to 127.0.0.1, port 259
Try a port > 1024?
 
Old 09-30-2013, 01:54 PM   #3
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by unSpawn View Post
Try a port > 1024?

10:38:36 Started
10:38:36 Connecting to server 127.0.0.1
10:38:36 Could not open socket to 127.0.0.1, port 1024

same thing on every port I try

Last edited by T-Dub116; 09-30-2013 at 04:09 PM.
 
Old 10-01-2013, 05:13 PM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,561
Blog Entries: 54

Rep: Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927
Maybe you should try Unform w/o stunnel and check if that works first?
 
Old 10-03-2013, 01:54 PM   #5
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by unSpawn View Post
Maybe you should try Unform w/o stunnel and check if that works first?
It Does, that is what I am using but I need stunnel to get around a issue

Last edited by T-Dub116; 10-03-2013 at 01:57 PM.
 
Old 10-05-2013, 03:25 AM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,561
Blog Entries: 54

Rep: Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927
Quote:
Originally Posted by T-Dub116 View Post
I need stunnel to get around a issue
Maybe you should explain your problem in more detail then and run stunnel in verbose debug mode?
 
Old 10-07-2013, 12:29 PM   #7
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Original Poster
Rep: Reputation: Disabled
The Software that I am using sends Mail out through unform but it is only allowing us to have 1 from e-mail address instead of multiple becasue of the smtp service provider my customer is using is restricting this. So I want to use stunnel in order to direct through a smtp gmail account that will allow as many from address as we want. Hope this helps explain my problem better
 
Old 10-07-2013, 12:46 PM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,561
Blog Entries: 54

Rep: Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927Reputation: 2927
That's only half of it, I also suggested to run stunnel in verbose debug mode:

Code:
client = yes
debug = 7
output = /var/log/stunnel_debug.log

...
 
1 members found this post helpful.
Old 10-08-2013, 12:39 PM   #9
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by unSpawn View Post
That's only half of it, I also suggested to run stunnel in verbose debug mode:

Code:
client = yes
debug = 7
output = /var/log/stunnel_debug.log

...



2013.10.08 09:23:36 LOG5[6343:47768290205888]: stunnel 4.15 on x86_64-redhat-linux-gnu with OpenSSL 0.9.8e-

fips-rhel5 01 Jul 2008

2013.10.08 09:23:36 LOG5[6343:47768290205888]: Threading:PTHREAD SSL:ENGINE Sockets:POLL,IPv6 Auth:LIBWRAP

2013.10.08 09:23:36 LOG6[6343:47768290205888]: file ulimit = 1024 (can be changed with 'ulimit -n')

2013.10.08 09:23:36 LOG6[6343:47768290205888]: poll() used - no FD_SETSIZE limit for file descriptors

2013.10.08 09:23:36 LOG5[6343:47768290205888]: 500 clients allowed

2013.10.08 09:23:36 LOG7[6343:47768290205888]: FD 4 in non-blocking mode

2013.10.08 09:23:36 LOG7[6343:47768290205888]: FD 5 in non-blocking mode

2013.10.08 09:23:36 LOG7[6343:47768290205888]: FD 6 in non-blocking mode

2013.10.08 09:23:36 LOG7[6343:47768290205888]: SO_REUSEADDR option set on accept socket

2013.10.08 09:23:36 LOG3[6343:47768290205888]: Error binding pop3s to 127.0.0.1:1109

2013.10.08 09:23:36 LOG3[6343:47768290205888]: bind: Address already in use (98)
 
Old 10-08-2013, 01:17 PM   #10
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by unSpawn View Post
That's only half of it, I also suggested to run stunnel in verbose debug mode:

Code:
client = yes
debug = 7
output = /var/log/stunnel_debug.log

...

Thank You Sir!

With the debug log file I was able to dettermin that there was an error with the POP and because e-mail is not coming in I just took pop out completely and we are successful.


Thanks Everyone for your input!!!


T-Dub
 
Old 10-09-2013, 09:15 AM   #11
T-Dub116
Member
 
Registered: Aug 2013
Location: Dolyestown
Posts: 82

Original Poster
Rep: Reputation: Disabled
In the end, stunnel still didn't allow me to have other from e-mail address, it instead made everything come from the gmail account. I had done it before where this worked but it would seem the gmail has made some changes. Looks like I will be programming around this, thanks again everyone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Prob. with gmail It's that time of day. Gmail aims to help you in many ways..." frenchn00b General 1 04-10-2009 05:27 PM
gmail: A sort of gmail-notify for the console ? frenchn00b Linux - Software 1 05-13-2008 05:54 PM
SUSE Open 10.3. Gmail. PITA. (If you don't have Gmail, you will not understand) Lola Kews Suse/Novell 6 03-19-2008 08:43 AM
LXer: Import mail into Gmail with the Gmail Loader LXer Syndicated Linux News 0 03-19-2007 07:01 AM
Need Help: new to stunnel Traveler_Q Linux - Security 1 04-21-2004 09:49 PM


All times are GMT -5. The time now is 07:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration