LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-21-2013, 11:06 PM   #1
stephlo
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Rep: Reputation: Disabled
Advice needed for installing gcc (old and new)


Dear all,

I am trying to install some rather old code that requires g77. Unfortunately, the g77 from compat-gcc-34-g77 seems to be unable to compile the code. I was then given a gcc-2.95.2.tar from the folks who wrote that code.

my os is fedora 17, it came with the gcc 4.7.2-8. THe configure script identifies my machine as "i686-pc-linux-gnu"
Unfortunately, my experience with linux is rather limited. So I can only outline what I did, and the outcome.

I have followed the gcc install instructions as best I can. I first tried to install the gcc2.95.2 - untarred, created a separate build folder. (both located directly in my home directory). From inside the build folder I:
./../src/configure --
make bootstrap
and ended up with:
( a lot about unreferenced/non-existent nodes)
.././../gcc-2.95.2/gcc/cpp.texi:2107: warning: unreferenced node `Conditinals-acccros'.
makeinfo: Removing output file `cpp.info' due to errors; use --force to preserve.
Making info file `cpp.info' from `.././../gcc-2.95.2/gcc/cpp.texi'.
make[2]: *** [cpp.info] Error 2
make[2]: Leaving directory `/home/stephanie/gcc29/build/gcc'
make[1]: *** [bootstrap] Error 2
make[1]: Leaving directory `/home/stephanie/gcc29/build/gcc'
make: *** [bootstrap] Error 2


I did this with the gcc 4.7 and then i tried again with gcc34. Before each attempt, I did in my build directory:
make distclean

I have been over the config files and been installing things that were listed as missing, as far as possible. But so far, the same end result.
I understand that I need a "POSIX"?
Eg: "checking for POSIXized ISC... no"
Is this important? If so, what package should I be installing? I did a yum search, but I cannot identify what I actually need.

And then I thought, why dont I try building a more recent gcc from source, instead, just to make sure that I am able to. So I tried building gcc 3.2.
(again tried with gcc34 and gcc 4.7.2) but again it fails.


make[2]: *** [read-rtl.o] Error 1
make[2]: Leaving directory `/home/stephanie/gcc32/build/gcc'
make[1]: *** [stage1_build] Error 2
make[1]: Leaving directory `/home/stephanie/gcc32/build/gcc'
make: *** [bootstrap] Error 2

So some questions:
1) Would you suggest a different os than fedora, in the view of needing to compile such old code?
2) Do you see any glaring errors?
3) is downloading the gcc source enough? could I be missing libraries/other stuff? Is there generally the way to check for these?
4) any advice or links to guides to installing gcc from source, particularly older versions is much appreciated! (I have been going over the gcc pages)
5) In case I might have messed up my gcc and gcc34 and such, what would be the best way to remove then cleanly so I can later install them again with yum.


I would really appreciate whatever advice you are willing to part with. Thank you so much for your time.

Last edited by stephlo; 07-22-2013 at 01:08 AM. Reason: for clarity
 
Old 07-22-2013, 05:28 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,947

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
Welcome to LQ.

Old-releases ftp://ftp.fu-berlin.de/unix/languages/gcc/old-releases/
> README ftp://ftp.fu-berlin.de/unix/language...eleases/README
> " These releases are here for historical research purposes only.
Don't try to use any of these on modern OSes! "

I.e. a rather old OS is required for compiling e.g. gcc-2.95.3 .

Suggest : Install the RHEL 3 packages (origin=linux7=Redhat 7.3)
1) # rpm -Uvh compat-gcc-7.3-2.96.128.i386.rpm
2) # rpm -Uvh compat-gcc-g77-7.3-2.96.128.i386.rpm
..... providing /usr/bin/i386-redhat-linux7-g77
http://ftp.scientificlinux.org/linux.../i386/SL/RPMS/

Test : $ i386-redhat-linux7-g77 hello.f -o hello-f77-gcc296 : OK, no errors.
http://people.sc.fsu.edu/~jburkardt/f77_src/f77/hello.f

P.S. : gcc-2.96 was the Redhat version of gcc-2.95.x .

-

Last edited by knudfl; 07-22-2013 at 05:33 AM.
 
1 members found this post helpful.
Old 07-23-2013, 07:16 AM   #3
stephlo
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Knudfl, thank you so much for your advice. I really appreciate your help.

I switched to an older os centos 5.3. In attempting to install the gcc packages you suggested, I found that the OS was a bit too new - there being conflict between what was dependencies of things already installed in the os and the dependencies of the two gcc packages. Resolving them seems to be far beyond my ability.

So I looked for an even older version and eventually found centos 2.0 which has gcc-2.96 (red hat version) natively. Unfortunately, even with this compiler, the legacy code wouldn't compile.

Once again. Thank you for your expertise.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing GCC over existing gcc in Redhat linux prakasha.lunux Linux - Newbie 10 01-19-2011 08:34 PM
Any advice before installing Ubuntu 19.19 Desdd57 Linux - Newbie 16 12-30-2010 12:59 PM
Installing vmware on Open Suse 11.1 - Requires original gcc 4.32 - gcc now 4.3 cyclops.matrix Linux - Software 2 08-31-2009 02:52 PM
Advice on Installing on Laptop gbrewste Linux - Newbie 1 06-19-2004 12:52 PM
Installing GCC 3.1 over GCC 2.96...? aaronluke Linux - General 3 09-27-2002 05:28 AM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration