LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 04-29-2014, 06:21 PM   #1
cody.lilley
LQ Newbie
 
Registered: May 2011
Location: Arkansas
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
Question Installer Hangs on MacBook Pro [Video showing problem]


I am trying to install Slackware64 14.1 on my Mid 2009 MBP (5,5).

I downloaded the ISO, and burned it to my USB using Universal USB Installer on a Windows 7 machine. When I boot into the USB on my MBP, I get greeted with a GRUB welcome screen, then a prompt to choose mode, then it says to wait, then it hangs.

I let it sit for an hour and it never gets to the select language, keyboard and login as root prompts.

I have been using Slackware on and off since 2010. I have always used SW on PCs (both laptops and desktops), but I have never tried it on any Mac.

I recorded what I was experiencing and uploaded it to YouTube
LINK: http://youtu.be/09HZ_FxChvg


--------------------
I DO NOT wish to use refit/refind, I simply want to hold the Option Key at boot and choose "Linux", and have it boot into Slackware

Last edited by cody.lilley; 04-29-2014 at 06:24 PM. Reason: added additional info
 
Old 04-30-2014, 03:09 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,184

Rep: Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022Reputation: 1022
First, thanks you for posting this video, that makes thing very clear.

To burn the ISO image on an USB stick, I suggest that you try Rufus instead of Universal USB installer, then please tell us if you get the same results. I've been successful using that for Slint installers, (though I couldn't make it recognized as bootable on a Mac yet, but that's probably for other reasons) and this is the tool recommended for Windows users on the Syslinux mailing list.

PS of course choose UEFI/GPT, not UEFI/MBR.

Last edited by Didier Spaier; 04-30-2014 at 03:21 AM.
 
Old 04-30-2014, 04:37 AM   #3
Germany_chris
Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Arch
Posts: 460

Rep: Reputation: 166Reputation: 166
I was never able to get Linux on the metal of my 2009 17" the dual graphics seem to be the issue
 
Old 04-30-2014, 06:17 AM   #4
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
Did it hang or was it just the display that froze up? (I notice the GRUB cursor isn't blinking, but do not know if this is normal.)

On my MBP Early 2011 8.3, using ELILO to boot the USB, I found it was just the display freezing up. I added nomodeset to the command line options and the installer worked properly. I don't know if it might be something similar for your MBP.

As for not using refit/refind, you could create a small FAT32 partition, create an EFI/BOOT directory and place the kernel/bootloader (whichever works better for your MBP) in there, renamed to BOOTX64.EFI. The Macbook EFI firmware doesn't recognise linux partitions. There may be other ways to do this, but this was the approach I used.
 
Old 05-07-2014, 12:00 PM   #5
cody.lilley
LQ Newbie
 
Registered: May 2011
Location: Arkansas
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Post Update

Sorry for the delay in getting back to you guys. I just finished Finals Week, so now I have more time for the Internet .


Ok, So I made another USB Disk using Rufus. I get the same result. However, I did play around with the usb-and-pxe-installers/ and put the USB installer on a Memory Card (My two USB ports are too close together to use two USBs at the same time). I also don't have a optical drive, I have a 1TB HDD there instead.

My thinking was that I could use the Memory card to get into Setup, then select the USB as the "source dvd" and have it install from there. And then I'd be on my merry way. However I run into some problems.

Video:http://youtu.be/GZftPEMlTMA

I tried to change the vga=normal to 773 and ask, and I couldn't tell if I was doing it right(not featured in video). It looks like it it doing this weird split and overlap thing. but I can select my keyboard layout, login as root, even start setup, but i just can't read anything.

Also, if someone could explain what to use of format the predefined partition My Macintosh SSD Partition layout (yes, I know there is nothing in my Windows partition, there WAS, but it was killed when I followed some old guides on the Internet, I wanna get this going, I will reinstall Windows and then SW later)

I am also not sure on what partition I should install the boot loader.

I didn't realize how much more difficult this would be on a Mac vs a PC, but it'll be worth it.
 
Old 05-07-2014, 03:33 PM   #6
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
I think it should be nomodeset, not nomemset, that you should try.

Triple booting OS X, Linux and Windows on an older Mac is a bit of a pain. My partition setup is Mac(HFS+), Linux(EXT4), then Windows(NTFS). The partition type doesn't really matter. Some websites say the order matters, I don't know if it does but I decided to play it safe.

Booting with EFI requires an additional FAT32 partition, either on a USB stick or on your second hard drive. The pathname of the bootloader/EFI Stub kernel should be /EFI/BOOT/BOOTX64.EFI. This is probably the best way to do it as long as everything on your Mac works properly in Linux though it might be harder to set up.

Booting via emulated BIOS can be done by going through Windows first. AlienBob's instructions will work. I don't recommend this method if you are installing Windows 8 unless there is no other choice.
 
  


Reply

Tags
freeze, hang, install, slackware, video


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't run Fedora installer on MacBook Pro tron_thomas Linux - Software 9 07-24-2011 12:03 AM
Problem installing Slackware on MacBook Pro eyeontheprize Slackware 1 05-07-2009 09:52 AM
MacBook Pro - Fedora 10 - svn mplayer - no video window pdoersch Linux - Newbie 1 02-03-2009 01:23 AM
Linux on a macbook/macbook pro... any experiences/problems, or is it even necessary? enigma_0Z Linux - Laptop and Netbook 13 09-14-2007 10:29 PM
Xubuntu on Macbook pro - video lag, and compile requirements? rose_bud4201 Ubuntu 2 03-14-2007 10:42 PM


All times are GMT -5. The time now is 03:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration