LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 09-28-2013, 10:54 AM   #1
ns_chrys
LQ Newbie
 
Registered: Sep 2013
Posts: 2

Rep: Reputation: Disabled
cannot transfer files between windows and ubuntu - SFTP host disconnected and connect


At home, I'm trying to connect my desktop (which has Ubuntu 12.10 installed) to my windows 7 laptop via sftp/ ssh. I have already installed openSSH-server and openSSH-client on my desktop. On my laptop, I have the BlueZone Secure FTP software (using which I'm able to connect with my linux workstation in my office).

Since I'm able to connect to my red-hat linux box at the office (via ssh), I think the BlueZone software is working correctly (and when it was first set up by one of the guys in IT, he told me he didn't have to install anything else in addition to the BlueZone Secure FTP software) So in order to connect my desktop and laptop (which are on the same WiFi network at home), I don't think I need to install any other software, and the main issue lies with the settings (either on the laptop or the desktop - I don't know which).

Could you please help me figure out the settings - either in the sshd_config file/ ssh_config file or on the laptop itself?

In BlueZone Secure FTP software, the current settings I am using to try and connect to my desktop are:

Host Address = 127.0.1.1 => I'm assuming this is the IP address of my desktop
Host Type = Auto-detect => left at default

TCP Port = 22 => left at default
Backup Host = none => left at default

Initial PC Directory = C:\Users\
Initial Host Directory = /home/user1

username = user1
password = pass1

Security = SFTP (SSH) => left at default
Preferred Cipher Suite = AES => left at default

I'm a newbie to the whole "networking using linux" bit, so if you need me to post anymore system info, please let me know
 
Old 09-28-2013, 11:24 AM   #2
MCD555
Member
 
Registered: May 2009
Location: Milan, Italy
Distribution: Ubuntu, Debian, Fedora, Oracle Linux
Posts: 104

Rep: Reputation: 9
Hi ns_chrys,

so your goal is connect from your ubuntu desktop (UD) to you Win7 laptop (W7), isn't it?
Let's say they are on the same network with IP_UD and IP_W7.

- Step 1 - Check if SSH server is running
First of all, check if BlueZone is up&running onto your W7 with a simple netstat:

from your command prompt (open a terminal) lauch the command
Code:
netstat -ano | find "22"
If the server is running you should get a response like this:
Code:
TCP    0.0.0.0:22            0.0.0.0:0              LISTENING
- Step 2 - Get your W7 ip address
from your command prompt (open a terminal) lauch the command
Code:
ipconfig
look for the IPv4 detail
Code:
IPv4 Address. . . . . . . . . . . . : xxx.xxx.xxx.xxx
that's your IP (IP_W7)

- Step 3 - Try connecting
From you UB terminal, simply try

Code:
ssh user1@IP_W7
You should get the server public key, response YES to the question and go on with authentication.

Now, let us know if you get problem on Step 1,2 or 3 to get out a better response to your issue.
 
1 members found this post helpful.
Old 09-28-2013, 11:32 AM   #3
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,258

Rep: Reputation: 385Reputation: 385Reputation: 385Reputation: 385
127.0.1.1 is not the correct host IP
that is local only...

you are probably looking for something starting 192.168

on your desktop
have a look at the output of
/sbin/ifconfig

Code:
eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:10.168.210.214  Bcast:10.168.210.255  Mask:255.255.255.0
          inet6 addr: fe80::250:8dff:fe93:fd1a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
the bold is the IP you want

like I said, your will probably start 192.168.0.
the default for many home routers

NOTE, I'm on a wire, eth0.. you may have wlan0

Last edited by Firerat; 09-28-2013 at 11:34 AM.
 
2 members found this post helpful.
Old 09-28-2013, 11:55 AM   #4
ns_chrys
LQ Newbie
 
Registered: Sep 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
@MCD555: Thanks for the steps, sir. The problem is at Step 1 - I don't see any output like that on my windows laptop after executing <netstat -ano | find "22">

however, Mr Firerat's solution has fixed this problem - I'm now able to access my desktop from my laptop using BlueZone Secure FTP. I can now transfer files back and forth between the two machines.

@Firerat: Thank you very much for your answer - the issue has been resolved.
 
Old 09-28-2013, 12:22 PM   #5
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-19-live-usb/ aix
Posts: 3,552

Rep: Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514Reputation: 514
^ seems like a typo. should be:
Code:
netstat -ano | grep -w "22"
 
Old 09-28-2013, 04:55 PM   #6
MCD555
Member
 
Registered: May 2009
Location: Milan, Italy
Distribution: Ubuntu, Debian, Fedora, Oracle Linux
Posts: 104

Rep: Reputation: 9
Smile

Quote:
Originally Posted by schneidz View Post
^ seems like a typo. should be:
Code:
netstat -ano | grep -w "22"
Not really a typo ... originally he said to connect from Ubuntu box to Windows 7 so the that "find" was related to the windows box.
May I misunderstood that or may it was really clear :-)
 
Old 09-29-2013, 10:21 AM   #7
dt64
Member
 
Registered: Sep 2012
Distribution: RHEL5/6, CentOS5/6
Posts: 141

Rep: Reputation: 18
One issue could be that some of the wifi routers do not allow by default connections between clients but only from clients to internet.
 
Old 09-29-2013, 10:48 AM   #8
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,258

Rep: Reputation: 385Reputation: 385Reputation: 385Reputation: 385
Quote:
Originally Posted by ns_chrys View Post

@Firerat: Thank you very much for your answer - the issue has been resolved.
glad it helped.

can you mark as solved.
There will be a option in the thread tools ( up at the top )
Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Transfer files in sftp xeon123 Linux - Networking 7 12-17-2010 11:04 AM
Batch files to execute and transfer files via sftp cm67 Linux - General 5 08-13-2009 09:59 AM
How Do I Transfer Files From Ubuntu (Host) and XP (Guest) ?? taurusx5 Linux - Software 2 04-11-2008 01:41 AM
LXer: Transfer files securely with SFTP LXer Syndicated Linux News 0 06-01-2007 05:31 PM


All times are GMT -5. The time now is 09:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration