LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 12-10-2012, 01:26 PM   #1
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Rep: Reputation: 9
Question Problem with LXDE desktop environment on Ubuntu 12.10


LXDE worked fine on 12.04. Now I installed it on 12.10, but when booting the computer does not present me with any other options than Unity, no matter what. Something needs to be done, but what? Any hint, anyone?
 
Old 12-11-2012, 07:10 AM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,175

Rep: Reputation: 219Reputation: 219Reputation: 219
Running LXDE on U12.10 here (original install was Xubuntu, but I deleted all of the XFCE components) without problems. I'm using lxdm as my display manager; it offers me the expected choices of sessions. Your display manager should offer a choise of sessions - do you have lxsession installed?
 
Old 12-11-2012, 01:50 PM   #3
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Original Poster
Rep: Reputation: 9
Yes
I tried to install lxde-common, lxsession and desktop-file-utils, but all I get is that the newest versions are already installed, so I`m back to square 1. Something else is the matter...
 
Old 12-11-2012, 02:19 PM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,175

Rep: Reputation: 219Reputation: 219Reputation: 219
Below is my U-12.10 lxdm.conf. I don't have to worry about the default session, so I left that line commented out.
Code:
/etc/lxdm$ cat lxdm.conf 
[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
# session=/usr/bin/startlxde

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt1

[display]
## gtk theme used by greeter
gtk_theme=Clearlooks

## background of the greeter
bg=/usr/share/backgrounds/default.png

## if show bottom pane
bottom_pane=1

## if show language select control
lang=1

## if show keyboard layout select control
keyboard=0

## the theme of greeter
theme=Industrial

[input]

[userlist]
## if disable the user list control at greeter
disable=1

## whitelist user
white=

## blacklist user
black=

Last edited by RockDoctor; 12-11-2012 at 02:21 PM. Reason: Didn't finish
 
Old 12-11-2012, 02:41 PM   #5
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Original Poster
Rep: Reputation: 9
Hello Rock Doctor
I compared my lxdm.conf to yours, and there is only a small difference, i.e.:

[userlist]
## if disable the user list control at greeter
disable=0

Has this disable=0 INSTEAD OF disable=1 any significance???

teboil12
 
Old 12-11-2012, 06:15 PM   #6
goodtimetribe
LQ Newbie
 
Registered: Apr 2007
Location: Dallas, TX
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
i'd probably try using

Code:
sudo dpkg-reconfigure lxdm
 
Old 12-12-2012, 01:19 AM   #7
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Original Poster
Rep: Reputation: 9
Hi Guys!
Now I`ve really messed it up! I did as told, sudo dpkg-reconfigure lxdm. As a result, I am stuck with a desktop with the text "Login:" and after that I can choose "syslog" or "usbmux daemon,,,(usbmux)" or "saned" and under these there is still the option "More..."
At the bottom part of the screen I can choose between many kinds of desktops, among others this LXDM, but to no use.
When hitting enter I get the "Password: " and when giving my password and hitting enter I am back to "Password " again. I am getting nowhere and the panic is rising. Could anyone help me out from this? Feel really uncomfortable at the moment.
 
Old 12-12-2012, 06:37 AM   #8
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,175

Rep: Reputation: 219Reputation: 219Reputation: 219
In lxdm.conf
Code:
## if disable the user list control at greeter
disable=1
will eliminate the list of all users (anything with a uid).

Looking at the first few lines of /etc/lxdm/Xsession on my system, I see
Code:
/etc/lxdm$ cat Xsession 
#!/bin/bash

# use bash for "exec -l", howto run login shell by /bin/sh ?

if [ $# -eq 1 -a -n "$1" ]; then
	LXSESSION=$1
else
# default session
	LXSESSION=/usr/bin/startlxde
fi
What happens if you add the line
Code:
LXSESSION=/usr/bin/startlxde
immediately following the last line shown above?
 
Old 12-12-2012, 09:32 AM   #9
teboil12
Member
 
Registered: Jan 2011
Location: Finland
Distribution: Mint 16 Cinnamon
Posts: 146
Blog Entries: 2

Original Poster
Rep: Reputation: 9
Hi again!
Sorry to have revealed to all the world what a moron I am. I studied the matter a little bit closer and found out that when I chose the option "More" I realised that my user name was asked for. Could not see it at first because it was black letters on a blue background. After entering my user name I was asked for my passwd and voilá, I was back in business again. This time I am free to choose whichever desktop I wish just like in the old Ubuntu 12.04 days! So thanks to goodtimetribe for the advice, looks like I am gonna manage from here on again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install gnome power manager in ubuntu server 9.04 under lxde desktop Ron_Beltran Linux - Laptop and Netbook 2 10-27-2009 08:39 PM
remove gnome-desktop ubuntu and strictly use lxde ubuntu 9.04 Jaunty Polanski Linux - Software 1 05-07-2009 01:53 PM
Lost my desktop environment in Ubuntu IsharaComix Linux - Desktop 4 12-22-2008 11:42 PM
LXer: LXDE - Light Weight Desktop Environment for openSUSE Linux LXer Syndicated Linux News 0 08-11-2008 08:21 PM
LXer: LXDE - Lightweight X11 Desktop Environment for Ubuntu LXer Syndicated Linux News 0 07-06-2008 01:42 PM


All times are GMT -5. The time now is 01:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration