LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices

Reply
 
LinkBack Search this Thread
Old 02-04-2013, 03:26 PM   #1
PLANTROON
LQ Newbie
 
Registered: Aug 2012
Location: Slovakia
Distribution: Slackware, Arch Linux
Posts: 12

Rep: Reputation: 0
Tearing


I had Sapphire Radeon HD 3650 GDDR3 512 MB. A week ago I got PNY nVidia GT520 1GB. Have I made a good choice ? (that nVidia card was very cheap and I need it only for some basic TF2 gaming).

Ok now to the tearing. On both cards I got screen tearing. Radeon card also caused tearing in World of Goo, weird html5 and full screen behavior and stuff like that. The new nVidia card doesn't make any tearing in World of Goo, but if I open steam overlay and move the windows, it's awfully slow. Also, in game it seems a little bit slow. For example Assault Cube runs fine, Sauerbraten even better. Quake 3 engine based games also run fine. Red Orchestra has some settings unavailable but still it looks good and runs without any problems. On my old radeon card it didn't draw shadows properly (only some filled rectangle on the ground, lol it looked funny)...

I have Vsync enabled everywhere where it is possible. I still get tearing... IDK why does this happen. I also tried enabling triple buffering which gave me worse performance and the tearing got even worse. Also I noticed some tearing on youtube vids, I tried some suggestions I found all over the Internet (I even disabled compositing in Xorg.conf thinking it only disables XRandR based compositing managers and then I got Gnome 3 fallback mode and KDE couldn't start at all). So is there any way to completely get rid of tearing?

Now it's a a little bit more difficult to change X server settings since I ran pacman -Syu ck kernel was updated and nvidia driver failed to start ... I did modprobe nvidia -f and it works now. Isn't it weird?

Thank you for any suggestions and interest in helping me... or do I really have to wait for nVidia to make better driver for this card? It's not rly one of the newest cards but still better than Radeon HD 3650 ....
 
Old 02-07-2013, 09:24 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,822

Rep: Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368
Quote:
Originally Posted by PLANTROON View Post
I had Sapphire Radeon HD 3650 GDDR3 512 MB. A week ago I got PNY nVidia GT520 1GB. Have I made a good choice ? (that nVidia card was very cheap and I need it only for some basic TF2 gaming).

Ok now to the tearing. On both cards I got screen tearing. Radeon card also caused tearing in World of Goo, weird html5 and full screen behavior and stuff like that. The new nVidia card doesn't make any tearing in World of Goo, but if I open steam overlay and move the windows, it's awfully slow. Also, in game it seems a little bit slow. For example Assault Cube runs fine, Sauerbraten even better. Quake 3 engine based games also run fine. Red Orchestra has some settings unavailable but still it looks good and runs without any problems. On my old radeon card it didn't draw shadows properly (only some filled rectangle on the ground, lol it looked funny)...

I have Vsync enabled everywhere where it is possible. I still get tearing... IDK why does this happen. I also tried enabling triple buffering which gave me worse performance and the tearing got even worse. Also I noticed some tearing on youtube vids, I tried some suggestions I found all over the Internet (I even disabled compositing in Xorg.conf thinking it only disables XRandR based compositing managers and then I got Gnome 3 fallback mode and KDE couldn't start at all). So is there any way to completely get rid of tearing?

Now it's a a little bit more difficult to change X server settings since I ran pacman -Syu ck kernel was updated and nvidia driver failed to start ... I did modprobe nvidia -f and it works now. Isn't it weird?
You loaded a new kernel, and essentially broke the driver...forcing it to load will obviously cause errors, since you're making it do something it wasn't designed to do. New kernel = new kernel module...so load the new driver, and your problems may go away. Also, you don't say WHICH driver you're using, or from where you got it.
Quote:
Thank you for any suggestions and interest in helping me... or do I really have to wait for nVidia to make better driver for this card? It's not rly one of the newest cards but still better than Radeon HD 3650 ....
Better driver?? nVidia released a new driver for both 32 and 64bit Linux January 21st of this year, which specifically address OpenGL bugs and other issues. Did you try to load it? If you already have the kernel source and development libraries installed, you should just be able to run the .run file you download from nVidia, and it'll compile a custom module for your card/kernel combination, and install it for you.
http://www.geforce.com/drivers/results/56283
 
Old 02-07-2013, 09:35 AM   #3
PLANTROON
LQ Newbie
 
Registered: Aug 2012
Location: Slovakia
Distribution: Slackware, Arch Linux
Posts: 12

Original Poster
Rep: Reputation: 0
I have 313.18 driver downloaded from official Archlinux repos (for the stock kernel) and from ck-repo for kernel with ck patchset. The one for ck is working now, the problem was reported about the driver not being loaded on the new kernel version. I could also simply use nvidia-hook but I was lazy to do so. I still get tearing in videos, games and moreover I noticed a lot of tearing in animations in Libreoffice Impress (really it can't do a smooth transition from one slide to another)
 
Old 02-07-2013, 10:19 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,822

Rep: Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368
Quote:
Originally Posted by PLANTROON View Post
I have 313.18 driver downloaded from official Archlinux repos (for the stock kernel) and from ck-repo for kernel with ck patchset. The one for ck is working now, the problem was reported about the driver not being loaded on the new kernel version. I could also simply use nvidia-hook but I was lazy to do so. I still get tearing in videos, games and moreover I noticed a lot of tearing in animations in Libreoffice Impress (really it can't do a smooth transition from one slide to another)
Ok, well, the only thing I can suggest is to load the official nVidia driver, and compile it for your new kernel. If you don't want to, and you don't want to use the nvidia-hook, there's little else to suggest. You say you updated the kernel, and say here that you're using the driver for the STOCK kernel...which you're not using.

So, you can either address the issue (update driver? downgrade kernel? nvidia-hook?), or live with it.
 
Old 02-07-2013, 10:31 AM   #5
PLANTROON
LQ Newbie
 
Registered: Aug 2012
Location: Slovakia
Distribution: Slackware, Arch Linux
Posts: 12

Original Poster
Rep: Reputation: 0
The only problem is tearing I get. It's not a kernel related issue because I remember the tearing was present when I was using only the stock kernel and only the driver from official repos. I'm basically asking for some settings, or DE I should use to avoid tearing I had an idea ... if it is possible to force Xorg to always use accelerated OpenGL rendering whatever happens on the screen. I think that it should help. Another thing I was thinking about is Wayland with Weston/Kwin-unstable as a window manager. Also other people have problems with tearing on nVidia cards (are amd cards getting really better on Linux?)... I just don't get why nobody cares about it.
 
Old 02-07-2013, 11:00 AM   #6
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 13,822

Rep: Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368Reputation: 2368
Quote:
Originally Posted by PLANTROON View Post
The only problem is tearing I get. It's not a kernel related issue because I remember the tearing was present when I was using only the stock kernel and only the driver from official repos. I'm basically asking for some settings, or DE I should use to avoid tearing I had an idea ... if it is possible to force Xorg to always use accelerated OpenGL rendering whatever happens on the screen. I think that it should help. Another thing I was thinking about is Wayland with Weston/Kwin-unstable as a window manager. Also other people have problems with tearing on nVidia cards (are amd cards getting really better on Linux?)... I just don't get why nobody cares about it.
Ok...again....load the nVidia driver FROM THE NVIDIA SITE and see if that helps. Third party drivers may not do what you want.
 
Old 02-07-2013, 08:38 PM   #7
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 478

Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by PLANTROON View Post
Now it's a a little bit more difficult to change X server settings since I ran pacman -Syu ck kernel was updated and nvidia driver failed to start ... I did modprobe nvidia -f and it works now. Isn't it weird?
Try updating the initramfs. I had this issue a few times when i upgraded the kernel or the nvidia driver.

Code:
update-initramfs -u
as root.
As for the tearing issue - i know what you saying - i had a 8200 IGP and i got tearing on the desktop when i dragged stuff (xfce, unaccelerated desktop mind you). Also, the vsync setting just wouldnt stick between reboots (set from the nvidia control panel) - i had to re enable it every time (it was "enabled", at least the tick was there just wasnt applied automatically).
Flash was always teary, i could do nothing about it.

About the cards - i think hardware-wise the 3650 is faster, because of its faster memory bus (128 bit). The 520 has 64 bit. Anyway, both cards have updated drivers for Steam, you should try both. For the ati card, make sure you use the latest 13.1 legacy drivers (assuming it will work with your x server).

PS. I now have a new mobo and AMD apu with integrated graphics (A8-5500 with 7650D) and i have no tearing issues anywhere (for flash fullscreen i enable the "tear free" option and it does the job just fine). It also runs TF2 well.

Last edited by gradinaruvasile; 02-07-2013 at 08:54 PM.
 
Old 02-08-2013, 12:20 PM   #8
PLANTROON
LQ Newbie
 
Registered: Aug 2012
Location: Slovakia
Distribution: Slackware, Arch Linux
Posts: 12

Original Poster
Rep: Reputation: 0
I installed the package from nVidia and nothing has changed
 
Old 02-10-2013, 02:11 AM   #9
notsure
Member
 
Registered: Jun 2012
Location: D
Distribution: Arch x86_64
Posts: 65

Rep: Reputation: Disabled
So you replaced the HD with the GeForce? What AMD drivers did you run with the HD? proprietary?

I thought disabling the composition manager would fix it as that is what I have to do whenever I watch video.

Have you tried running a different window manager/DE?

I've been an NVIDIA fan for a long time. My next GFX card will be AMD. Better video support for tearing, better multi-monitor support (>=3), overclocking (cannot OC NVIDIA anymore) and hash cracking is far superior.

As far as gaming is concerned, I usually have AntiAliasing maxed out and NVIDIA seems to have the edge with the latest cards.

RED ORCHESTRA IS THE BEST GAME EVER!!!!!!!!!!!! It is too bad there are so few servers to choose from... nothing lasts forever, eh? On that note, I don't enjoy gaming so much anymore.
 
Old 02-10-2013, 04:33 AM   #10
PLANTROON
LQ Newbie
 
Registered: Aug 2012
Location: Slovakia
Distribution: Slackware, Arch Linux
Posts: 12

Original Poster
Rep: Reputation: 0
Now I started using Kwin ... In most applications I could get rid of tearing but I noticed some tearing on the desktop itself. Also, I use Steam for gaming and I noticed some delay when moving a window in overlay in any 2D/3D game ... I move my mouse and the window moves like 500ms later ... when using Big Picture the cursor in overlay does the same thing.... I can run Unigine Sanctuary, Unigine Heaven, Assaultcube, ... with no tearing. I also managed to play Warsow with no tearing at all. The tearing still occurs in Team Fortress 2 and some 2D games are very slow So I need better drivers because I think this cheap card should handle some 2D graphics....
 
Old 02-10-2013, 11:34 AM   #11
gradinaruvasile
Member
 
Registered: Apr 2010
Location: Cluj, Romania
Distribution: Debian Testing
Posts: 478

Rep: Reputation: 100Reputation: 100
There are no better drivers.
Unfortunately 2d graphics isnt that fast with the proprietary drivers.
The OSS Nouveau on the other hand seems to be better in that regard, but i dont think you want to trade all the 3d speed for some 2d improvements.
 
Old 02-10-2013, 11:38 AM   #12
PLANTROON
LQ Newbie
 
Registered: Aug 2012
Location: Slovakia
Distribution: Slackware, Arch Linux
Posts: 12

Original Poster
Rep: Reputation: 0
I tried enlightenment 17 just a while ago and there was no tearing at all. The problem is that I don't want to switch to e17. So there should be a way to completely get rid of tearing in KWin. I'm trying to find it now with different settings and stuff like that ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia vs ATI and tearing bucovaina78 Linux - Desktop 16 09-16-2012 06:39 AM
tightvncviewer tearing 10110111 Linux - Software 2 01-23-2010 02:14 AM
Nvidia Screen tearing with Xv kryptobs2000 Linux - Software 0 01-15-2008 09:57 AM
Tearing my hair out!! kcommins Linux - Software 6 08-29-2005 02:36 PM
nVidia GL Tearing FLOODS Fedora 1 04-09-2005 10:04 AM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration