LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Virtualization and Cloud
User Name
Password
Linux - Virtualization and Cloud This forum is for the discussion of all topics relating to Linux Virtualization and Linux Cloud platforms. Xen, KVM, OpenVZ, VirtualBox, VMware, Linux-VServer and all other Linux Virtualization platforms are welcome. OpenStack, CloudStack, ownCloud, Cloud Foundry, Eucalyptus, Nimbus, OpenNebula and all other Linux Cloud platforms are welcome. Note that questions relating solely to non-Linux OS's should be asked in the General forum.

Notices



Reply
 
Search this Thread
Old 07-09-2013, 12:38 PM   #1
Gullible Jones
Member
 
Registered: Apr 2011
Posts: 142

Rep: Reputation: 10
Making X11 work reliably on a Xen 4.1 dom0, with some caveats


I currently have a workstation set up with Debian Wheezy as a dom0 on top of Xen 4.1 (from the Wheezy repository). I need to have X11 running and stable on the dom0, on this workstation. X11 has been very unstable with the video card, a Radeon HD 4200; switching VTs tends to corrupt the screen, and X sometimes segfaults on start.

Caveat 1: I can't use the Wheezy nonfree repo, which means X has to work without the proprietary Radeon firmware.

Caveat 2: I'm stuck with a 1680x1050 monitor, and I don't know if the video BIOS supports widescreen resolutions. If it doesn't, using the vesa driver will be a problem.

Anyway, the current state of affairs:

- radeon driver works but is unstable, as indicated above. Hardware acceleration and kernel modesetting don't work, since I can't use the proprietary firmware.

- vesa driver doesn't work; X refuses to start, claiming that no usable screens exist.

- fbdev driver can't work at the moment, because I'm having trouble enabling the Linux framebuffer...

Any advice? Is this solvable, or am I SOL?

Last edited by Gullible Jones; 07-12-2013 at 11:46 AM.
 
Old 07-12-2013, 11:47 AM   #2
Gullible Jones
Member
 
Registered: Apr 2011
Posts: 142

Original Poster
Rep: Reputation: 10
SOLVED... by user education. You're not supposed to run X in the dom0; you're supposed to run your desktop in a domU, and administer the minimal dom0 through ssh, or something.

Edit: Ugh, apparently this only works for server/client setups in a lot of cases. Getting the domU to see the video hardware is a pain.

For now I'm switching to KVM/libvirt, which may be theoretically inferior to Xen but has the advantage of actually working for desktop scenarios.

Last edited by Gullible Jones; 07-12-2013 at 05:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup Slackware64 HVM with Xen Dom0 Kernel 2.6.31.4 in Fedora 11 x86-64 Dom0 Teo En Ming Linux - Virtualization and Cloud 0 11-01-2009 09:24 AM
LXer: Setup Xen 3.3.0 Ubuntu Intrepid Server Dom0 via build xen-kernel based on http: LXer Syndicated Linux News 0 01-03-2009 06:50 PM
LXer: Setup Xen 3.3.0 Ubuntu Intrepid Server Dom0 via build xen-kernel based on http: LXer Syndicated Linux News 0 01-03-2009 03:50 PM
LXer: Setup Xen 3.3.0 Ubuntu Intrepid Server Dom0 via build xen-kernel based on http: LXer Syndicated Linux News 0 01-03-2009 01:00 PM
LXer: Backport Intrepid Xen 3.3 Hypervisor to Ubuntu Hardy Dom0 (2.6.24-21-xen) LXer Syndicated Linux News 0 11-13-2008 07:11 PM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration