LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices



Reply
 
Search this Thread
Old 07-06-2005, 01:02 PM   #1
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Rep: Reputation: 0
Wireless DNS Issue


I just installed the newest SimplyMepis, looks great! Everything was configured from the start except my wireless card. I set up NDISWRAPPER to work with my D-Link DWL-G510 on the Marvell W8300 chipset and that seemed to work with my DWL-624 router.

However, when I try to load a page in firefox, it just times out when resolving the domain. Obvious DNS issue, but where? I can log in to my router admin page - 192.168.0.1 - without a hitch so are there any settings I should change there or in the Mepis control panel? If I use DHCP or manually input the settings, I get the same result.

I'm using a managed connection, no wep or wpa.

It's late so I'm sure it's necessary to include more info than I've included to diagnose this, but I'm hoping it's an easy fix, and if not... I'll post it tomorrow.

Here's my Lan:
LAN
MAC Address
00-0F-#D-#F-#5-A0
IP Address
192.168.0.1
Subnet Mask
255.255.255.0
DHCP Server
Enabled

My Wan:
MAC Address
00-##-##-#F-#E-#A
Connection
DHCP Client Connected
IP Address
192.168.1.96
Subnet Mask
255.255.255.0
Default Gateway
192.168.1.254
DNS
65.7.xxx.xxx

I've posted this question on the mepislovers.org forum and I was told to guarddog firewall is the reason why I can't connect to domain names. If this was the case why can I login to my router address - 192.168.0.1 - as I assume this is connecting through port 80. I am able to ping my wan IP 65.7.xxx.xxx so I believe there is something I'm missing.

Right now I'm using DHCP, if I use manual settings what is the broadcast iP supposed to be, default? 192.168.0.255?

Thanks for any feedback.
 
Old 07-06-2005, 01:16 PM   #2
priller
Member
 
Registered: Jan 2004
Distribution: Debian etch
Posts: 202

Rep: Reputation: 30
You probably need to setup the firewall to allow dns requests through. You can login to the router because it doesn't need todo a dns request to resolve the domainname.
 
Old 07-06-2005, 02:05 PM   #3
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
That makes sense, I'll try this when I get off work. Thank you much.
 
Old 07-06-2005, 03:30 PM   #4
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
Iwould just turn off the firewall and test..

if that works.. then do as Priller suggested..

does the problem only exist in FireFox.? Do you get the
same behavior in Konqueror??

hth
 
Old 07-06-2005, 03:56 PM   #5
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Yeah I'm going to turn it off. It's not just in Firefox but also Konq, and if I try to ping an domain name, it doesn't resolve.
 
Old 07-06-2005, 06:10 PM   #6
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
cat your /etc/resolv.conf

should look something like this ( I am on Cox's network)

Code:
search ok.cox.net
nameserver 68.12.16.25
nameserver 68.12.16.30
nameserver 68.2.16.25
lookup file bind
you should have your ISP dns servers in there..
also try
netstat -rn..

should look somthing like this
Code:
$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

hth
 
Old 07-06-2005, 07:37 PM   #7
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Ok, disabling the firewall didn't do anything for me. the solution seems obvious to you guys but to me, I just need help putting it all together. Here's all the info out on the table. Hopefully this will yield success.

Here's the output of netstat -rn:
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 0.0.0.0 0.0.0.0 UG 0 0 0 wlan0

...something seems off here?

Here's the output of cat /etc/resolv.conf:
search launchmodem.com
nameserver 192.168.0.1

....it looks like my router has become my name server?


Here's my setup in MEPIS OS Center > Network Interfaces:

Status
lo ip: 127.0.0.1
eth0 ip: down
wlan0 ip: 192.168.1.100
wireless is: on wlan0
-----
Wireless
ess id: xxxxxx
mode: infrastructure
#then i have none of the following checked
encryption key
frequency
nwid/domain (cell id)
----
wlan0
[x] Use DHCP for IP
Timeout: 15 sec
------------------------
 
Old 07-06-2005, 08:55 PM   #8
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
ok.. now the solution.. is not obvious.. we are troubleshooting here.. :-)

not every problem is the same.. so hang in there..

do me a favor.. check your wireless router configuration.. you should get
2 or 3 dns servers and your gateway listed..

also.. do you have dhcp enabled on your router..???
if so you should also get your ISP dns servers on your
client ..
 
Old 07-07-2005, 01:41 AM   #9
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Ok, I'm trying to be patient, but it's like I'm so close to finally getting linux fully functional on my computer that it's driving me even more insane! :]

Straight from my router:

LAN
MAC Address 00-0F-#D-#F-##-A0
IP Address 192.168.0.1
Subnet Mask 255.255.255.0
DHCP Server Enabled

WAN
MAC Address 00-11-95-2F-4E-5A
Connection DHCP Client Connected
IP Address 192.168.1.96
Subnet Mask 255.255.255.0
Default Gateway 192.168.1.254
DNS 65.7.###.##

Wireless 802.11g (mixed mode)
SSID defunk
Channel 6
Encryption Disabled

On this winxp laptop, "ipconfig /all" shows:
Ethernet adapter wireless network connection:
connection-specific DNS suffix: launchmodem.com
description: high rate wireless adapter
physical addres: some #'s
DHCP enabled: YES
Autoconfig enabled: Yes
IP Address: 192.168.0.101
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.0.1
DHCP server: 192.168.0.1
DNS Servers: 192.168.0.1

Lease obtained
Lease expired

Keep the help coming, feels like we're getting somewhere.
 
Old 07-07-2005, 08:38 AM   #10
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
something is amiss with your WAN configuration..
The IP should be something other than
192.168.x.x ( that is private IP space)

[quote]
Q. What are private IP addresses?
A. The Internet Assigned Numbers Authority (IANA) has reserved the following three blocks of the IP address space for private internets (local networks):

10.0.0.0 - 10.255.255.255
172.16.0.0 - 172.31.255.255
192.168.0.0 - 192.168.255.255

Also, IP addresses in the range of 169.254.0.0 -169.254.255.255 are reserved for Automatic Private IP Addressing.

These IP's should not be used on the Internet.
[/quote ]

Unless your cable/dsl modem is also running a dhcp server.. ??
that would be the reason for the private ip addresses you are
seeing on your WAN...

Is your Router directly connected to your cable/dsl modem?

go ahead and describe your network setup including model
numbers on the modem and router..

i.e.
mine

surfboard cable modem (model #)
|
|
OpenBSD 3.6 firewall
|
NetGear Switch
/ \---- Windows PC
/ \
Linux Linux Mail Server
PC
 
Old 07-07-2005, 07:31 PM   #11
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
Hey here's my setup:

Westell Wirespeed DSL Modem >
|
D-Link DWL-624 Router >
|
Now I have one desktop hardwired (XP) and 3 computers wireless: Desktop w/ MEPIS using DWL-G510 PCI Card(suspect in question), IBM Laptop (XP), Compaq Laptop (win2000)

Sincerely, thanks for your time everyone in diagnosing this for me.
 
Old 07-08-2005, 09:35 AM   #12
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
did you know your Westell Wirespeed DSL router
is also doing DHCP???
and your wireless
router is also doing DHCP...

so you are doing a double NAT... which works ok.. for the
most part..

My guess is that you are only having problems with all
your machines..???? based on your output from
ipconfig /all..

Simple fix:
Put your DNS IPS in your wireless router.. then your clients
should get them..
I would turn off the DHCP server in DSL router and assign
a static address to it..

or...
just get a PCMCIA card and plug it into your DSL modem.. remove
your D-Link from the picture..

Googling on your modem
here
Quote:
The router runs on a default IP address of 192.168.1.1 and can be accessed using your favourite web browser by pointing it to http://192.168.1.1. By default, the inbuilt DHCP server is operational and will assign your computer a suitable IP address if configured to accept one (described within the quick start guide). The unit does not support access via other means, such as telnet.

Last edited by thekat; 07-08-2005 at 10:44 AM.
 
Old 07-08-2005, 11:28 AM   #13
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
No, the thing is every computer works, besides my Linux box running MEPIS. I have just set up this computer with MEPIS and am just trying to get the same settings I have on my windows boxes (which detected it automatically btw) running with MEPIS.
 
Old 07-08-2005, 02:06 PM   #14
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
I C..
hmm..
post your ifconfig from your Mepis box..

could be that your wi-fi isn't supported..


Last edited by thekat; 07-08-2005 at 03:19 PM.
 
Old 07-08-2005, 07:27 PM   #15
digitzero
LQ Newbie
 
Registered: Jul 2005
Posts: 11

Original Poster
Rep: Reputation: 0
I do believe that my wi-fi is supported because it's known to work with ndiswrapper for others. And also, like I said, I can connect to my router. Also, using kWiFiManager, when I scan for networks I am able to see my router's SSID and it appears to connect.

Here's my ifconfig output:

lo:
Link encap: Local loopback
inet adddr: 127.0.0.1 Mask: 255.0.0.0
inet6 addr: ::1/128 scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric: 1
RX packets: 10 errors: 0 dropped:0 overruns:0 frame:0
TX packets: 10 errors:0 dropped:0 overruns: 0 carrier:0
collisions: 0 txqueuelen:0
RX bytes: 500 (500.0 b) tx bytes:500 (500.0 b)

wlan0:
Link encap:ethernet HWaddr 00:11:95:2F:4E:5A
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80:211:95ff:fe2f:4e5a/64 scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:122 errors:0 dropped:0 overruns:0 frame:0
tx packets:106 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
rx bytes:30722 (30.0 KiB) tx bytes:14674 (14.3 KiB)
Memory:ed000000-ed00ffff

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dns issue Paxmaster Linux - Security 2 08-20-2005 03:17 PM
DNS issue dementiaa Linux - Software 0 01-04-2005 01:21 PM
DNS issue or caching issue? AZDAVE Linux - Networking 7 10-02-2004 01:28 AM
Dns Issue!!! treedstang Linux - Networking 0 06-04-2004 04:44 PM
dns issue no.2 iquadri1 Linux - Networking 0 09-29-2001 02:22 PM


All times are GMT -5. The time now is 05:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration