LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 08-10-2004, 02:00 AM   #1
slacka
LQ Newbie
 
Registered: Jul 2004
Location: Chico, CA
Distribution: Slackware 10
Posts: 21

Rep: Reputation: 15
Setting up wireless in Slack 10


With the help of some posts on this forum, I managed to get the wireless card working on my Inspiron 5100 (Dell TrueMobil 1400) running Slackware 10. Here's how to do it:


First, ensure wireless support is enabled in kernel configuration, along with TCP/IP. Recompile, if you need to, and get a copy of NDISWrapper. There are plenty of posts on this forum with instructions on compiling/installing it.


After ndiswrapper is installed, the ndiswrapper module needs to be loaded:

modprobe ndiswrapper


Then, various settings of the card need to be configured:

iwconfig wlan0 enc restricted #Turns on encryption
iwconfig wlan0 nick <your computer nick here> #Sets computer nick
iwconfig wlan0 mode managed
iwconfig wlan0 key <s:<text wep key here>> OR <hex wep key here> #Sets the WEP key (note: this key must be 13 characters long for 128-bit encryption)
iwconfig wlan0 essid <network name> #Name of network being connected to


Next, bring up the wireless interface:

ifconfig wlan0 up


Finally, get an IP address from the router:

dhcpcd wlan0


This is cut directly from my rc.local script (to bring up wireless during boot):

modprobe ndiswrapper
iwconfig wlan0 enc restricted
iwconfig wlan0 nick xxxx
iwconfig wlan0 mode managed
iwconfig wlan0 key s:xxxxxxxxxxxxx
iwconfig wlan0 essid xxxxxxxxx
ifconfig wlan0 up
dhcpcd wlan0


If, when you type in "#route -n" to check the routing table, eth0 (or any interface other than your wireless interface) is set as the default interface, you need to change one of your init files so eth0 is not set, at runtime, as the default. There may be an easier way to do this, but this worked for me.

I got this out of the Linux PPP HOWTO by Corwin Light-Williams and Joshua Drake ( 2000 by Commandprompt, Inc and 1997 by Robert Hart), which can be found here: http://www.ibiblio.org/pub/Linux/docs/HOWTO/PPP-HOWTO

Even though this howto is for ppp, it applies in this case, for changing the default route.

"You should also be able to see a route to the the remote host (and beyond). To do this, issue the command

route -n

You should se something like:-

Kernel routing table
Destination Gateway Genmask Flags MSS Window Use Iface
10.144.153.3 * 255.255.255.255 UH 1500 0 1 ppp0
127.0.0.0 * 255.0.0.0 U 3584 0 11 lo
10.0.0.0 * 255.0.0.0 U 1500 0 35 eth0
default 10.144.153.3 * UG 1500 0 5 ppp0

Of particular importance here, notice we have TWO entries pointing to
our ppp interface.

The first is a HOST route, (indicated by the H flag) and that allows
us to see the host to which we are connected to - but no further.

The second is the default route, (established by giving pppd the
option defaultroute. This is the route that tells our Linux PC to send
any packets NOT destined for the local Ethernet(s) - to which we have
specific network routes - to the PPP server itself. The PPP server
then is responsible for routing our packets out onto the Internet and
routing the return packets back to us.

If you do not see a routing table with two entries, something is
wrong. In particular if your syslog shows a message telling you pppd
is not replacing an existing default route, then you have a default
route pointing at your Ethernet interface - which MUST be replaced by
a specific network route: YOU CAN ONLY HAVE ONE DEFAULT ROUTE!!!

You will need to explore your system initialization files to find out
where this default route is being set up (it will use a route add
default... command). Change this command to something like route add
net...."

The init file they are talking about is rc.inet1, located in /etc/rc.d
The line that needs to be changed is line 105; it looks like this:

/sbin/route add default gw ${GATEWAY} metric 1

Change 'default' to read 'net', like this:

/sbin/route add net gw ${GATEWAY} metric 1

Bring down the eth0 interface (or whatever your default interface is):

#ifconfig eth0 down

Ensure your wireless interface is up:

#ifconfig wlan0 up

And make your wireless interface the default (wlan0 in my case):

#route add default gw <ip address of your router>


Hope this helps the slackers out there. Any questions, feel free to email me.
This definately works for me, because I'm posting from wireless linux.


This guy's post is also of great value, if you find any of this confusing:
http://www.linuxquestions.org/questi...109#post843109

Last edited by slacka; 08-10-2004 at 01:20 PM.
 
Old 08-10-2004, 03:13 AM   #2
peok
Member
 
Registered: Aug 2003
Location: CA, USA
Distribution: (Almost) LFS 6.1.1
Posts: 91

Rep: Reputation: 15
Great. I would suggest making an entry in the HCL (Hardware Compatability List) that way if somebody with your card wants to know this, hopefully they can find it easily there .

Under HCL - Network Cards - Dell there's only a "Broadcomm Dell True Mobile 1300" so it looks like you'd have a new entry!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up wireless network cards in Slack 10?? Rhatlinux Slackware 2 10-21-2004 07:49 PM
Setting up Eclipse 3.0 on slack 9.1 pgrimes Linux - Software 2 07-29-2004 04:02 AM
Setting up my wireless LAN internet on my slack laptop :D Belize Linux - Wireless Networking 17 10-04-2003 01:15 PM
setting time in Slack 3.5 KnightAbel Slackware 4 12-20-2002 11:01 PM
Setting up little network with slack Pres Linux - Networking 4 08-12-2002 09:12 AM


All times are GMT -5. The time now is 05:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration