LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-09-2012, 07:17 AM   #1
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 191

Rep: Reputation: 6
mc takes 30 seconds to start slackware current


Hi guys

I think somthing is not right as mc takes 30 seconds to start slackware current

Even on root and any user !


Any ideas !

regards

lawrence
 
Old 05-09-2012, 07:34 AM   #2
Slackyman
Member
 
Registered: Mar 2011
Location: Rome - Italy
Distribution: Slackware 13.1
Posts: 347

Rep: Reputation: 44
Is it a fresh install?
Can you post the otput of your /var/log/dmesg?

Last edited by Slackyman; 05-09-2012 at 07:41 AM.
 
Old 05-09-2012, 08:11 AM   #3
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,336

Rep: Reputation: 376Reputation: 376Reputation: 376Reputation: 376
i tested on Slackware-Current (32 bit) and it takes less than 1s to start mc
check the output of dmesg
 
Old 05-09-2012, 08:36 AM   #4
schmatzler
Member
 
Registered: Jan 2011
Location: Germany
Distribution: Slackware64 -current + Multilib
Posts: 113

Rep: Reputation: 39
I had the same problem on a Debian system a while ago.

I deleted all mc-related stuff in /tmp and in $HOME, worked fine again after that.

There where no error messages in dmesg, though.
 
Old 05-09-2012, 09:44 AM   #5
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 191

Original Poster
Rep: Reputation: 6
@ Slackyman Its a brand new fresh install current 64 bit kde 4.8.2

here is the output of dmesg


[ 0.792889] NET: Registered protocol family 1
[ 0.792951] RPC: Registered named UNIX socket transport module.
[ 0.792953] RPC: Registered udp transport module.
[ 0.792955] RPC: Registered tcp transport module.
[ 0.792956] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.792978] pci 0000:00:1a.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 0.793003] pci 0000:00:1a.0: PCI INT A disabled
[ 0.793023] pci 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 0.793044] pci 0000:00:1d.0: PCI INT A disabled
[ 0.793063] pci 0000:01:00.0: Boot video device
[ 0.793082] pci 0000:04:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 0.793111] pci 0000:04:00.0: PCI INT A disabled
[ 0.793115] PCI: CLS 64 bytes, default 64
[ 0.793147] Trying to unpack rootfs image as initramfs...
[ 0.840967] Freeing initrd memory: 3996k freed
[ 0.841345] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[ 0.841351] Placing 64MB software IO TLB between ffff8800e305b000 - ffff8800e705b000
[ 0.841354] software IO TLB at phys 0xe305b000 - 0xe705b000
[ 0.842147] Intel AES-NI instructions are not detected.
[ 0.842318] audit: initializing netlink socket (disabled)
[ 0.842326] type=2000 audit(1336494816.445:1): initialized
[ 0.868767] VFS: Disk quotas dquot_6.5.2
[ 0.868820] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[ 0.869034] ROMFS MTD (C) 2007 Red Hat, Inc.
[ 0.869073] msgmni has been set to 15908
[ 0.870001] async_tx: api initialized (async)
[ 0.870068] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[ 0.870087] io scheduler noop registered
[ 0.870091] io scheduler deadline registered
[ 0.870142] io scheduler cfq registered (default)
[ 0.870207] pcieport 0000:00:01.0: setting latency timer to 64
[ 0.870225] pcieport 0000:00:01.0: irq 40 for MSI/MSI-X
[ 0.870306] pcieport 0000:00:1c.0: setting latency timer to 64
[ 0.870343] pcieport 0000:00:1c.0: irq 41 for MSI/MSI-X
[ 0.870421] pcieport 0000:00:1c.3: setting latency timer to 64
[ 0.870457] pcieport 0000:00:1c.3: irq 42 for MSI/MSI-X
[ 0.870587] pcieport 0000:00:01.0: Signaling PME through PCIe PME interrupt
[ 0.870590] pci 0000:01:00.0: Signaling PME through PCIe PME interrupt
[ 0.870592] pci 0000:01:00.1: Signaling PME through PCIe PME interrupt
[ 0.870595] pcie_pme 0000:00:01.0cie01: service driver pcie_pme loaded
[ 0.870609] pcieport 0000:00:1c.0: Signaling PME through PCIe PME interrupt
[ 0.870611] pci 0000:02:00.0: Signaling PME through PCIe PME interrupt
[ 0.870616] pcie_pme 0000:00:1c.0cie01: service driver pcie_pme loaded
[ 0.870629] pcieport 0000:00:1c.3: Signaling PME through PCIe PME interrupt
[ 0.870632] pci 0000:04:00.0: Signaling PME through PCIe PME interrupt
[ 0.870637] pcie_pme 0000:00:1c.3cie01: service driver pcie_pme loaded
[ 0.870687] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
[ 0.870753] vesafb: mode is 1024x768x16, linelength=2048, pages=1
[ 0.870755] vesafb: scrolling: redraw
[ 0.870757] vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
[ 0.871236] vesafb: framebuffer at 0xf1000000, mapped to 0xffffc90004100000, using 3072k, total 14336k
[ 0.887025] Console: switching to colour frame buffer device 128x48
[ 0.901790] fb0: VESA VGA frame buffer device
[ 0.901946] intel_idle: MWAIT substates: 0x1120
[ 0.901947] intel_idle: v0.4 model 0x2A
[ 0.901948] intel_idle: lapic_timer_reliable_states 0xffffffff
[ 0.902087] ERST: Table is not found!
[ 0.902196] GHES: HEST is not enabled!
[ 0.904619] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[ 1.841099] Refined TSC clocksource calibration: 3292.520 MHz.
[ 1.841314] Switching to clocksource tsc
[ 3.970051] floppy0: no floppy controllers found
[ 3.971349] brd: module loaded
[ 3.971530] Loading iSCSI transport class v2.0-870.
[ 3.971912] ahci 0000:00:1f.2: version 3.0
[ 3.971921] ahci 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[ 3.972157] ahci 0000:00:1f.2: irq 43 for MSI/MSI-X
[ 3.983027] ahci 0000:00:1f.2: AHCI 0001.0300 32 slots 6 ports 6 Gbps 0x3f impl SATA mode
[ 3.983306] ahci 0000:00:1f.2: flags: 64bit ncq sntf pm led clo pio slum part ems sxs apst
[ 3.983555] ahci 0000:00:1f.2: setting latency timer to 64
[ 3.993442] scsi0 : ahci
[ 3.993581] scsi1 : ahci
[ 3.993707] scsi2 : ahci
[ 3.993832] scsi3 : ahci
[ 3.993959] scsi4 : ahci
[ 3.994087] scsi5 : ahci
[ 3.999095] ata1: SATA max UDMA/133 abar m2048@0xf7225000 port 0xf7225100 irq 43
[ 4.004184] ata2: SATA max UDMA/133 abar m2048@0xf7225000 port 0xf7225180 irq 43
[ 4.009157] ata3: SATA max UDMA/133 abar m2048@0xf7225000 port 0xf7225200 irq 43
[ 4.014005] ata4: SATA max UDMA/133 abar m2048@0xf7225000 port 0xf7225280 irq 43
[ 4.018788] ata5: SATA max UDMA/133 abar m2048@0xf7225000 port 0xf7225300 irq 43
[ 4.023496] ata6: SATA max UDMA/133 abar m2048@0xf7225000 port 0xf7225380 irq 43
[ 4.029423] scsi6 : pata_legacy
[ 4.033922] ata7: PATA max PIO4 cmd 0x1f0 ctl 0x3f6 irq 14
[ 4.331872] ata1: SATA link down (SStatus 0 SControl 300)
[ 4.336543] ata6: SATA link down (SStatus 0 SControl 300)
[ 4.341112] ata5: SATA link down (SStatus 0 SControl 300)
[ 4.345538] ata3: SATA link down (SStatus 0 SControl 300)
[ 4.349834] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 4.354217] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[ 4.358480] ata4.00: ATAPI: HL-DT-ST DVDRAM GH22LS40, LL02, max UDMA/100
[ 4.362911] ata2.00: ATA-8: ST31000528AS, CC46, max UDMA/133
[ 4.367199] ata2.00: 1953525168 sectors, multi 16: LBA48 NCQ (depth 31/32)
[ 4.372768] ata2.00: configured for UDMA/133
[ 4.377016] ata4.00: configured for UDMA/100
[ 4.377096] scsi 1:0:0:0: Direct-Access ATA ST31000528AS CC46 PQ: 0 ANSI: 5
[ 4.377227] sd 1:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[ 4.377259] sd 1:0:0:0: [sda] Write Protect is off
[ 4.377260] sd 1:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 4.377273] sd 1:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 4.429286] sda: sda1 sda2 sda3 sda4
[ 4.433707] sd 1:0:0:0: [sda] Attached SCSI disk
[ 4.504097] scsi 3:0:0:0: CD-ROM HL-DT-ST DVDRAM GH22LS40 LL02 PQ: 0 ANSI: 5
[ 4.614158] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
[ 4.618623] cdrom: Uniform CD-ROM driver Revision: 3.20
[ 4.623081] sr 3:0:0:0: Attached scsi CD-ROM sr0
[ 4.623457] scsi7 : pata_legacy
[ 4.627799] ata8: PATA max PIO4 cmd 0x170 ctl 0x376 irq 15
[ 4.782768] i8042: PNP: No PS/2 controller found. Probing ports directly.
[ 4.790262] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 4.794695] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 4.799151] mousedev: PS/2 mouse device common for all mice
[ 4.803532] rtc_cmos 00:04: RTC can wake from S4
[ 4.807912] rtc_cmos 00:04: rtc core: registered rtc_cmos as rtc0
[ 4.812202] rtc0: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[ 4.816492] md: linear personality registered for level -1
[ 4.820857] md: raid0 personality registered for level 0
[ 4.825324] md: raid1 personality registered for level 1
[ 4.829805] md: raid10 personality registered for level 10
[ 4.834377] md: raid6 personality registered for level 6
[ 4.839039] md: raid5 personality registered for level 5
[ 4.843557] md: raid4 personality registered for level 4
[ 4.848069] md: multipath personality registered for level -4
[ 4.852783] device-mapper: uevent: version 1.0.3
[ 4.857560] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
[ 4.862814] cpuidle: using governor ladder
[ 4.868436] cpuidle: using governor menu
[ 4.873462] TCP cubic registered
[ 4.878291] Initializing XFRM netlink socket
[ 4.883476] NET: Registered protocol family 17
[ 4.888415] Registering the dns_resolver key type
[ 4.893892] registered taskstats version 1
[ 4.907201] rtc_cmos 00:04: setting system clock to 2012-05-08 16:33:41 UTC (1336494821)
[ 4.913232] Freeing unused kernel memory: 664k freed
[ 4.918643] Write protecting the kernel read-only data: 8192k
[ 4.925704] Freeing unused kernel memory: 964k freed
[ 4.931738] Freeing unused kernel memory: 360k freed
[ 4.949826] usbcore: registered new interface driver usbhid
[ 4.955204] usbhid: USB HID core driver
[ 4.961148] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 4.966526] ehci_hcd 0000:00:1a.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 4.971954] ehci_hcd 0000:00:1a.0: setting latency timer to 64
[ 4.971957] ehci_hcd 0000:00:1a.0: EHCI Host Controller
[ 4.977328] ehci_hcd 0000:00:1a.0: new USB bus registered, assigned bus number 1
[ 4.982611] ehci_hcd 0000:00:1a.0: debug port 2
[ 4.991659] ehci_hcd 0000:00:1a.0: cache line size of 64 is not supported
[ 4.991674] ehci_hcd 0000:00:1a.0: irq 16, io mem 0xf7227000
[ 5.005691] ehci_hcd 0000:00:1a.0: USB 2.0 started, EHCI 1.00
[ 5.010758] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 5.015798] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 5.020845] usb usb1: Product: EHCI Host Controller
[ 5.025862] usb usb1: Manufacturer: Linux 3.2.13 ehci_hcd
[ 5.030831] usb usb1: SerialNumber: 0000:00:1a.0
[ 5.035925] hub 1-0:1.0: USB hub found
[ 5.040863] hub 1-0:1.0: 2 ports detected
[ 5.045769] ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
[ 5.050756] ehci_hcd 0000:00:1d.0: setting latency timer to 64
[ 5.050759] ehci_hcd 0000:00:1d.0: EHCI Host Controller
[ 5.055793] ehci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
[ 5.060771] ehci_hcd 0000:00:1d.0: debug port 2
[ 5.069470] ehci_hcd 0000:00:1d.0: cache line size of 64 is not supported
[ 5.069482] ehci_hcd 0000:00:1d.0: irq 23, io mem 0xf7226000
[ 5.083447] ehci_hcd 0000:00:1d.0: USB 2.0 started, EHCI 1.00
[ 5.088360] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[ 5.093307] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 5.098269] usb usb2: Product: EHCI Host Controller
[ 5.103293] usb usb2: Manufacturer: Linux 3.2.13 ehci_hcd
[ 5.108411] usb usb2: SerialNumber: 0000:00:1d.0
[ 5.113778] hub 2-0:1.0: USB hub found
[ 5.118796] hub 2-0:1.0: 2 ports detected
[ 5.124562] xhci_hcd 0000:04:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 5.129556] xhci_hcd 0000:04:00.0: setting latency timer to 64
[ 5.129560] xhci_hcd 0000:04:00.0: xHCI Host Controller
[ 5.134598] xhci_hcd 0000:04:00.0: new USB bus registered, assigned bus number 3
[ 5.139827] xhci_hcd 0000:04:00.0: irq 19, io mem 0xf7100000
[ 5.144921] xhci_hcd 0000:04:00.0: irq 44 for MSI/MSI-X
[ 5.144925] xhci_hcd 0000:04:00.0: irq 45 for MSI/MSI-X
[ 5.144927] xhci_hcd 0000:04:00.0: irq 46 for MSI/MSI-X
[ 5.144930] xhci_hcd 0000:04:00.0: irq 47 for MSI/MSI-X
[ 5.144933] xhci_hcd 0000:04:00.0: irq 48 for MSI/MSI-X
[ 5.145021] usb usb3: New USB device found, idVendor=1d6b, idProduct=0002
[ 5.150157] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 5.155328] usb usb3: Product: xHCI Host Controller
[ 5.160492] usb usb3: Manufacturer: Linux 3.2.13 xhci_hcd
[ 5.165584] usb usb3: SerialNumber: 0000:04:00.0
[ 5.170691] xHCI xhci_add_endpoint called for root hub
[ 5.170692] xHCI xhci_check_bandwidth called for root hub
[ 5.170755] hub 3-0:1.0: USB hub found
[ 5.175667] hub 3-0:1.0: 2 ports detected
[ 5.180531] xhci_hcd 0000:04:00.0: xHCI Host Controller
[ 5.185610] xhci_hcd 0000:04:00.0: new USB bus registered, assigned bus number 4
[ 5.190631] usb usb4: New USB device found, idVendor=1d6b, idProduct=0003
[ 5.195636] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 5.200641] usb usb4: Product: xHCI Host Controller
[ 5.205581] usb usb4: Manufacturer: Linux 3.2.13 xhci_hcd
[ 5.210480] usb usb4: SerialNumber: 0000:04:00.0
[ 5.215448] xHCI xhci_add_endpoint called for root hub
[ 5.215449] xHCI xhci_check_bandwidth called for root hub
[ 5.215529] hub 4-0:1.0: USB hub found
[ 5.220355] hub 4-0:1.0: 2 ports detected
[ 5.371534] usb 1-1: new high-speed USB device number 2 using ehci_hcd
[ 5.490525] usb 1-1: New USB device found, idVendor=8087, idProduct=0024
[ 5.495513] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 5.500787] hub 1-1:1.0: USB hub found
[ 5.505677] hub 1-1:1.0: 6 ports detected
[ 5.612703] usb 2-1: new high-speed USB device number 2 using ehci_hcd
[ 5.731738] usb 2-1: New USB device found, idVendor=8087, idProduct=0024
[ 5.736684] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 5.742104] hub 2-1:1.0: USB hub found
[ 5.747143] hub 2-1:1.0: 8 ports detected
[ 5.826181] usb 1-1.4: new low-speed USB device number 3 using ehci_hcd
[ 5.923884] usb 1-1.4: New USB device found, idVendor=045e, idProduct=0752
[ 5.928898] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5.933885] usb 1-1.4: Product: Wired Keyboard 400
[ 5.938870] usb 1-1.4: Manufacturer: Microsoft
[ 5.948090] input: Microsoft Wired Keyboard 400 as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0/input/input0
[ 5.953496] generic-usb 0003:045E:0752.0001: input,hidraw0: USB HID v1.11 Keyboard [Microsoft Wired Keyboard 400] on usb-0000:00:1a.0-1.4/input0
[ 6.026532] usb 2-1.1: new low-speed USB device number 3 using ehci_hcd
[ 6.122714] usb 2-1.1: New USB device found, idVendor=04f3, idProduct=02f4
[ 6.128369] usb 2-1.1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 6.134011] usb 2-1.1: Product: 2.4G Wireless Mouse
[ 6.143625] input: 2.4G Wireless Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input1
[ 6.149918] generic-usb 0003:04F3:02F4.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [2.4G Wireless Mouse] on usb-0000:00:1d.0-1.1/input0
[ 6.240285] udev[1086]: starting version 165
[ 8.077238] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 8.717489] loop: module loaded
[ 9.095191] udev[1261]: starting version 165
[ 9.287701] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2
[ 9.294201] ACPI: Power Button [PWRB]
[ 9.300681] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[ 9.307317] ACPI: Power Button [PWRF]
[ 9.491143] mei: module is from the staging directory, the quality is unknown, you have been warned.
[ 9.498062] mei 0000:00:16.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 9.504841] mei 0000:00:16.0: setting latency timer to 64
[ 9.504901] mei 0000:00:16.0: irq 49 for MSI/MSI-X
[ 9.580473] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[ 9.587408] snd_hda_intel 0000:00:1b.0: irq 50 for MSI/MSI-X
[ 9.587430] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
[ 9.711991] sd 1:0:0:0: Attached scsi generic sg0 type 0
[ 9.718925] sr 3:0:0:0: Attached scsi generic sg1 type 5
[ 9.736638] Linux agpgart interface v0.103
[ 9.812464] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input4
[ 9.816638] e1000e: Intel(R) PRO/1000 Network Driver - 1.5.1-k
[ 9.816640] e1000e: Copyright(c) 1999 - 2011 Intel Corporation.
[ 9.833880] snd_hda_intel 0000:01:00.1: PCI INT B -> GSI 17 (level, low) -> IRQ 17
[ 9.833933] e1000e 0000:00:19.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
[ 9.833941] e1000e 0000:00:19.0: setting latency timer to 64
[ 9.848388] hda_intel: Disabling MSI
[ 9.848441] e1000e 0000:00:19.0: irq 51 for MSI/MSI-X
[ 9.855601] snd_hda_intel 0000:01:00.1: setting latency timer to 64
[ 10.143586] e1000e 0000:00:19.0: eth0: (PCI Express:2.5GT/s:Width x1) 38:60:77:a3:6b:48
[ 10.150992] e1000e 0000:00:19.0: eth0: Intel(R) PRO/1000 Network Connection
[ 10.158410] e1000e 0000:00:19.0: eth0: MAC: 10, PHY: 11, PBA No: FFFFFF-0FF
[ 10.165771] i801_smbus 0000:00:1f.3: PCI INT C -> GSI 18 (level, low) -> IRQ 18
[ 10.269566] HDMI status: Codec=0 Pin=5 Presence_Detect=0 ELD_Valid=0
[ 10.288505] HDMI status: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=0
[ 10.307476] HDMI status: Codec=2 Pin=5 Presence_Detect=0 ELD_Valid=0
[ 10.326381] HDMI status: Codec=3 Pin=5 Presence_Detect=0 ELD_Valid=0
[ 10.339428] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input5
[ 10.346961] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input6
[ 10.354194] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input7
[ 10.361141] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input8
[ 10.564736] nvidia: module license 'NVIDIA' taints kernel.
[ 10.571313] Disabling lock debugging due to kernel taint
[ 10.613686] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 10.620332] nvidia 0000:01:00.0: setting latency timer to 64
[ 10.620335] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=nonewns=io+mem
[ 10.627199] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 295.49 Mon Apr 30 23:46:33 PDT 2012
[ 11.159528] fuse init (API version 7.17)
[ 11.973472] EXT4-fs (sda1): re-mounted. Opts: (null)
[ 12.101367] EXT4-fs (sda1): re-mounted. Opts: (null)
[ 12.630186] ppdev: user-space parallel port driver
[ 12.637266] lp: driver loaded but no devices found
[ 17.633097] Btrfs loaded
[ 17.672327] device fsid f4820e23-9db4-4378-998f-902573ed3f3a devid 1 transid 7500 /dev/sda2
[ 17.817269] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
[ 20.155823] NET: Registered protocol family 10
[ 26.886679] e1000e 0000:00:19.0: irq 51 for MSI/MSI-X
[ 26.937426] e1000e 0000:00:19.0: irq 51 for MSI/MSI-X
[ 26.937878] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 28.474258] e1000e: eth0 NIC Link is Up 100 Mbps Half Duplex, Flow Control: None
[ 28.474262] e1000e 0000:00:19.0: eth0: 10/100 speed: disabling TSO
[ 28.479045] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 38.507730] eth0: no IPv6 routers present
[ 63.882488] ata2.00: configured for UDMA/133
[ 63.882494] ata2: EH complete
[ 65.647755] EXT4-fs (sda1): re-mounted. Opts: commit=0
[ 65.649556] EXT4-fs (sda3): re-mounted. Opts: commit=0

On a machine without btrfs I dont have the problem

Regards

Lawrenc
 
Old 05-09-2012, 10:40 AM   #6
deNiro
Member
 
Registered: Jun 2003
Location: Belgium
Distribution: Slackware
Posts: 109

Rep: Reputation: 16
How about any other console apps, like pkgtool. Does that one takes longer to load?.

btw, do you have an intel gpu?
 
Old 05-09-2012, 10:54 AM   #7
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Possibly to find out with "strace" where it gets stuck.
 
Old 05-09-2012, 10:55 AM   #8
audriusk
Member
 
Registered: Mar 2011
Location: Klaipėda, Lithuania
Distribution: Slackware
Posts: 231

Rep: Reputation: 102Reputation: 102
Sounds like mc is trying to connect somewhere and is waiting for connection to time out. Try to use strace and analyze its output for some clues. Run mc like the following and quit it immediately:
Code:
$ strace -o /tmp/strace-mc.log mc
If you're not sure about the contents of the log file, post it here (better attach it, as it can be quite big).

You can run
Code:
$ tail -f /tmp/strace-mc.log
in another terminal at the same time to see in real time where mc is stalling.
 
Old 05-10-2012, 03:01 AM   #9
zasavage
Member
 
Registered: Sep 2010
Location: Bloemfontein , South Africa
Distribution: Slackware 13.37 and Slackware 14
Posts: 191

Original Poster
Rep: Reputation: 6
@audriusk
the trace on the log

If I look from my inexperience it seems there are files missing

Regards

Lawrence

unmap(0x7f6e3f8e9000, 4096) = 0
socket(PF_INET, SOCK_DGRAM|SOCK_NONBLOCK, IPPROTO_IP) = 3
connect(3, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.43.34.190")}, 16) = 0
poll([{fd=3, events=POLLOUT}], 1, 0) = 1 ([{fd=3, revents=POLLOUT}])
sendto(3, "\227\301\1\0\0\1\0\0\0\0\0\0\10DARKSTAR\25moringahea"..., 54, MSG_NOSIGNAL, NULL, 0) = 54
poll([{fd=3, events=POLLIN}], 1, 5000) = 1 ([{fd=3, revents=POLLIN}])
ioctl(3, FIONREAD, [12]) = 0
recvfrom(3, "\227\301\201\5\0\0\0\0\0\0\0\0", 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.43.34.190")}, [16]) = 12
poll([{fd=3, events=POLLIN}], 1, 4875) = 0 (Timeout)
socket(PF_INET, SOCK_DGRAM|SOCK_NONBLOCK, IPPROTO_IP) = 4
connect(4, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.28.75.200")}, 16) = 0
poll([{fd=4, events=POLLOUT}], 1, 0) = 1 ([{fd=4, revents=POLLOUT}])
sendto(4, "\227\301\1\0\0\1\0\0\0\0\0\0\10DARKSTAR\25moringahea"..., 54, MSG_NOSIGNAL, NULL, 0) = 54
poll([{fd=4, events=POLLIN}], 1, 5000) = 1 ([{fd=4, revents=POLLIN}])
ioctl(4, FIONREAD, [117]) = 0
recvfrom(4, "\227\301\201\203\0\1\0\0\0\1\0\0\10DARKSTAR\25moringahea"..., 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.28.75.200")}, [16]) = 117
close(3) = 0
close(4) = 0
socket(PF_INET, SOCK_DGRAM|SOCK_NONBLOCK, IPPROTO_IP) = 3
connect(3, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.43.34.190")}, 16) = 0
poll([{fd=3, events=POLLOUT}], 1, 0) = 1 ([{fd=3, revents=POLLOUT}])
sendto(3, "\262R\1\0\0\1\0\0\0\0\0\0\10DARKSTAR\0\0\1\0\1", 26, MSG_NOSIGNAL, NULL, 0) = 26
poll([{fd=3, events=POLLIN}], 1, 5000) = 1 ([{fd=3, revents=POLLIN}])
ioctl(3, FIONREAD, [26]) = 0
recvfrom(3, "\262R\201\5\0\1\0\0\0\0\0\0\10DARKSTAR\0\0\1\0\1", 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.43.34.190")}, [16]) = 26
close(3) = 0
socket(PF_INET, SOCK_DGRAM|SOCK_NONBLOCK, IPPROTO_IP) = 3
connect(3, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.28.75.200")}, 16) = 0
poll([{fd=3, events=POLLOUT}], 1, 0) = 1 ([{fd=3, revents=POLLOUT}])
sendto(3, "\262R\1\0\0\1\0\0\0\0\0\0\10DARKSTAR\0\0\1\0\1", 26, MSG_NOSIGNAL, NULL, 0) = 26
poll([{fd=3, events=POLLIN}], 1, 5000) = 1 ([{fd=3, revents=POLLIN}])
ioctl(3, FIONREAD, [101]) = 0
recvfrom(3, "\262R\201\203\0\1\0\0\0\1\0\0\10DARKSTAR\0\0\1\0\1\0\0\6\0\1\0"..., 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.28.75.200")}, [16]) = 101
close(3) = 0
umask(0) = 022
umask(022) = 0
getcwd("/home", 4096) = 6
stat("/home", {st_mode=S_IFDIR|0755, st_size=22, ...}) = 0
stat("/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat("libX11.so", 0x7fff95fbcfc0) = -1 ENOENT (No such file or directory)
stat("libX11.so.so", 0x7fff95fbcfc0) = -1 ENOENT (No such file or directory)
stat("libX11.so.la", 0x7fff95fbcfc0) = -1 ENOENT (No such file or directory)
futex(0x7f6e3ef520b0, FUTEX_WAKE_PRIVATE, 2147483647) = 0
open("/etc/ld.so.cache", O_RDONLY|O_CLOEXEC) = 3
fstat(3, {st_mode=S_IFREG|0644, st_size=185151, ...}) = 0
mmap(NULL, 185151, PROT_READ, MAP_PRIVATE, 3, 0) = 0x7f6e3f85b000
close(3) = 0
open("/usr/lib64/libX11.so", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0\320\327\1\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=1310016, ...}) = 0
mmap(NULL, 3407144, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f6e3cdb7000
mprotect(0x7f6e3cef1000, 2097152, PROT_NONE) = 0
mmap(0x7f6e3d0f1000, 24576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x13a000) = 0x7f6e3d0f1000
close(3) = 0
open("/usr/lib64/tls/x86_64/libxcb.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/tls/x86_64", 0x7fff95fbc4a0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/tls/libxcb.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/tls", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/lib64/x86_64/libxcb.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/x86_64", 0x7fff95fbc4a0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/libxcb.so.1", O_RDONLY|O_CLOEXEC) = 3
read(3, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0000\211\0\0\0\0\0\0"..., 832) = 832
fstat(3, {st_mode=S_IFREG|0755, st_size=114096, ...}) = 0
mmap(NULL, 2209552, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x7f6e3cb9b000
mprotect(0x7f6e3cbb6000, 2097152, PROT_NONE) = 0
mmap(0x7f6e3cdb6000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1b000) = 0x7f6e3cdb6000
close(3) = 0
 
Old 05-10-2012, 03:44 AM   #10
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 145Reputation: 145
Missing files should be ok in the search-and-find process, as long as they are found finally.
Do you get speed improvement with only lo and no other network interface up?
 
Old 05-10-2012, 04:30 AM   #11
GazL
Senior Member
 
Registered: May 2008
Posts: 3,231

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
Code:
socket(PF_INET, SOCK_DGRAM|SOCK_NONBLOCK, IPPROTO_IP) = 3
 connect(3, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.43.34.190")}, 16) = 0
 poll([{fd=3, events=POLLOUT}], 1, 0) = 1 ([{fd=3, revents=POLLOUT}])
 sendto(3, "\227\301\1\0\0\1\0\0\0\0\0\0\10DARKSTAR\25moringahea"..., 54, MSG_NOSIGNAL, NULL, 0) = 54
 poll([{fd=3, events=POLLIN}], 1, 5000) = 1 ([{fd=3, revents=POLLIN}])
 ioctl(3, FIONREAD, [12]) = 0
 recvfrom(3, "\227\301\201\5\0\0\0\0\0\0\0\0", 1024, 0, {sa_family=AF_INET, sin_port=htons(53), sin_addr=inet_addr("196.43.34.190")}, [16]) = 12
 poll([{fd=3, events=POLLIN}], 1, 4875) = 0 (Timeout)
Well, looks like you lost ~5 seconds waiting for that dns query from 196.43.34.190. I'd be inclined to take a closer look at the config of your resolver (etc/host.conf, /etc/resolv.conf), that your name servers are working properly, and that your box can resolve its own hostname and so on.
 
Old 05-10-2012, 01:58 PM   #12
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
I agree, review your hosts files and dns settings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Password prompt takes 20 seconds to display after login afgs_uk Linux - General 6 12-07-2006 10:13 PM
HELP !!! compression only takes a few seconds lukman Linux - Newbie 1 06-15-2006 01:28 AM
why mounting 20GB encrypted data takes 2 seconds rino.caldelli Linux - General 2 03-05-2006 03:13 AM
Mounting Reiser4 partition takes about 5 seconds DX2 Linux - General 4 05-03-2005 06:55 PM
NFS mount takes 6 seconds drspiffy Linux - Networking 5 03-16-2005 09:34 PM


All times are GMT -5. The time now is 12:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration