LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 05-24-2011, 11:48 PM   #1
manoj.linux
Member
 
Registered: Aug 2007
Posts: 223

Rep: Reputation: 15
Question vi is not working as normal user


Hi,

I am unable to create/open any file in vi editor for normal user, though using root I am able to create/open any file, using redhat 5.5,

example
vi test

it showing nothing after entering command
 
Old 05-25-2011, 12:34 AM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, Lubuntu, FreeBSD
Posts: 3,930
Blog Entries: 5

Rep: Reputation: Disabled
Showing nothing - as in the command prompt hangs?
 
Old 05-25-2011, 01:10 AM   #3
manoj.linux
Member
 
Registered: Aug 2007
Posts: 223

Original Poster
Rep: Reputation: 15
Question

it is showing just like below
[test@test123 ~]$ vi test
[test@test123 ~]$
 
Old 05-25-2011, 02:43 AM   #4
norbert74
Member
 
Registered: Apr 2006
Posts: 63

Rep: Reputation: 23
What happens if you use the full path, e.g. ?
Code:
$ /usr/bin/vi -V test
 
Old 05-02-2012, 10:04 AM   #5
srivinbsc@gmail.com
LQ Newbie
 
Registered: May 2012
Posts: 2

Rep: Reputation: Disabled
Thumbs up Issue resolved

change the /var/tmp to 777 permission

Regards
Vinodh
 
Old 05-02-2012, 10:09 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,
Quote:
Originally Posted by srivinbsc@gmail.com View Post
change the /var/tmp to 777 permission

Regards
Vinodh
Don't dig up a year old thread please.

And if you do want to contribute make sure your solution is correct! Both /tmp and /var/tmp should be 1777 and not 777!!
 
Old 05-02-2012, 10:58 AM   #7
srivinbsc@gmail.com
LQ Newbie
 
Registered: May 2012
Posts: 2

Rep: Reputation: Disabled
Hi druuna

If you had know solutions one year why can't you updated ? I had to search for 15 mins. 777 works fine for me. And I do n't want other to search and waste 15 mins of time as this is the 1st result for vi editor with such problem. Please note people looking into forum when the face issue not every time like you and find fault for no reason

Regards
Vinodh
 
Old 05-02-2012, 11:18 AM   #8
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371Reputation: 2371
Hi,
Quote:
Originally Posted by srivinbsc@gmail.com View Post
If you had know solutions one year why can't you updated ?
I don't know the answer to this one. And although you claim your answer is the correct one, neither do you....

You are not the OP of this thread, this thread does not have the [SOLVED] tag, so for all we know this is still unresolved.

Quote:
I had to search for 15 mins. 777 works fine for me.
777 are the wrong permissions for /var/tmp and /tmp. Setting these permission _will_ get you into trouble!
The permissions on both directories are 1777. This is default/mandatory!

Quote:
Please note people looking into forum when the face issue not every time like you and find fault for no reason
I have good reason to add my previous reply: To make sure that people that stumble upon this thread would know that your solution is wrong!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
super user privileges check for a normal user in bash script freeindy Programming 2 08-01-2008 06:08 AM
Hi. Apache not working under normal user. parsex Linux - Newbie 8 07-27-2006 03:06 PM
X no longer working as normal user - permission denied vharishankar Debian 4 07-15-2006 12:36 AM
iRiver drivers working for normal user ? smau Linux - Hardware 1 10-24-2005 04:15 PM
Games runs slow as normal user, but fast as root user mcore Linux - Software 2 06-07-2004 11:11 PM


All times are GMT -5. The time now is 11:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration