Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 04-13-2012, 08:41 PM   #1
LQ Newbie
Registered: Apr 2012
Posts: 4

Rep: Reputation: Disabled
IP Forwarding Stopped Working

I've a difficult situation here. My ipforwarding setup on a Redhat machine stopped working all of a sudden. I have ipforwarding scripts in place that worked fine till yesterday. I have tried all sorts of configuration but no luck. Can any body explain me what could be the reason for this problem?

Last edited by vijaysoft; 04-13-2012 at 08:44 PM.
Old 04-14-2012, 03:15 AM   #2
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
Was the machine rebooted? Or (possibly) the networking service restarted?
If sysctl isn't configured to enable ip_forward at boot then this could cause the problem.
You can check this with: (1 is enabled)
# cat /proc/sys/net/ipv4/ip_forward
And this link explains the fix. Particularly in the *note* section.
Old 04-14-2012, 07:13 AM   #3
LQ Newbie
Registered: Apr 2012
Posts: 4

Original Poster
Rep: Reputation: Disabled
Resolved the issue

Thanks for looking into my issue. I have the IP Forwarding enabled and all settings are intact. Later I found that the issue was due to the reason that my ISP changed DNS numbers. When I changed all those client machines where I had this DNS number specified it resolved the issue.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Ubuntu 11.04 mic stopped working in HP G-32, but was working to fix it? Highjo Ubuntu 4 08-08-2011 06:59 AM
Three Mobile Broadband was configured and working but it has now stopped working and Tinabarma Linux - Newbie 0 10-20-2008 08:36 AM
It stopped working. UmneyDurak Fedora 8 08-15-2004 03:41 PM
ssh X forwarding has stopped working. microtim Linux - Networking 2 09-20-2003 06:02 AM
My X just stopped working??? freeindy Linux - Newbie 4 11-30-2002 11:53 AM

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration