LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 03-28-2012, 03:40 PM   #1
dcarrington
Member
 
Registered: Dec 2011
Distribution: RHEL, CentOS, Ubuntu
Posts: 49

Rep: Reputation: 2
Kickstart - Enable osad & nscd service


Hello,

After taking over the RHEL admin responsibilities (while still being quite green), I am looking into our kickstart builds and noticed that there are "snippets" being used to enable a couple of services post-build.

When I looked, I noticed that these services (osad & nscd) are explicitly set to be enabled in the kickstart script.

I have not been able to find a log file or error message as to why these services are not being enabled without using the additional snippets.

Does anyone have any idea where I can find why these services are not enabled after a kickstart build unless I use an additional post-install script to enable them?

The line in the kickstart script is:


services --disabled=kudzu,firstboot,atd,lvm2-monitor,isdn,mdmonitor,nfslock,cups,bluetooth,pcscd,hidd,autofs,hplip,rawdevices,xinetd,gpm,xfs,yum-updatesd,smartd,rpcgssd,rpcidmapd,avahi-daemon,iscsi,iscsid,mcstrans,restorecond,readahead_early --enabled=ntpd,auditd,psacct,snmpd,osad,nscd

Any help would be appreciated! Thanks!
 
Old 03-28-2012, 09:01 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Maybe they're being disabled in the %post section ? .. I can't think of any reason for it not to work unless there was a space between 'snmpd' and 'osad'
 
Old 03-29-2012, 12:08 PM   #3
dcarrington
Member
 
Registered: Dec 2011
Distribution: RHEL, CentOS, Ubuntu
Posts: 49

Original Poster
Rep: Reputation: 2
kbp,

I looked all through the finished script and verified that there is no white space in the services line. In fact, originally, osad and nscd were the first two services listed (--enabled=osad,nscd,ntpd....) and I moved them to the end...just in case order had anything to do with it.

Also, I found no mention of osad apart from the above-mentioned "services" call and the insertion of the snippet that I still have to add that just does a "chkconfig osad on". Same goes for nscd.

We are a little behind on patching our Satellite server, so I don't know if that could have anything to do with it. We're going to get Satellite current on patching and everything, but that's a fairly major thing that tends to break lots of stuff, so we're not rushing into that. Who knows...maybe that's all it is.
 
Old 03-30-2012, 07:47 AM   #4
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
I usually do my service disabling/enabling in the post section so I can have a bit more control

e.g.
Code:
if [[ "$NAS" = "y" ]]
then
echo "[*] enabling services for NAS"
for service in netfs nfs nfslock portmap
do
  chkconfig $service on
  echo "... $service enabled"
done
fi
If you have the time you could try adding it as 2 lines:

Code:
services --disabled=kudzu,firstboot,atd,lvm2-monitor,isdn,mdmonitor,nfslock,cups,bluetooth,pcscd,hidd,autofs,hplip,rawdevices,xinetd,gpm,xfs,yum-updatesd,smartd,rpcgssd,rpcidmapd,avahi-daemon,iscsi,iscsid,mcstrans,restorecond,readahead_early
services --enabled=ntpd,auditd,psacct,snmpd,osad,nscd

Last edited by kbp; 03-30-2012 at 07:49 AM.
 
Old 03-30-2012, 12:17 PM   #5
dcarrington
Member
 
Registered: Dec 2011
Distribution: RHEL, CentOS, Ubuntu
Posts: 49

Original Poster
Rep: Reputation: 2
kbp,

I wondered about that as I was originally wondering if I was running into an issue of having too long of a string. We're using Satellite, so I don't know if there's a way to separate those out unless I just go directly into modifying the script manually. Not opposed to doing that, but I just think it shouldn't HAVE to be done that way. (I like when stuff just works the way it's supposed to.)

I can definitely try your suggestion, though. It might help to narrow down the cause of why it's not working the way I've got it.

Thanks!!
 
Old 05-08-2012, 10:56 AM   #6
dcarrington
Member
 
Registered: Dec 2011
Distribution: RHEL, CentOS, Ubuntu
Posts: 49

Original Poster
Rep: Reputation: 2
With the help of Red Hat support, I think we finally found it...

It looks like after I added a "--enablecache" switch after "authconfig ...." my services now seem to be running and enabled after kickstarting.

Yay Red Hat!!
 
  


Reply

Tags
kickstart


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to enable package selection in kickstart Ashish Sood Linux - General 4 05-23-2010 09:02 AM
Kickstart V Windows Deployment Service the student Linux - General 4 04-13-2010 04:33 AM
ssh service start & enable ? bjh Suse/Novell 3 02-16-2009 01:43 PM
How to : Enable & Disable Service in Solaris 5.9 avklinux Solaris / OpenSolaris 2 11-21-2008 04:17 PM
how to enable package selection in system-config-kickstart in rhel5 mamtasahai1 Linux - Enterprise 3 05-08-2008 09:51 PM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration