LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > AIX
User Name
Password
AIX This forum is for the discussion of IBM AIX.
eserver and other IBM related questions are also on topic.

Notices



Reply
 
Search this Thread
Old 03-22-2012, 02:00 AM   #1
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Rep: Reputation: Disabled
installing vim-X11 on AIX 7.1 machine


What rpm packages shall be installed prior to installation of vim-X11 on AIX 7.1 machine?
I have already installed three vim packages, but when I try to install vim-X11 I always get the message that some package is lacked.
 
Old 03-23-2012, 08:07 PM   #2
DukeSSD
Member
 
Registered: Sep 2007
Posts: 88

Rep: Reputation: 20
"I always get the message that some package is lacked."

What is the exact message please?
 
Old 03-27-2012, 03:59 AM   #3
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
It turned out that I installed packages with versions not enough upgraded: perl=5.8.2 and not 5.8.8, vim-common=6.3.1 etc.
I think after upgrading everything will be OK
Thanks
 
Old 04-16-2012, 09:04 AM   #4
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
vim-X11 on AIX 7.1

After installation of vim packages on AIX 7.1 machine I tried to run gvim and get error:

exec() 0509-036 Cannot load program gvim because of the following error:
0509-022 Cannot load module /lib/libgdk-x11-2.0.a(libgdk-x11-2.0.so.0).
0509-150 Dependent module /lib/libXrender.a(libXrender.so.1) could not be loaded
0509-152 Member libXrender.so.1 is not found in archive

It seems to me that when I installed packages vim is dependent on and somtimes used --nodeps flag some soft had not been installed properly.

Could someone write me what rpm packages and in what order shall be installed in order to install vim-X11 from the scratch?
 
Old 04-18-2012, 04:12 AM   #5
cliffordw
Member
 
Registered: Jan 2012
Location: South Africa
Posts: 281

Rep: Reputation: 118Reputation: 118
It looks like you are missing xrender (ftp://ftp.software.ibm.com/aix/freeS...aix5.2.ppc.rpm).
 
Old 04-18-2012, 05:33 AM   #6
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hi
Here are some outputs:

# rpm -qa | grep Xrender
libXrender-0.9.6-1

# ls -lasF /lib/libXrender.a
/lib/libXrender.a@ -> /usr/lpp/X11/lib/R7/libXrender.a

# ls -lasF /usr/lpp/X11/lib/R7/libXrender.a
168 -rw-r--r-- 1 bin bin 168900 Aug 07 2010 /usr/lpp/X11/lib/R7/libXrender.a
 
Old 04-18-2012, 06:18 AM   #7
cliffordw
Member
 
Registered: Jan 2012
Location: South Africa
Posts: 281

Rep: Reputation: 118Reputation: 118
OK, that looks similar to my setup. If you run "ar -t /lib/libXrender.a" to look at the contents of the library, you will see that it contains libXrender.so.0, while in your output above you are looking for libXrender.so.1.

I suspect that this might be because of the version of libgdk you are using, namely v2 from the gtk2 RPM. As far as I can tell, you need v1, which is in the gtk+ rpm. Is gtk+ installed on your machine?
 
Old 04-18-2012, 08:42 AM   #8
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hi
gtk+ was not installed and I installed it.

# rpm -qa | grep gtk
gtk+-1.2.10-6
gtk2-2.18.9-2

I tried to uninstall gtk2 but I got the following error:

# rpm -e gtk2-2.18.9-2
error: removing these packages would break dependencies:
gtk2>=2.8.3 is needed by vim-X11-7.3.353-1
 
Old 04-18-2012, 01:49 PM   #9
cliffordw
Member
 
Registered: Jan 2012
Location: South Africa
Posts: 281

Rep: Reputation: 118Reputation: 118
You shouldn't need to uninstall gtk2; it can coexist with gtk+. Does gvim still produce the errors you got before installing gtk+?
 
Old 04-19-2012, 05:27 AM   #10
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Yes, it does.
I think I need to reinstall all vim-X11 dependent or related rpm because it seems to me that since I made installation of rpms in stages sometimes I installed rpms that demand more latest rpm that were installed and I did not put attention on it - I used --nodeps flag.
Now this is the question what rpms and in what order shall be installed in order to success in vim-X11 installation assuming that no Linux tools is installed already.
 
Old 04-20-2012, 01:21 AM   #11
cliffordw
Member
 
Registered: Jan 2012
Location: South Africa
Posts: 281

Rep: Reputation: 118Reputation: 118
Hi again,

I'm not sure which packages are required. The "-R" flag on the rpm command should tell you this, but on my version the RPM is not configured with specific package dependencies, so it just lists the auto-detected library dependencies, as follows:

# rpm -qRp vim-X11-6.3-1.aix5.1.ppc.rpm
vim-common
libC.a(shr.o)
libICE.a(shr.o)
libSM.a(shr.o)
libX11.a(shr4.o)
libXt.a(shr4.o)
libbind.a(shr.o)
libbsd.a(shr.o)
libc.a(shr.o)
libcurses.a(shr42.o)
libgdk.so
libglib.so
libgmodule.so
libgtk.so
libiconv.a(shr4.o)
librtl.a(shr.o)

If you just try and install it without --nodeps, it should tell you what you still need.
 
Old 04-22-2012, 03:19 AM   #12
vvertsberger
LQ Newbie
 
Registered: Feb 2012
Posts: 12

Original Poster
Rep: Reputation: Disabled
Hi
Thanks a lot.
At the end I just extracted libXrender.so.0 from /lib/libXrender.a , renamed it libXrender.so.1 and added the module to /lib/libXrender.a and it works.
 
Old 04-22-2012, 08:00 AM   #13
cliffordw
Member
 
Registered: Jan 2012
Location: South Africa
Posts: 281

Rep: Reputation: 118Reputation: 118
I'm glad you got it working. I'm not sure your solution is ideal, though, as:
1) This may break some other applications, possibly in the future when you install something else, and
2) Any update to the fileset containing /lib/libXrender.a will undo your hack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there virtual machine software for AIX 5.1 or 5.2 tsebo4mile AIX 4 03-29-2010 11:28 PM
AIX 5.2: <X11/extensions/XI.h> not found jvme AIX 1 08-02-2007 05:20 AM
bash + vim on AIX slackamp AIX 2 09-22-2006 08:36 AM
Can I tunnel X11 aps from an AIX (5.2) box to my linux workstation? davee AIX 3 04-01-2005 03:28 AM
RedHat ES3 - no vim-X11 package? GAVollink Red Hat 0 01-06-2004 11:25 AM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration