LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-25-2007, 03:53 PM   #1
ouellettesr
LQ Newbie
 
Registered: Feb 2007
Posts: 14

Rep: Reputation: 0
bad symlink?/cdrom reading dvd rom


Hello everyone, partial-newb here. I just installed slackware 11.0 and I have the 2.4 default kernel. I have a dvd-rom and a cdrom installed on one ide cable. My problem is that when I mount my cdrom it actually mounts the dvd-rom. I have done some goolging and found out that my problem is probably due to they are both pointing to /dev/hdc. My fstab shows /dev/dvd and /dev/cdrom for the two devices and I don not know anything about symlinks or how to fix them, I really need some help here. Thanks.

I can provide more info if requested.
 
Old 02-25-2007, 04:19 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
to symlink do:

Code:
ln -s /source /destination
# for example (link from /dev/hdc to /dev/dvd):
ln -s /dev/hdc /dev/dvd
 
Old 02-25-2007, 04:42 PM   #3
ouellettesr
LQ Newbie
 
Registered: Feb 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Hello thanks for replying.
When I try that command It says: file exists
no when I try to mount the cdrom it says unknown device. Is thre a way to undo the symlinks and start over?
 
Old 02-25-2007, 05:22 PM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
yes, you can remove the symlinks ...

Code:
rm /dev/dvd
BE VERY CAREFUL AS ROOT WITH THE RM COMMAND ... IT IS DANGEROUS !!!

Don't rm /dev/hdc or /dev/hdd or anything like that. Only /dev/dvd or /dev/cdrom, and other symlinks.
 
Old 02-25-2007, 06:09 PM   #5
ouellettesr
LQ Newbie
 
Registered: Feb 2007
Posts: 14

Original Poster
Rep: Reputation: 0
Problem solved. You have been a great help. I thought this was going to be hard but it was actually quite simple using the commands you provided.

Thanks.
 
Old 02-26-2007, 09:29 AM   #6
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
'ls -l' is helpful too... shows symlinks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 11:37 AM
Reading Files on a CD/DVD-ROM without proper permissions meb495 Linux - Newbie 9 02-03-2007 02:18 PM
DVD-ROM music only. System not reading? trox Linux - General 1 04-17-2006 02:57 PM
My dvd/cd-rom is not reading as it was supposed to stormrider_may Linux - Newbie 2 02-18-2006 03:55 AM
mount: wrong fs type, bad option, bad superblock...(cdrom,dvd and floppy) SpItoS Mandriva 14 11-12-2004 02:27 PM


All times are GMT -5. The time now is 06:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration