LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-31-2005, 11:14 PM   #1
Merlinfmct87
LQ Newbie
 
Registered: Mar 2005
Location: Phoenix, AZ
Distribution: Ubuntu, Gentoo, and SUSE
Posts: 15

Rep: Reputation: 0
Yet another i810 graphics problem, very very poor 3D support


Hello all. I've been trying to get my i810 drivers to work right. I've gotten X to load, and glxgears to run with hardware acceleration.

However, when I try to run the Quake III demo, it locks up. Alt+Tab, Ctrl+ALt+Del, Ctrl+Alt+Backspace are all useless, I have to restart.

I was able to get the Q3 console log, here's the relevant portion:

Code:
----- R_Init -----
...loading libGL.so: Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
X connection to :0.0 broken (explicit kill or server shutdown).
Here's my xorg.conf:

Code:
Section "Module"


    Load        "dbe"  #.# Double buffer extension

    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
Load "extmod"


    Load        "type1"
    Load        "speedo"
    Load        "freetype"
#    Load        "xtt"


    Load       "glx"

    Load       "dri"


EndSection



Section "Files"


    RgbPath	"/usr/X11R6/lib/X11/rgb"



    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/TTF/"
    FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"



EndSection



Section "ServerFlags"



EndSection



Section "InputDevice"

    Identifier	"Keyboard1"
    Driver	"Keyboard"


    Option "AutoRepeat" "500 30"



    Option "XkbRules"	"xorg"
    Option "XkbModel"	"pc104"
    Option "XkbLayout"	"us"
    Option "XkbVariant"	"HP keyboard"

EndSection



Section "InputDevice"



    Identifier	"Mouse1"
    Driver	"mouse"
    Option "Protocol"    "ExplorerPS/2"
    Option "Device"      "/dev/mouse"
    Option "Buttons" "7"
    Option "ZAxisMapping" "6 7"




EndSection


Section "Monitor"

    Identifier  "Sony Multiscan 200ES"

    HorizSync   31.5 - 64.3

    VertRefresh 50-70

EndSection




Section "Device"
    Identifier	"Standard VGA"
    VendorName	"Unknown"
    BoardName	"Unknown"

    Driver     "vga"

EndSection

Section "Device"
    Identifier  "Intel Linux config"
    Driver      "i810"
    VideoRam    32768 # 32 MB of VRAM, the max according to documentation
    #VideoRam    65536 - # 64 MB of VRAM, the true ammount according to win diagnostics.
    # Insert Clocks lines here if appropriate
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "Intel Linux config"
    Monitor     "Sony Multiscan 200ES"
    DefaultDepth 16

#    Subsection "Display"
#        Depth       8
#        Modes       "1280x1024" "1024x768" "800x600" "640x480"
#        ViewPort    0 0
#    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
#    Subsection "Display"
#        Depth       24
#        Modes       "1280x1024" # "1024x768" "800x600" "640x480"
#        ViewPort    0 0
#    EndSubsection
EndSection


Section "ServerLayout"


    Identifier  "Simple Layout"


    Screen "Screen 1"

    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

 Section "DRI"
    Mode 0666
 EndSection
The reason the 8 bit and 24 bit resolutions above are commented out is that the i810 can only render 3D graphics in 16 bit colour.

I tried a strace, but the log that resulted from it just had one loooong line with no text. When I tried the less command at the prompt, I just got a pageful of ^@ repeating endlessly. Also, this does run perfectly in windows. It's not the hardware.

I've been looking high and low on the net for an answer, with no luck. I even used the top-secret LinuxQuestions.org search feature!

If you can help at all, I'd greatly appreciate it.

Thank you for reading,

Merlin
 
Old 04-01-2005, 04:35 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
Are you running the framebuffer driver? If so, don't. It can cause problems. That's the only that comes to mind. I don't use x.org, though.
 
Old 04-01-2005, 06:42 AM   #3
PSHLOS_007
LQ Newbie
 
Registered: Dec 2004
Location: Greece
Distribution: Slackware 10.1 - 2.6.11.2
Posts: 29

Rep: Reputation: 15
The monitor resolution is too high for this graphics card. In section device try not to use VideoRam variant because this card is a dynamic one. VideoRam is system-OS depended. Just comment it. Also try to comment this line in xorg.conf:
Option "omit xfree86-dga" So it can load the DGA extention in your X. If it crashes again, try ctrl-alt-F4-5-6.. to open another session and check what is wrong.
 
Old 04-01-2005, 09:39 AM   #4
axobeauvi
Member
 
Registered: Apr 2003
Posts: 128

Rep: Reputation: 16
I agree with PSHLOS_007
plus I would comment out dri and change the default color to 24bit
 
Old 04-06-2005, 01:54 AM   #5
Merlinfmct87
LQ Newbie
 
Registered: Mar 2005
Location: Phoenix, AZ
Distribution: Ubuntu, Gentoo, and SUSE
Posts: 15

Original Poster
Rep: Reputation: 0
adz: No, I'm not using the framebuffer driver, I don't have the kernel version(I'm running 2.4.6).

PSHLOS_007: First, I don't understand what you mean by the monitor resolution. I've run the desktop at 1280x1024 both in Win and Lin, plus Half-Life 1 in Win, on this hardware, so I don't quite follow you.

As far as your suggestions go, I'll let you know in a half hour(I'm in win atm).

axobeauvi: Mmk, I'll change the color bit and see what happens. Which section of DRI do you want me to comment out though, 'Load "dri"' or 'Section "DRI"
Mode 0666
EndSection'?

Thanks so much for your help!

Merlin
 
Old 04-06-2005, 04:55 AM   #6
Merlinfmct87
LQ Newbie
 
Registered: Mar 2005
Location: Phoenix, AZ
Distribution: Ubuntu, Gentoo, and SUSE
Posts: 15

Original Poster
Rep: Reputation: 0
OK. messed around with my xorg.conf, commented out the VideoRam. That got Q3 to load and display, but with a LOT of lag. glxgears now only gets ~40 fps when it used to get ~200. Commenting DRI, DGA, or making the default display depth 24 has had no effect.

My only guess is that Xorg isn't allocating Video RAM dynamically, even without the VideoRam tag in the xorg.conf. This would explain why glxgears is running at such a low fps. The question is, how do I get xorg to allocate dynamically now?

Again, thank you VERY much for your help,

Merlin
 
Old 04-08-2005, 02:33 AM   #7
jimbob1234
LQ Newbie
 
Registered: Nov 2003
Distribution: Slackware Current
Posts: 21

Rep: Reputation: 15
Quote:
Originally posted by axobeauvi
I agree with PSHLOS_007
plus I would comment out dri and change the default color to 24bit
This is really good advise that I just decided to try out. I have now given up with using DRI with the I810. It just plain sucks. Everything now looks better at 24 bit and I don't have to deal with all of the weird redraw problems that have plagued my system.

The down side is glxgears dropped from 400 to 90 fps. But I think that it is well worth it.
 
Old 04-11-2005, 01:38 PM   #8
TheMusicGuy
Member
 
Registered: Mar 2004
Distribution: Ubuntu 8.04
Posts: 127

Rep: Reputation: 15
Eidt:
Oh, pfft, nevermind; you already are using the i810 driver. (Duhhhhh....)

Weeeell in that case, my only advice is that i810 sucks. It can't even run HALO under Windows. :P

Last edited by TheMusicGuy; 04-11-2005 at 01:42 PM.
 
Old 04-11-2005, 01:56 PM   #9
BinaryBob
Member
 
Registered: Aug 2002
Posts: 117

Rep: Reputation: 15
Yeah i810 is not full out 3d chipset. You were lucky to get 400 out of it on, anything, even an animated triangle =)
 
Old 04-13-2005, 01:04 AM   #10
Merlinfmct87
LQ Newbie
 
Registered: Mar 2005
Location: Phoenix, AZ
Distribution: Ubuntu, Gentoo, and SUSE
Posts: 15

Original Poster
Rep: Reputation: 0
You'd have a point if I wasn't able to run Quake III in windows. The problem lies in the configuration, not the chipset.

I'm well aware that it's not the lastest nVIDIA card. But it is capable of running the programs I'm asking it to. The reason it's not is because something in linux is FUBAR'd. Weather it's the reverse-engineered i810 driver, my xorg settings, or something else, I don't know. That's sorta kinda why I came here.

I know it can do the work. I can give you screen shots of my chipset running Quake III with all the bells and whistles at 800x600, w/o OpenGL in 1024x768.

So can you help me get it working on tux? Please?

Merlin
 
Old 04-13-2005, 09:18 PM   #11
BinaryBob
Member
 
Registered: Aug 2002
Posts: 117

Rep: Reputation: 15
Do you have agpgart modulde for your kernel built?

Post output of:

Code:
glxinfo | grep -i "direct rendering"
 
Old 04-14-2005, 05:23 AM   #12
Merlinfmct87
LQ Newbie
 
Registered: Mar 2005
Location: Phoenix, AZ
Distribution: Ubuntu, Gentoo, and SUSE
Posts: 15

Original Poster
Rep: Reputation: 0
OK. I did a modprobe agpgart, restarted, and KDE looked very different. I could tell that the effects of the 3-D were finally being used. However, glxgears was still at ~50 fps. Only thing I could think of(I was running in 16 bit already) was to set the VideoRam. I do so, shutdown X and type startx. It tells me it can't find a screen to run. I dutifully open and edit xorg.conf and comment out the VideoRam line. When I start KDE up again it's back into flat 2-D mode. glxgears is also still at 50.

Quote:
glxinfo | grep -i "direct rendering"
gets:

Quote:
direct rendering: no
Merlin
 
Old 04-14-2005, 07:19 AM   #13
BinaryBob
Member
 
Registered: Aug 2002
Posts: 117

Rep: Reputation: 15
Before loading X, modprobe agpgart, (everything depends on it) and..

add this to Section Device:

Code:
            VendorName  "Intel"
            Option      "AGPMode" "1"

so its kinda like:

Section "Device"
    Identifier  "Intel Linux config"
    VendorName  "Intel"
    Driver      "i810"
    Option      "AGPMode" "1"
    VideoRam    32768 # 32 MB of VRAM, the max according to documentation
    #VideoRam    65536 - # 64 MB of VRAM, the true ammount according to win diagnostics.
    # Insert Clocks lines here if appropriate
EndSection
check the following:

---
The kernel module for the i810 is named i810.o and should be installed in /lib/modules/2.4.x/kernel/drivers/char/drm/. It will be automatically loaded by the Xserver if needed.

The DRI 3D driver for the i810 should be in /usr/X11R6/lib/modules/dri/i810_dri.so. This will be automatically loaded by libGL.so.
---

then start x and see whats up, and if glxinfo | grep -i "direct rendering" is yes yet.

my source: http://dri.sourceforge.net/doc/DRIuserguide.html take a look there
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3D acceleration with i810 graphics card mugwump84 Linux - Hardware 4 11-04-2005 09:28 PM
Poor graphics performance Ross Clement Linux - Laptop and Netbook 1 09-13-2005 02:20 PM
Poor graphics performance himyuza Slackware 13 02-25-2005 02:30 AM
Intel i810 graphics configuration problem SadPenguin Linux - Hardware 3 02-08-2005 10:42 AM
Poor device support after kernel recompile - possible problem with modules? Dag Linux - General 1 08-04-2004 04:42 PM


All times are GMT -5. The time now is 11:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration