LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Sabayon
User Name
Password
Sabayon This forum is for the discussion of Sabayon Linux.

Notices

Reply
 
Search this Thread
Old 06-07-2009, 07:02 AM   #1
markmaus
LQ Newbie
 
Registered: Sep 2008
Location: Bridgeton, MO
Distribution: Mythdora, Ubuntu, Fedora
Posts: 9

Rep: Reputation: 0
Nvidia driver won't load


I have installed Sabayon 4.1 and upgraded to 4.2. Everything went fine until I rebooted and now X will not start. Apparently my Nvidia driver will no longer load. I can still log into a terminal. Is there anyway to reload the Nvidia driver from the command line? (The Gentoo equivalent of "apt-get install nvidia") I have tried editing the /etc/X11/xorg.conf file. I changed the "nvidia" to "nv", hoping that I could get into X that way, but it didn't help. Please help.



GForce 7300 GS Video Card
Intel 915 motherboard
Pentium III 3.2 GHz Hyperthreaded CPU
2 GB RAM
 
Old 06-07-2009, 07:13 AM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,572
Blog Entries: 1

Rep: Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027
The nvidia driver must have installed against the old kernel and while you upgraded to Sabayon 4.2, the kernel upgraded as well. Try to replace nvidia with 'vesa' it should restore your X system. If not, you could install 'links' (command line web browser) and download/install the nvidia driver again.
 
Old 06-08-2009, 07:15 AM   #3
markmaus
LQ Newbie
 
Registered: Sep 2008
Location: Bridgeton, MO
Distribution: Mythdora, Ubuntu, Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
I'm at work now and my Sabayon box is at home. But I'll try the "vesa" entry when I get home. I'm assuming that this will get me into X and then I can use the Package Manager to install the Nvidia driver again?
 
Old 06-08-2009, 08:06 AM   #4
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,572
Blog Entries: 1

Rep: Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027Reputation: 1027
Quote:
Originally Posted by markmaus View Post
I'm at work now and my Sabayon box is at home. But I'll try the "vesa" entry when I get home. I'm assuming that this will get me into X and then I can use the Package Manager to install the Nvidia driver again?
I'd assume so. I don't know how you install nvidia in Sabayon - if you can't do it via the package manager. You can always visit the nvidia website, dowload the driver and install it manually.

http://www.nvidia.com/object/unix.html

The Sabayon package manager, however, would be a preferred option.

Good luck
 
Old 06-08-2009, 05:42 PM   #5
markmaus
LQ Newbie
 
Registered: Sep 2008
Location: Bridgeton, MO
Distribution: Mythdora, Ubuntu, Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
Ok, I've edited my /etc/X11/xorg.conf file and changed "nvidia" to "vesa" and after rebooting, X kind of loads, but all I get is a blank white screen with a black cursor. (The cursor is functional) So I'm not sure if this is progress or not. Any other suggestions?
Thanks,
 
Old 06-08-2009, 05:56 PM   #6
markmaus
LQ Newbie
 
Registered: Sep 2008
Location: Bridgeton, MO
Distribution: Mythdora, Ubuntu, Fedora
Posts: 9

Original Poster
Rep: Reputation: 0
One more thought, I had enabled the Compiz desktop (rotating cube) back when X was working. I think that I probably need to disable that and I'll have to do it from the command line. Does anyone know how that is done?
Thanks,
 
Old 06-23-2009, 10:31 PM   #7
xlnagla
Sabayon Linux Team
 
Registered: May 2009
Distribution: Sabayon
Posts: 18

Rep: Reputation: 1
are you in kde or gnome?

the white screen means compiz loaded - never a good thing with vesa. However, you desktop is still usable even with the white screen!

press alt-f2, wait a couple seconds, then type

metacity --replace

and that should bring up metacity, which will let you use X.

The command line equivalent to apt-get in Sabayon is "equo install nvidia-drivers", as root of course.

~xlnagla
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Load nvidia Linux driver manually, not by using X-server, possible ? Vilius Linux - Hardware 2 02-02-2009 12:36 AM
installing nvidia 6200,everything is OK but driver can't load cowyn Slackware 7 10-23-2006 02:14 PM
Nvidia Driver Problem- gui won't load mr-t Linux - Hardware 4 10-09-2006 03:12 PM
NVidia driver will not load after kernel upgrade Ptrs!OP Linux - Hardware 10 02-06-2005 05:53 AM
can't load the nvidia driver antipop Linux - Newbie 11 05-02-2004 06:46 AM


All times are GMT -5. The time now is 11:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration