LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Sabayon (http://www.linuxquestions.org/questions/sabayon-86/)
-   -   How to install Nvidia driver/kill X server (http://www.linuxquestions.org/questions/sabayon-86/how-to-install-nvidia-driver-kill-x-server-805550/)

Onoir 05-02-2010 07:22 PM

How to install Nvidia driver/kill X server
 
I just installed Sabayon, its the Gentoo 2.0.1 version...

I've installed the nVidia driver from the website a thousand times, my problem is that I can't kill the X server on Gentoo/Sabayon. Trying /etc/init.d/xdm stop just kills X and leaves me with a blinking cursor.

I just need to get down to CLI so I can run the binary installer. Suggestions?

John VV 05-02-2010 07:49 PM

?? how is gdm,xdm,or kdm started in the first place?
as a service or a boot up daemon ?
do you use inittab ( service) or rc.conf ( daemon ) ?

colorpurple21859 05-02-2010 08:08 PM

try
Quote:

init 3

John VV 05-02-2010 08:55 PM

telinit 3 dose not always work
it dose not on my arch install

sometimes one needs to put a " ! " in-front of gdm, or kdm

Onoir 05-02-2010 08:59 PM

Init 3, or 5 change nothing. Some of the guys, although rude, are helpful. My system is a little behind the times but I've got it updating and apparently the drivers you can get via equo for nvidia are the same as the nvidia site. I'll post what the outcome is once done.

dr_agon 05-03-2010 10:29 AM

Quote:

Originally Posted by Onoir (Post 3955072)
Trying /etc/init.d/xdm stop just kills X and leaves me with a blinking cursor.

I just need to get down to CLI so I can run the binary installer. Suggestions?

Unless I am deeply mistaken, since you can do "/etc/init.d/xdm stop" you are at CLI, so what's the problem? You can install new driver from within old X session, then restart X. Just be sure to backup your current settings.

Doesn't Sabayon have more virtual terminals than the one with X running? Can't you just switch to them with Ctrl-Alt-F1, -F2,etc.?

Onoir 05-03-2010 11:17 AM

Quote:

Originally Posted by dr_agon (Post 3955692)
Unless I am deeply mistaken, since you can do "/etc/init.d/xdm stop" you are at CLI, so what's the problem? You can install new driver from within old X session, then restart X. Just be sure to backup your current settings.

Doesn't Sabayon have more virtual terminals than the one with X running? Can't you just switch to them with Ctrl-Alt-F1, -F2,etc.?

The Nvidia driver downloaded from the site cannot install with any version of X running. Hence, X itself must be stopped and you need to do it at the command line interface only.

However, Sabayon/Gentoo fixed that issue with the following:
Quote:

equo search nvidia
Shows you what software they have, then,
Quote:

equo install nvidia-drivers
Installs the drivers and their dependencies. Which for me, since I accidentally installed the older version of Sabayon took a while. I had to update my whole system.

Little key on that, if you do follow this and it installs around 270 new packages, thats just to be able to use the new drivers, not a full system update. The guys at the Sabayon site were able to get me up and running with:
Quote:

equo update
equo install entropy
equo upgrade
equo conf update
It would appear I've got the latest driver installed now via their packages.

colorpurple21859 05-03-2010 11:38 AM

This may work if you need to stop X. I tried it on my gentoo install and it worked.
Quote:

rc-update del gdm default
and then reboot. To restart gdm
Quote:

rc-update add gdm default
and reboot.

copperhead 05-03-2010 12:19 PM

To kill X, try using ps aux and use kill on the process number

$ ps aux | grep -i /usr/bin/X

Which will return a process number, for example 4340

Then:

$ kill 4340

normang 05-06-2010 12:56 PM

Killing X
 
Since killing X windows is the problem, in the GUI just type
CTRL>ALT>Backspace

Often this can terminate a balky X session. Good luck -

madicoe 05-08-2010 11:11 AM

I do not know if you are still looking for a solution and hope this will help. Edit your /etc/inittab file and set the boot level to 3 save it then reboot and you would boot to CLI. When you are done just change back the boot level to 5 and reboot.
Hope this sheds some light on your problem.

axobeauvi 06-16-2010 07:24 AM

so you can't Ctrl-Alt-F1 and kill X from there to install from tty1?

normang 06-17-2010 11:31 PM

Sure you can, axoveauvi - if you'd rather do it in bash, just use copperhead's solution above.

Jc61990 10-26-2012 10:30 PM

Quote:

Originally Posted by axobeauvi (Post 4005259)
so you can't Ctrl-Alt-F1 and kill X from there to install from tty1?

i think its ctrl alt f2. and you could do pkill X to kill the X server.

be sure to also Edit etc/X11/xorg.conf and change the Driver option under Device from nv or vesa to nvidia, also ensure the the Load glx line is uncommented in the Module Section

then

# eselect opengl set nvidia

this can be found at http://wiki.sabayon.org/index.php?ti...ing_in_Sabayon


after you reboot try running glxgears in a terminal.


All times are GMT -5. The time now is 12:38 PM.