LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   ROCK (http://www.linuxquestions.org/questions/rock-65/)
-   -   After booting ROCKS, asks for next cd and says CD not found. (http://www.linuxquestions.org/questions/rock-65/after-booting-rocks-asks-for-next-cd-and-says-cd-not-found-501946/)

feltdd 11-15-2006 03:33 PM

After booting ROCKS, asks for next cd and says CD not found.
 
Newbie here, need some help. I have several Rocks nodes, and a power outage wiped a few of them out. Trying to rebuild a node that will, afer basic boot, go to the floppy and get directions where to load it's real OS code.

I can boot the Rocks 4.2.1 boot cd, and then it goes to "The Rocks CD was not found in any of your CDROM drives. Please insert the ROCKS CD and press enter.." I then put in any other of the Rocks CDs, Base, Kernel, Disk 1, but any of them give the Rocks CD not found.

What am I doing wrong here? The machine is not in the network at this time.

Thanks!
PasadenaDave

MensaWater 11-18-2006 05:36 PM

The initial boot occurs because the BIOS loads the CD. Then the OS takes over and tries to use it's driver for the CD. The most common issue if it is an IDE (ATAPI) CD is it doesn't use DMA. You can make it get around that by typing the following at the original "boot:" prompt.

boot: ide=nodma

smacm 02-05-2010 05:31 PM

Thanks jlightner!
 
I was having exactly the same problem installing CentOS 5.4 from CD. Your solution solved the problem. One correction, at the boot: prompt, you need to type:

linux ide=nodma

MensaWater 02-09-2010 03:45 PM

Glad it helped and thanks for the update on usage.

At the time I posted that (2006) I pretty sure it was "boot:" but wouldn't swear to it now. - I'd run into it specifically on Fedora Core 4 - They're up to Fedora 12 these days. Also RedHat/Fedora give you other options from main screen than they did then.

foottuns 02-27-2010 09:01 AM

hello guys i am booting through PXE when I wanna start to install the node, but the problem is that either if I choose NFS is telling me that the rocks directory tree is not in that directory or this problem with the CD, I copy the Rock image into the master computer, and nothing happens, I am trying for 2 days to install the node but is not working, also when I type insert-ethers on the master I can see the node but the installation wont start. Can someone please give me some advices, I am getting made here because for about 2 days I am trying to fix it and I cannot.


PS: I change the name of the image, is that a problem?

MensaWater 03-01-2010 08:52 AM

Please open a new thread. This thread is from 2006 and isn't related PXE boot.

By opening a new thread it will get higher visibility - typically the only people that see older threads are those who subscribed at the time it was opened.

henry87 04-07-2010 12:54 PM

Hi

My rocks clusters 5.1 was rebooted due to some unknown reasons.
then two of the compute nodes need to be re-install. I used
a USB CDROM. However, during the installation process, I was told
that the CDROM doesn't have any Rocks disk inside it as described by
previous post. I am not sure when to type "linux ide=nodma". Could
someone help?

what I did is follows:

1) from the front node, type "insert-ethers" as root
2) choose "Compute" and hit "OK" button.
3) Insert Rocks Clusters 5.1 kernel CD into my USB CDROM attached to my compute node
4) Boot my compute node
5) There is a Rocks Clusters Flash window with a prompt "boot:", i typed
"linux ide=nodma" here, and I was told that no kernel "linux=ide=nodma" was found.

thanks for your attention and help

regards

Henry

MensaWater 04-07-2010 01:15 PM

Please open a new thread. This thread is from 2006 and isn't related USB CD boot. The likely issue has to do with the driver being needed for USB booting. The above is about IDE CD boot.

By opening a new thread it will get higher visibility - typically the only people that see older threads are those who subscribed at the time it was opened.


All times are GMT -5. The time now is 10:09 AM.