LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Yum Won't Update Due To Missing Dependency on New Installation (http://www.linuxquestions.org/questions/red-hat-31/yum-wont-update-due-to-missing-dependency-on-new-installation-732467/)

cmnorton 06-12-2009 08:40 AM

Yum Won't Update Due To Missing Dependency on New Installation
 
I have yet another Yum missing dependency issue for a fairly newly installed Red Hat EL 5 WS install. I have been working with Red Hat support for over a month with no success. Here is the tail end of the yum update:

--> Finished Dependency Resolution
db4-devel-4.3.29-9.fc6.i386 from installed has depsolving problems
--> Missing Dependency: db4 = 4.3.29-9.fc6 is needed by package db4-devel-4.3.29-9.fc6.i386 (installed)
sqlite-devel-3.3.6-2.i386 from installed has depsolving problems
--> Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
Error: Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
Er

Given this is a new install with no special packages added, I just want to go back to plain old vanilla updates. I've tried purging the cache with no success. Any ideas on how to reset this?

ilikejam 06-12-2009 10:21 AM

Umm,

Remove the Fedora 6 repo from /etc/yum.conf or /etc/yum.d/wherever, then:

# rpm -e sqlite-devel
# rpm -e db4-devel
# yum install sqlite-devel db4-devel
# yum update

Dave

cmnorton 06-12-2009 10:31 AM

Wound up removing those packages
 
Thanks for your reply.

I added a rpm -e for rpm-dev on which the sql-lite-dev package depended. After executing the rest of the commands, I got the same error. Given I am not using either of those packages, I removed them, and updated.

That was successful. Again, thank you for your reply.


All times are GMT -5. The time now is 01:31 PM.