LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 06-12-2009, 08:40 AM   #1
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
Yum Won't Update Due To Missing Dependency on New Installation


I have yet another Yum missing dependency issue for a fairly newly installed Red Hat EL 5 WS install. I have been working with Red Hat support for over a month with no success. Here is the tail end of the yum update:

--> Finished Dependency Resolution
db4-devel-4.3.29-9.fc6.i386 from installed has depsolving problems
--> Missing Dependency: db4 = 4.3.29-9.fc6 is needed by package db4-devel-4.3.29-9.fc6.i386 (installed)
sqlite-devel-3.3.6-2.i386 from installed has depsolving problems
--> Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
Error: Missing Dependency: sqlite = 3.3.6-2 is needed by package sqlite-devel-3.3.6-2.i386 (installed)
Er

Given this is a new install with no special packages added, I just want to go back to plain old vanilla updates. I've tried purging the cache with no success. Any ideas on how to reset this?

Last edited by cmnorton; 06-12-2009 at 08:41 AM. Reason: fix note
 
Old 06-12-2009, 10:21 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Umm,

Remove the Fedora 6 repo from /etc/yum.conf or /etc/yum.d/wherever, then:

# rpm -e sqlite-devel
# rpm -e db4-devel
# yum install sqlite-devel db4-devel
# yum update

Dave

Last edited by ilikejam; 06-12-2009 at 10:23 AM.
 
Old 06-12-2009, 10:31 AM   #3
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Original Poster
Rep: Reputation: 35
Wound up removing those packages

Thanks for your reply.

I added a rpm -e for rpm-dev on which the sql-lite-dev package depended. After executing the rest of the commands, I got the same error. Given I am not using either of those packages, I removed them, and updated.

That was successful. Again, thank you for your reply.
 
  


Reply

Tags
dependency, yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Dependency - yum hectorDUQUE Fedora 6 06-29-2008 08:33 PM
Yum update fails - Missing Dependency godisadj Fedora 5 01-02-2008 05:44 AM
yum update gives 'Error: Missing Dependency:" on fresh install tightface Linux - Software 4 07-04-2007 02:10 AM
How to tell yum missing dependency is actually there decrepit Fedora 2 02-04-2007 05:36 AM
yum missing dependencY puppet Linux - Software 6 10-26-2005 10:20 AM


All times are GMT -5. The time now is 11:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration