Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 05-10-2005, 07:39 PM   #1
LQ Newbie
Registered: Oct 2003
Location: SF Bay Area
Distribution: Slackware, Red Hat, Fedora, Suse
Posts: 9

Rep: Reputation: 0
yum update and SpamAssassin dependancy

When I run yum update i get the following error and no packages are updated.
Appreciate any help.

--> Running transaction check
--> Processing Dependency: perl(Digest::HMAC_MD5) for package: perl-Net-DNS
--> Processing Dependency: perl-Mail-SpamAssassin = 3.0.2-1 for package: spamassassin-tools
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Digest-HMAC.noarch 0:1.01-13 set to be updated
--> Running transaction check
--> Processing Dependency: perl-Mail-SpamAssassin = 3.0.2-1 for package: spamassassin-tools
--> Finished Dependency Resolution
Error: Missing Dependency: perl-Mail-SpamAssassin = 3.0.2-1 is needed by package spamassassin-tools

Old 05-17-2005, 09:55 PM   #2
Registered: Dec 2004
Location: Hawaii
Distribution: Fedora & CentOS
Posts: 72

Rep: Reputation: 15
What is enabled in your yum repo?

I recomend that you use the atomic yum repo for new software build for rh9. You can find some file here:

Below all the files are all the different repos this guy has setup. Most of them are for plesk servers, but the ones that don't say "psa" in them you can probably use just fine.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
yum question: How to update from backed up yum cache? Arodef Linux - Software 2 02-02-2010 11:42 PM
FC4: "yum update libcddb" fails -- missing dependancy problem: MattCrypto Fedora 2 07-28-2005 06:47 PM
YUM - - Can't install! Dependancy problem on RH9? irlkersten Red Hat 7 05-07-2005 08:34 PM
PERL update -> broke Spamassassin froedi Linux - Software 0 01-23-2005 08:08 AM
spamassassin fails after update blaroe Linux - Software 2 04-14-2004 11:02 AM

All times are GMT -5. The time now is 10:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration