LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   yum on redhat 5.3 not work python module problem (http://www.linuxquestions.org/questions/red-hat-31/yum-on-redhat-5-3-not-work-python-module-problem-718180/)

cormanstnl 04-10-2009 07:27 AM

yum on redhat 5.3 not work python module problem
 
Since a update, I'am not enable to use yum.

If I run yum, I have :
# yum update
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

/usr/lib64/python2.4/site-packages/rpm/_rpmmodule.so: undefined symbol: rpmdbCheckTerminate

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Sep 17 2008, 16:07:08)
[GCC 4.1.2 20071124 (Red Hat 4.1.2-41)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://wiki.linux.duke.edu/YumFaq

I googled and check the YumFaq and no result
WARNING : I use a 64 arch.

Could you help me ?
thanks

unixmen 04-10-2009 09:26 AM

Quote:

Originally Posted by cormanstnl (Post 3504506)
Since a update, I'am not enable to use yum.

If I run yum, I have :
# yum update
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

/usr/lib64/python2.4/site-packages/rpm/_rpmmodule.so: undefined symbol: rpmdbCheckTerminate

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Sep 17 2008, 16:07:08)
[GCC 4.1.2 20071124 (Red Hat 4.1.2-41)]

If you cannot solve this problem yourself, please go to
the yum faq at:
http://wiki.linux.duke.edu/YumFaq

I googled and check the YumFaq and no result
WARNING : I use a 64 arch.

Could you help me ?
thanks


reinstall you python but not with yum remove .
because the python packages version is not compatible with the yum version .


just
rpm -qa | grep python
rpm -e --nodeps python...

wget of download the Pyhton package from Redhat site
rpm -ivh python .


All times are GMT -5. The time now is 11:08 AM.