LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 11-18-2010, 05:18 AM   #1
alokatzenith
LQ Newbie
 
Registered: Aug 2007
Posts: 16

Rep: Reputation: 1
yum : not resolving dependencies


Hi, I am a newbie in the world of linux. I installed RHEL 5 on my desktop a few days back. I want to enjoy movies in my new OS. Some one told me to install mplyer caz it plays any file. So I decided to install it. I issued the following command:



[root@pcel-idg yum.repos.d]# yum install resolvedep mplayer.i386
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: resolvedep
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mplayer to pack into transaction set.
mplayer-1.0-0.43.svn20090 100% |=========================| 17 kB 00:01
---> Package mplayer.i386 0:1.0-0.43.svn20090711.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: liblirc_client.so.0 for package: mplayer
--> Processing Dependency: libvga.so.1 for package: mplayer
--> Processing Dependency: libgif.so.4 for package: mplayer
--> Processing Dependency: libamrwb.so.3 for package: mplayer
--> Processing Dependency: libungif.so.4 for package: mplayer
--> Processing Dependency: libXvMCW.so.1 for package: mplayer
--> Processing Dependency: libfaac.so.0 for package: mplayer
--> Processing Dependency: libmad.so.0 for package: mplayer
--> Processing Dependency: libdirac_encoder.so.0 for package: mplayer
--> Processing Dependency: libdca.so.0 for package: mplayer
--> Processing Dependency: mplayer-fonts for package: mplayer
--> Processing Dependency: libamrnb.so.3 for package: mplayer
--> Processing Dependency: libfribidi.so.0 for package: mplayer
--> Processing Dependency: libartsc.so.0 for package: mplayer
--> Processing Dependency: libx264.so.68 for package: mplayer
--> Processing Dependency: libmp3lame.so.0 for package: mplayer
--> Processing Dependency: libdirectfb-1.2.so.0 for package: mplayer
--> Processing Dependency: liblzo2.so.2 for package: mplayer
--> Processing Dependency: libenca.so.0 for package: mplayer
--> Processing Dependency: libXvMC.so.1 for package: mplayer
--> Processing Dependency: libSDL-1.2.so.0 for package: mplayer
--> Processing Dependency: libmpcdec.so.5 for package: mplayer
--> Processing Dependency: libcaca.so.0 for package: mplayer
--> Processing Dependency: libopenal.so.0 for package: mplayer
--> Processing Dependency: libaa.so.1 for package: mplayer
--> Processing Dependency: libdirac_decoder.so.0 for package: mplayer
--> Processing Dependency: libxvidcore.so.4 for package: mplayer
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libcaca to pack into transaction set.
libcaca-0.99-0.1.beta17.e 100% |=========================| 4.5 kB 00:00
---> Package libcaca.i386 0:0.99-0.1.beta17.el5.rf set to be updated
---> Downloading header for lirc to pack into transaction set.
lirc-0.6.6-4.el5.rf.i386. 100% |=========================| 26 kB 00:00
---> Package lirc.i386 0:0.6.6-4.el5.rf set to be updated
---> Downloading header for libdca to pack into transaction set.
libdca-0.0.5-1.el5.rf.i38 100% |=========================| 4.1 kB 00:00
---> Package libdca.i386 0:0.0.5-1.el5.rf set to be updated
---> Downloading header for faac to pack into transaction set.
faac-1.26-1.el5.rf.i386.r 100% |=========================| 4.9 kB 00:00
---> Package faac.i386 0:1.26-1.el5.rf set to be updated
---> Downloading header for libmpcdec to pack into transaction set.
libmpcdec-1.2.6-1.el5.rf. 100% |=========================| 4.2 kB 00:00
---> Package libmpcdec.i386 0:1.2.6-1.el5.rf set to be updated
---> Downloading header for enca to pack into transaction set.
enca-1.10-1.el5.rf.i386.r 100% |=========================| 4.8 kB 00:00
---> Package enca.i386 0:1.10-1.el5.rf set to be updated
---> Downloading header for openal to pack into transaction set.
openal-0.0.8-2.el5.rf.i38 100% |=========================| 4.5 kB 00:00
---> Package openal.i386 0:0.0.8-2.el5.rf set to be updated
---> Downloading header for xvidcore to pack into transaction set.
xvidcore-1.2.2-1.el5.rf.i 100% |=========================| 4.2 kB 00:00
---> Package xvidcore.i386 0:1.2.2-1.el5.rf set to be updated
---> Downloading header for lzo2 to pack into transaction set.
lzo2-2.04-1.el5.rf.i386.r 100% |=========================| 4.2 kB 00:00
---> Package lzo2.i386 0:2.04-1.el5.rf set to be updated
---> Downloading header for aalib to pack into transaction set.
aalib-1.4.0-5.el5.rf.i386 100% |=========================| 6.1 kB 00:00
---> Package aalib.i386 0:1.4.0-5.el5.rf set to be updated
---> Downloading header for lame to pack into transaction set.
lame-3.98.4-1.el5.rf.i386 100% |=========================| 6.7 kB 00:00
---> Package lame.i386 0:3.98.4-1.el5.rf set to be updated
---> Downloading header for amrnb to pack into transaction set.
amrnb-7.0.0.2-1.el5.rf.i3 100% |=========================| 4.7 kB 00:00
---> Package amrnb.i386 0:7.0.0.2-1.el5.rf set to be updated
---> Downloading header for mplayer-fonts to pack into transaction set.
mplayer-fonts-1.1-3.0.rf. 100% |=========================| 14 kB 00:00
---> Package mplayer-fonts.noarch 0:1.1-3.0.rf set to be updated
---> Downloading header for svgalib to pack into transaction set.
svgalib-1.9.25-1.el5.rf.i 100% |=========================| 13 kB 00:00
---> Package svgalib.i386 0:1.9.25-1.el5.rf set to be updated
---> Downloading header for directfb to pack into transaction set.
directfb-1.2.4-1.el5.rf.i 100% |=========================| 23 kB 00:00
---> Package directfb.i386 0:1.2.4-1.el5.rf set to be updated
---> Downloading header for libmad to pack into transaction set.
libmad-0.15.1b-4.el5.rf.i 100% |=========================| 4.2 kB 00:00
---> Package libmad.i386 0:0.15.1b-4.el5.rf set to be updated
---> Downloading header for amrwb to pack into transaction set.
amrwb-7.0.0.3-1.el5.rf.i3 100% |=========================| 3.5 kB 00:00
---> Package amrwb.i386 0:7.0.0.3-1.el5.rf set to be updated
---> Downloading header for dirac to pack into transaction set.
dirac-1.0.2-1.el5.rf.i386 100% |=========================| 9.4 kB 00:00
---> Package dirac.i386 0:1.0.2-1.el5.rf set to be updated
---> Downloading header for x264 to pack into transaction set.
x264-0.0.0-0.4.20090708.e 100% |=========================| 4.4 kB 00:00
---> Package x264.i386 0:0.0.0-0.4.20090708.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libXvMC.so.1 for package: mplayer
--> Processing Dependency: libSDL-1.2.so.0 for package: mplayer
--> Processing Dependency: libgif.so.4 for package: mplayer
--> Processing Dependency: libungif.so.4 for package: mplayer
--> Processing Dependency: libcppunit-1.12.so.0 for package: dirac
--> Processing Dependency: libXvMCW.so.1 for package: mplayer
--> Processing Dependency: libfribidi.so.0 for package: mplayer
--> Processing Dependency: libts-0.0.so.0 for package: directfb
--> Processing Dependency: libSDL-1.2.so.0 for package: openal
--> Processing Dependency: libartsc.so.0 for package: mplayer
--> Processing Dependency: libartsc.so.0 for package: openal
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for cppunit to pack into transaction set.
cppunit-1.12.0-3.el5.rf.i 100% |=========================| 5.1 kB 00:00
---> Package cppunit.i386 0:1.12.0-3.el5.rf set to be updated
---> Downloading header for tslib to pack into transaction set.
tslib-1.0-1.el5.rf.i386.r 100% |=========================| 8.3 kB 00:00
---> Package tslib.i386 0:1.0-1.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libXvMC.so.1 for package: mplayer
--> Processing Dependency: libSDL-1.2.so.0 for package: mplayer
--> Processing Dependency: libgif.so.4 for package: mplayer
--> Processing Dependency: libungif.so.4 for package: mplayer
--> Processing Dependency: libXvMCW.so.1 for package: mplayer
--> Processing Dependency: libfribidi.so.0 for package: mplayer
--> Processing Dependency: libSDL-1.2.so.0 for package: openal
--> Processing Dependency: libartsc.so.0 for package: mplayer
--> Processing Dependency: libartsc.so.0 for package: openal
--> Finished Dependency Resolution
Error: Missing Dependency: libgif.so.4 is needed by package mplayer
Error: Missing Dependency: libungif.so.4 is needed by package mplayer
Error: Missing Dependency: libXvMCW.so.1 is needed by package mplayer
Error: Missing Dependency: libfribidi.so.0 is needed by package mplayer
Error: Missing Dependency: libartsc.so.0 is needed by package mplayer
Error: Missing Dependency: libXvMC.so.1 is needed by package mplayer
Error: Missing Dependency: libSDL-1.2.so.0 is needed by package mplayer
Error: Missing Dependency: libSDL-1.2.so.0 is needed by package openal
Error: Missing Dependency: libartsc.so.0 is needed by package openal
[root@pcel-idg yum.repos.d]#





As you can see yum is not resolving the dependencies. Can anyone please help me out and let me enjoy some movies .
 
Old 11-18-2010, 05:21 AM   #2
GrapefruiTgirl
Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550Reputation: 550
I believe the root of your problem is here:
Quote:
This system is not registered with RHN.
You need to register your RHEL OS with RHN (which costs money) in order to use RHN for updates.
Solutions:

1 - pay for support and updates.
2 - Manually install packages by hand ( I believe you can do this even without a registered system)
3 - Install something else, like Fedora or CentOS, which are like RedHat, only not.
 
  


Reply

Tags
yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum GUI complaining about dependencies but not resolving them ! nkd Linux - Software 3 11-29-2008 05:15 AM
yum not resolving correct dependencies schneidz Linux - Software 1 10-10-2008 05:15 PM
resolving dependencies panurge Linux - General 1 08-11-2007 07:03 AM
Need help resolving some dependencies. obelxi Linux - General 2 03-16-2005 02:57 PM
Resolving dependencies Calcutec Linux - Software 4 09-08-2002 03:21 PM


All times are GMT -5. The time now is 12:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration