LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 06-14-2004, 02:01 PM   #1
zepplin611
Member
 
Registered: Jan 2004
Distribution: AIX 4.3 RH 7,8,9 / Fedora C1/
Posts: 187

Rep: Reputation: 30
Yum error: .conflict between perl and perl-NDBM_File


Greetings,

I am running yum update on a RH 9.0 machine (yum version: yum-2.0.7-1). The following error
crept up while trying to update the machine:

.conflict between perl and perl-NDBM_File

A google of this error revealed:

in rhl 8.0 perl obsoleted perl-NDBM_File
but that obsolete was removed in rhl 9.

however, I am not sure that deleting perl-NDBM_File is the proper course of action.

Any ideas/suggestions on how to stop this error and move forward with bringing this machine up to
date?

thanks a bunch

zepp
 
Old 06-16-2004, 09:47 PM   #2
zepplin611
Member
 
Registered: Jan 2004
Distribution: AIX 4.3 RH 7,8,9 / Fedora C1/
Posts: 187

Original Poster
Rep: Reputation: 30
I still need an answer to this question...if anyone can cross-post it for me across forum's I would greatly appreciate it...I have numerous RH 9.0 machines that need to be updated and I'm stuck with how to do it via yum or in any other manner....

thanks for everyone's help

zepplin611
 
Old 10-19-2004, 10:13 AM   #3
yanetdk
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Cool rebuild rpm database

Hi!

I had the same problem, but it helped to rebuild the rpm database with:

rpm -vv --rebuilddb

After that i could do the rpm -e without getting an error

;-Peter
Yanet.dk
 
Old 10-20-2004, 10:22 AM   #4
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Re: Yum error: .conflict between perl and perl-NDBM_File

Quote:
A google of this error revealed:

in rhl 8.0 perl obsoleted perl-NDBM_File
Cannot confirm that:

$ rpm -qp --obsoletes perl-5.8.0-88.3.i386.rpm
perl-Digest-MD5
perl-MIME-Base64
perl-libnet
perl-Storable

Try to install the packages manually with "rpm -Uvvh" to see where they conflict.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with perl module for w3c validator to work on my local Apache+PHP+perl instal tbamt Linux - Software 0 12-16-2004 05:37 PM
Hiding code in PERL, perl gui question randomx Programming 1 06-26-2004 03:22 PM
cgi perl : I cant get perl to append my html file... the_y_man Programming 3 03-22-2004 05:07 AM
perl(Cwd) perl(File::Basename) perl(File::Copy) perl(strict)....What are those? Baldorg Linux - Software 1 11-09-2003 08:09 PM
chrooting apache v2 (php, ssl, perl support) ; perl configuration markus1982 Linux - Security 3 01-26-2003 06:15 PM


All times are GMT -5. The time now is 02:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration