LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Wireless keeps disconnecting from AP (http://www.linuxquestions.org/questions/red-hat-31/wireless-keeps-disconnecting-from-ap-92192/)

mickeyboy 09-12-2003 10:27 PM

Wireless keeps disconnecting from AP
 
Redhat9.0/2.4.20-19.9/
I having problems with one of my boxes, wireless nic, keeps
disconnecting from AcessPoint.
When the computer boots ,it loads AMD8211 module and
starts Network and after logging-in you can start Mozilla and
get on the internet, but if you shut down mozilla, and let the
box set there at idle the, the nic disconnects from the AccessPoint,
and the Desktop slows down, any windows you try to open,
it opens and closes very slow.
If I goto the Network Configuration gui and deactivate and
then activate network, The network (nic)starts to communicate
with the AccessPoint. the process starts over again when the
computer sets idle.
I,m not having any problems with nic and box and not getting
any errors when booting.
I have listed the settings below.
Please help.
Jim Tate

This is ifconfig,and it does not shutoff.
/sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:E0:98:AF:39:40
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11126 errors:0 dropped:0 overruns:0 frame:0
TX packets:461 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1187001 (1.1 Mb) TX bytes:58337 (56.9 Kb)
Interrupt:3 Base address:0xa400

This is iwconfig, when the box is connected to the Access Point.
/sbin/iwconfig
eth0 IEEE 802.11-DS ESSID:"linksys-g" Nickname:"admin"
Mode:Managed Frequency:2.437GHz Access Point: 00:90:4B:24:D6:6C
Bit Rate=2.8Mb/s Tx-Power=47 dBm Sensitivity:0/65535
Retry limit:3 RTS thr=2346 B Fragment thr=2346 B
Power Management:off
Link Quality:100 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

This is iwconfig, when the box disconnects from the Access Point.
/sbin/iwconfig
lo no wireless extensions.

eth0 IEEE 802.11-DS ESSID:"linksys-g" Nickname:"admin"
Mode:Managed Frequency:2.437GHz Access Point: 00:00:00:00:00:00
Bit Rate=2.8Mb/s Tx-Power=47 dBm Sensitivity:0/65535
Retry limit:3 RTS thr=2346 B Fragment thr=2346 B
Power Management:off
Link Quality:95 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


This is my ifcfg-eth0, I have changed the settings all kinds of ways to communicate with the Access Point. If I set Bootproto=
static if keeps changing back to =none. Changing to ESSID=linksys-g or Rate=11M or Mode=Auto doesn't help either.

USERCTL=no
PEERDNS=no
GATEWAY=192.168.1.1
ONBOOT=yes
TYPE=Wireless
IPADDR=192.168.1.3
DEVICE=eth0
HWADDR=00:e0:98:af:39:40
BOOTPROTO=none
NETMASK=255.255.255.0
ESSID=
CHANNEL=6
MODE=Managed
RATE=Auto
BROADCAST=192.168.1.255
NETWORK=192.168.1.0
DOMAIN=
DHCP_HOSTNAME=
KEY=

akaBeaVis 09-12-2003 11:11 PM

This looks much more like a power management issue than a network issue, are you running apmd? are there messages in you /var/log/messages regarding power management? If not, have you tried using iwconfig with the power property defined? Do a "man iwconfig" to see how the power parameter can be used. If all that was happening was that the card was "sleeping" and disconnecting from the ap, then I would say it was the card, but you're saying everything else seems to be sluggish also, so it's not just the wireless card.

mickeyboy 09-12-2003 11:59 PM

I shut down the apmd in Services and rebooted the computer and still have the same problem.
If I deactivate in Network Configuration, at least the desktop
works faster.

Thanks
Jim Tate

akaBeaVis 09-13-2003 12:16 AM

well, there's no way the wireless extensions, which are compiled into the kernel suddenly disappear after a period of dis-use, nope, not happening. Is it possible that this is somehow related to my nemesis: ACPI? yes, I hate the acronym and all it stands for, is your machine recent enough to employ acpi? do you see anything in dmesg about acpi or apic?

wackman 09-13-2003 12:43 AM

I would agree that this sounds like a power management issue. It sounds like the card is sleeping and you need to shut down the connection and bring it back up again to get everything working. Follow previous advice and see if you have the card configured somewhere to go to sleep after a period of inactivity.

As for your computer acting slugish, this is deffinitely related. With pretty much any modern networking-aware OS, many simple actions like moving a window or opening a file explorer will poll the network just in case you're going to be accessing network resources (I've only heard of this happening on Windows, but it wouldn't suprise me for it to be in linux too). The reason why it's slow is that the computer keeps trying to search for the network (or at least the wireless part of the network) and finally times out and gives up.

For example, you open konqueror and the OS (depending on low-level networking configuration) could be pre-fetching and caching network shares and resources just in the case you're going to use them.

Reader's Digest answer: Fix the wireless card problem and you'll fix your sluggishness.

mickeyboy 09-13-2003 01:29 PM

I did a "/sbin/iwconfig eth0 power off" and that did not make any difference.
I also did a cut on the source code for the 8211.o module and it's use of power management , listed below.
, but i don't understand source code, someday!!
I do believe that the man page for iwconfig is the best man page i have ever seen in Linux
I just love those "Examples" .

Thanks
Jim Tate


This a cut from "man iwconfig" on howto manipulate power management.
--------------------------------------------------------------------

power Used to manipulate power management scheme parameters and mode.
To set the period between wake up, enter period ‘value’. To set
the timeout before going back to sleep, enter timeout ‘value’.
You can also add the min and max modifiers. By defaults, those
values are in seconds, append the suffix m or u to specify val-
ues un milliseconds or microseconds. Sometimes, those values are
without units (number of dwell or the like).
off and on disable and reenable power management. Finally, you
may set the power management mode to all (receive all packets),
unicast (receive unicast packets only, discard multicast and
broadcast) and multicast (receive multicast and broadcast only,
discard unicast packets).
Examples :
iwconfig eth0 power period 2
iwconfig eth0 power 500m unicast
iwconfig eth0 power timeout 300u all
iwconfig eth0 power off
iwconfig eth0 power min period 2 power max period 4




This is a cut from the ADM8211 source code on power management. I'm not that good on understanding source code,
can anyone help?
-----------------------------------------------------------------------------------------------------------

/***** Power saving stuff(power management, unicast and multicast) *****/
case SIOCSIWPOWER:/* set Power Management settings */
//wrq->u.power.fixed = 1;
wrq->u.power.flags=0;
wrq->u.power.value=0;
wrq->u.power.disabled = 1;

break;

case SIOCGIWPOWER:/* get Power Management settings */
//wrq->u.power.fixed = 1;
wrq->u.power.flags=0;
wrq->u.power.value=0;
wrq->u.power.disabled = 1;
break;
/* ************* end of Power saving *********** */
case SIOCSIWTXPOW:/* set transmit power (dBm) */

#ifdef ioctl_debug
printk("Set TxPower value =%d fixed=%x disabled=%x flags=%x \n",wrq->u.txpower.value,
wrq->u.txpower.fixed, wrq->u.txpower.disabled, wrq->u.txpower.flags);
#endif

if( wrq->u.txpower.disabled == 1)
pDevice->LM_Device.TxPowerFlag=Disable;
else
{
if (( wrq->u.txpower.value >= 0x00 ) && ( wrq->u.txpower.value <= 0x3f ) )
{
if( wrq->u.txpower.value == -1 )
{
wrq->u.txpower.value=0x2f;
}
pDevice->LM_Device.TxPowerFlag=Enable;
netif_stop_queue(dev);
query_buf[0]=wrq->u.txpower.value;
UM_Set_Information(&(pDevice->STA_Module), OID_802_11_TX_POWER_LEVEL , query_buf, &query_len);
netif_start_queue(dev);

}
}

break;
case SIOCGIWTXPOW:/* get transmit power (dBm) */
/*we should know current channel*/
UM_Query_Information(&(pDevice->STA_Module), OID_802_11_TX_POWER_LEVEL , query_buf, &query_len);
wrq->u.txpower.value=query_buf[0];
wrq->u.txpower.fixed = 1;
if (pDevice->LM_Device.TxPowerFlag == Disable )
wrq->u.txpower.disabled = 1;
else
wrq->u.txpower.disabled = 0;
wrq->u.txpower.flags = IW_TXPOW_DBM;

break;

akaBeaVis 09-13-2003 02:09 PM

is this the 1.03 or 1.0.5 source code? or, is this source from admtek's download page at all? I agree with wackman, the sluggishness could certainly be the result of lengthy network timeouts occurring, for instance, in kde and X itself many things are done via sockets.

I notice that the kernel you're using is not the "stock" redhat 9.0 kernel. When compiling kernel modules, it's imperative that the source code residing in the directory pointed to by the /lib/modules/`uname -r`/build symlink match the running kernel (ie: it was the same source used to compile it), and that the .config in /boot match also (ie: this was the actual config file used to compile the running kernel), perhaps there's a mis-configuration there.

mickeyboy 09-13-2003 02:50 PM

The driver i downloaded from ADMtec was the ADM8211_src_105.tar.gz.
It was compiled with 2.4.20-19.9 kernel, "make" from/usr/src/linux-2.4.20-19.9/ADM8211 source code.
I moved the ADM8211 directory to that location after I extracted it.
The only problems I had was when I did insmod 8211.o it kept
saying it could not find 8211.o and modprobe was no help.
i phyiscally moved 8211.o to /lib/modules/2.4.20-19.9/kernel/drivers/net/wireless.

akaBeaVis 09-13-2003 05:36 PM

unload the driver with a rmmod 8211, then do a depmod -a, then reload it with modprobe, not insmod, might help, might not.

mickeyboy 09-13-2003 06:50 PM

Nope, that didn't work either, but i did learn howto use modprobe.
I guess I will have to reside to the fact that I have got a bad module.
Thanks Guy's for your help.

Jim Tate

mickeyboy 09-14-2003 01:50 PM

Well I guess I have got to give up on this ADM8211 until
ADMtec.com can fix it. I sent them a email explaining all
this, so I hope they will address it. they never responded
to any of my emails. so I'm in the dark about what's going on.
My computer is a dual boot with $Windows98 2nd ed.
I install the windows98 driver and the pci/nic works fine in
Windows98 and does not disconnect from AP,with 100%
link connection.

Well guys I want to thank all of you who help.

Jim Tate

akaBeaVis 09-14-2003 03:37 PM

I just had the same problem on a machine running slack9 with an admtek wireless pci card, it's a trendnet tew-223pi, I'm using the same source as you. Everything got sluggish, I'm using kde and the whole thing got slow, this is an older machine with no acpi, and apmd was not running. It has a voodoo3 card and normally I get 460 or so fps in glxgears, at that point it was under 100, I did an ifconfig eth0 down, rmmod 8211 and then modprobe 8211, then I had to do ifconfig, iwconfig and route to simulate the bootup stuff in slackware. I also noticed that rate auto showed a 22M speed and doubled my ping time to the router, rate 11M was much better. One thing you may not have done that I did just to see if I could stop the "unresolved symbols" errors on a depmod -a was to copy *all* the *.o files from the ADM8211 source directory to my /lib/modules/`uname -r`/kernel/drivers/net directory, this stops those errors but causes an attempted load of the adm8211.o file which finds no device and so no harm done.

forgot to add this bit:
At the time of the "slowdown", iwconfig was showing the Access Point as all 0's, and yet I was still associated and using the connection normally.

just wanted to let you know, it's not just you...

mickeyboy 09-14-2003 04:49 PM

Well at least I'm not in this world by myself.
If you could goto http://www.admtek.com.tw and at top
of page you will find Download&Support/Support Teams and
email the Nic Support teams and give your side of the story.
If enough of us state our case maybe they will fix the problem.
Don't expect a reply to your email, it won't come.

LOL
Jim Tate

akaBeaVis 09-14-2003 05:26 PM

I'll do that.

Nightjester 11-23-2003 08:12 AM

ADMTek card disconnecting
 
I have been having somewhat of a similar problem with my TrendNet TEW-223PI network card since I first installed it. The card in question is running the internet link to the rest of my computers in my house, so I normally am not running any browsing apps directly on the server. However, after a 'random' length of time, the card will suddenly drop off the network and be inaccessible until you reset the network interface - ifdown eth1, ifup eth1. This normally happened about once a day. I recently installed a wireless print server and the problem has started to occur much more frequently. In order to function at all well without having to run around the house resetting the interface, I'm running a bash script for the file-server to ping the print server and if it's unreachable, reset the network... it does this every 2 seconds. (oi!) It seems that the more computers are on the wireless network, the more problems this driver has. Here's an output of the log entries generated from the script:
Nov 23 00:08:10 Resetting eth1
Nov 23 00:10:25 Resetting eth1
Nov 23 00:26:11 Resetting eth1
Nov 23 00:33:01 Resetting eth1
Nov 23 00:37:39 Resetting eth1
Nov 23 00:39:33 Resetting eth1
Nov 23 00:42:06 Resetting eth1
Nov 23 00:44:27 Resetting eth1
Nov 23 00:48:36 Resetting eth1

As you can see, it's become very unreliable. Looking back at my /var/log/messages log, I see the trademark entry that has always shown up when it drops off the network:
Nov 22 16:32:27 fileserver kernel: set channel 4
Nov 22 16:32:28 fileserver testnet.sh - Resetting eth1
Nov 22 16:32:29 fileserver kernel: set channel 4
Nov 22 16:32:32 fileserver kernel: start to send packet

The first set channel always occurs when the interface stops responding, the next line is the script resetting the network, and the last 2 are the results of the ifup script.

The kernel: lines are generated by the 105 driver when the adm8201_debug in lm.h is set. The set channel line is written during the LM_Set_Channel function. Why the card is setting it's channels again for no reason is beyond me.

I also had these problems with the 103 driver, but that one generated many more log messages about packets, etc. so I switched.

I have previously contacted both TrendNet (got a reply, but no help) and ADMTek (as you noticed, no reply-no help).
I'll be forwarding this mail and topic to them (again)

Mandrake 9.1, kernel: 2.4.21-0.25mdk
iwtools v 26


All times are GMT -5. The time now is 04:41 PM.