LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 04-30-2013, 11:36 PM   #1
sumangsh
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Rep: Reputation: Disabled
wireless is not enable in my RedHat enterprise linux 6 box


in my Redhat enterprise linux 6 system wireless not getting activated. And I can see also wireless device also not showing. Please help.Thanks in advance.

[root@dhcppc0 ~]# lspci
00:00.0 Host bridge: Intel Corporation Sandy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Sandy Bridge Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation Cougar Point HECI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation Cougar Point High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 5 (rev b5)
00:1c.7 PCI bridge: Intel Corporation Cougar Point PCI Express Root Port 8 (rev b5)
00:1d.0 USB Controller: Intel Corporation Cougar Point USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Cougar Point LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation Cougar Point 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation Cougar Point SMBus Controller (rev 05)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
09:00.0 Network controller: Intel Corporation Device 008a (rev 34)

0b:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
[root@dhcppc0 ~]#
 
Old 05-01-2013, 12:51 AM   #2
Terminator3000
Member
 
Registered: Jun 2012
Distribution: Centos 6 & Fluxbox
Posts: 86

Rep: Reputation: Disabled
See this post on setting up wireless via DHCP it is for Centos 6 which is an rpm based system.
 
Old 05-01-2013, 07:04 AM   #3
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,057
Blog Entries: 1

Rep: Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373Reputation: 1373
Moderator Response

Moved: This thread is more suitable in <RedHat> and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 05-01-2013, 09:45 AM   #4
Terminator3000
Member
 
Registered: Jun 2012
Distribution: Centos 6 & Fluxbox
Posts: 86

Rep: Reputation: Disabled
You have 2 network controllers, can't tell from here if one is the wireless device but even if it is, the fact that it is showing with the lspci command does not necessarily mean that it is installed properly or at all. You need the drivers installing/building properly, so first find them and follow the instructions to build, most likely a simple ./configure, make & make install from a suitable directory like /tmp or /usr/local. Then run

$ sudo ifconfig -a

and make sure you have an output like the eth0 one but appearing as

wlan0 or similar - then you should be ready to set up the connection

Go to the post on wireless setup for RHEL to set it up, although the post is for wep/dhcp it should at least get you going.
 
Old 05-18-2013, 12:04 AM   #5
sumangsh
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
At the time of startup its showing wrong mac address asigned. but i checked from windows that the mac address is same which i asigned. Please suggest.
 
Old 05-18-2013, 01:45 AM   #6
Terminator3000
Member
 
Registered: Jun 2012
Distribution: Centos 6 & Fluxbox
Posts: 86

Rep: Reputation: Disabled
You need to make sure that the correct mac address is in your /etc/sysconfig/network-scripts/ifcfg-wlan0 file. Try this

$ sudo grep wlan0 /var/log/dmesg

and check that the output is the same as in your wlan0-ifcfg file.

$ cat /etc/sysconfig/network-scripts/ifcfg-wlan0

if not, change it

$ sudo vi /etc/sysconfig/network-scripts/ifcfg-wlan0

change the HWADDR of this to the output of the first command above

Substitute 'wlan0' for whatever name your device has
 
Old 05-19-2013, 12:25 AM   #7
sumangsh
LQ Newbie
 
Registered: Apr 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
there is no such line with wlan0 in dmesg.i have attached dmesg and ifcfg-wlan0 file.Please check and suggest. Thanks in advance.
Most of ridiculous thing is when i am trying to enable or disable wireless from keyboard it is working on bluetooth connection.
 
Old 05-19-2013, 03:58 AM   #8
Terminator3000
Member
 
Registered: Jun 2012
Distribution: Centos 6 & Fluxbox
Posts: 86

Rep: Reputation: Disabled
I cant see the attachment but if its not showing wlan0 or similar in either dmesg or ifcfg then probably drivers still not installed properly. ie system not detecting it. Try uninstall/reinstall drivers then run through previous again.

a. First you have to see that drivers installed so that wlan0 or similar shows in the

$ sudo ifconfig -a command

b.The HWADDR from dmesg has to be the same as the one in your ifcfg-wlan0 file, you will have to build this file manually, Centos 6 wireless runs through it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to enable telnet in redhat enterprise 5 arun.ee1988 Linux - Newbie 3 09-21-2012 02:43 AM
Enable GUI Redhat Enterprise Linux 6 server zahid Linux - Newbie 2 06-19-2012 12:46 AM
Wireless is not enable on my Redhat enterprise linux 5 box Ashish Sood Linux - General 10 02-02-2011 02:30 AM
Enable rsh service on RedHat Enterprise version 5 Fluidyn Linux - Newbie 2 06-05-2009 03:33 AM
Enable DOM in PHP5, Redhat Enterprise 4 pxumsgdxpcvjm Programming 0 09-14-2006 04:19 AM


All times are GMT -5. The time now is 06:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration