LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 02-25-2004, 08:30 PM   #1
kokfei77
LQ Newbie
 
Registered: Feb 2004
Location: Kuala Lumpur, Malaysia
Posts: 1

Rep: Reputation: 0
Unhappy vsftp - Can access FTP within office network BUT cant access via Internet!


Hi, I having a problem with FTP service setup on Linux RedHat 8.0. I have do the necessary configuration according the samples that I have downloaded from few web sites. And I have verified that the FTP is working within office network (Eg. I can upload and download files from the RedHat 8.0 FTP server with > ftp 192.168.100.133)

But when I tried to access via Internet, it prompts me as follow:

C:\>ftp 203.xxx.xxx.xxx
Connected to 203.xxx.xxx.xxx
Connection closed by remote host.

It always said 'Connection closed by remote host'.
I have tried the possible which found on Internet but all failed.

Below is my /etc/vsftpd.conf file:

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are very paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
#
# Allow anonymous FTP?
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
# dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120

# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that turning on ascii_download_enable enables malicious remote parties
# to consume your I/O resources, by issuing the command "SIZE /big/file" in
# ASCII mode.
# These ASCII options are split into upload and download because you may wish
# to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
# without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
# on the client anyway..
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
ftpd_banner="FTP ready"
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# chroot_local_user=NO
# chroot_list_enable=YES
# (default follows)
# chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
pam_service_name=vsftpd
listen_port=21
local_root=/home/Asset
hide_ids=YES
log_ftp_protocol=YES

I have tried to solved this problem since one week ago. I have no idea what can I do now? Please help!! Thank you.
 
Old 01-21-2011, 03:26 AM   #2
mtrento
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Rep: Reputation: 0
Smile check dns resolution.

For those like me who did'nt find an answer in the forums

I had some similar problem with a machine on a dmz.
ftp access from lan worked but not from the internet.

the problem was the dns server in resolv.conf . it could not be reached from the dmz.
after correcting the adress , all worked as expected.
cheers
 
Old 03-07-2012, 08:24 PM   #3
adamtarshis
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
putty tunnel

If it helps anyone - i was getting the immediate disconnect on vsftpd when trying to tunnel through putty:

C:\>ftp 203.xxx.xxx.xxx
Connected to 203.xxx.xxx.xxx
Connection closed by remote host.

I was using the external ip of the server I was trying to tunnel to - which didnt work as the server only had port 21 open locally. So I changed the putty tunnel ip to the private ip (192.168.1.x) of the server and it worked fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
access to ftp from internet yucehan Linux - Networking 3 03-07-2005 03:09 PM
Connection to access point OK, but cannot access the network/internet Nymphetamine Linux - Wireless Networking 29 01-13-2005 03:59 PM
I lose ftp access when I disable shell access for user captainObvious Linux - General 3 11-13-2004 06:49 PM
Cannot access FTP from outside network Big Jim Slade Linux - Networking 12 09-04-2004 04:20 PM
cannot access ftp or internet pfunck123 Linux - Newbie 4 11-06-2003 05:52 PM


All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration