LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 06-04-2004, 02:28 PM   #1
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Rep: Reputation: 15
Question Users couldnt get Write permission from root.


Goodday.

OS: Redhat 9

Harddisk : FAT
Need help becoz i couldnt really get users to write data into my FAT formatted harddisk.
i have aready mounted hdb5 (which is the FAT harddisk) to a folder call "windows"

Only Root have RWX permission on FAT windows.
[root@localhost mnt]# ls -l windows
total 4
drwxr-xr-x 2 root root 4096 Jun 8 00:58 Recycled

I want to allow user to have Write permission on the harddisk as well.
[root@localhost mnt]# chmod u=rwx windows

[root@localhost mnt]# ls -l windows
total 4
drwxr-xr-x 2 root root 4096 Jun 8 00:58 Recycled

But it doesnt work

I tried to change ownership to a user call novkhan but it doesnt work as well!

[root@localhost mnt]# chown novkhan windows
chown: changing ownership of `windows': Operation not permitted
[root@localhost mnt]# ls -l windows
total 4
drwxr-xr-x 2 root root 4096 Jun 8 00:58 Recycled

I hope to achieve WRX for all users on my FAT Harddisk.

drwxr-wxr-wxr

please help !
Thankyou!
 
Old 06-04-2004, 02:54 PM   #2
kevinatkins
Member
 
Registered: Jan 2004
Location: cheshire, uk
Distribution: Ubuntu Hoary
Posts: 605

Rep: Reputation: 32
hi,

this is quite a common question.

you need to set up the mount parameters for your windows partition in your /etc/fstab file.

the following is an extract from my fstab file which works -

Quote:
/dev/hda1 /windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
to edit your /etc/fstab file, you'll need root privileges, and remember to make a backup copy first, just in case..
you should then be able to write to your windows partition..
 
Old 06-04-2004, 09:35 PM   #3
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by kevinatkins
hi,

this is quite a common question.

you need to set up the mount parameters for your windows partition in your /etc/fstab file.

the following is an extract from my fstab file which works -



to edit your /etc/fstab file, you'll need root privileges, and remember to make a backup copy first, just in case..
you should then be able to write to your windows partition..
i open /etc/fstab with gedit

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/hda9 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/sda1 /mnt/thumbdrive vfat user,noauto,umask=0 0 0
/dev/hda5 /mnt/windows/c vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

i placed hdb5 which is the /dev/hda5 .... but it doesnt work?

[root@localhost root]# cd /mnt
[root@localhost mnt]# chmod 777 windows
chmod: changing permissions of `windows' (requested: 0777, actual: 0755): Operation not permitted

i tried this few options as well but in vain!

/dev/hda5 /mnt/windows vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0

/dev/hda5 /mnt/windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0


Last edited by novkhan; 06-04-2004 at 09:37 PM.
 
Old 06-04-2004, 10:01 PM   #4
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
To let a user do whatever the umask needs to be 000
 
Old 06-04-2004, 10:05 PM   #5
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
BTW, I don't know if you know this or not, but when you make changes to /etc/fstab you have to run

mount -a

for the file to be re-read
 
Old 06-05-2004, 02:25 PM   #6
novkhan
Member
 
Registered: Jan 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by darthtux
BTW, I don't know if you know this or not, but when you make changes to /etc/fstab you have to run

mount -a

for the file to be re-read
thanks i didnt knew abt this .
Any way i change it to

/dev/hda5 /mnt/windows vfat users,gid=users,umask=000,iocharset=iso8859-1,code=437 0 0

save it. I ran the command
# mount /dev/hdb5 /mnt/windows
# mount -a

I still couldnt assign write permission to user
 
Old 06-24-2004, 06:16 PM   #7
tweezerz
LQ Newbie
 
Registered: Jun 2004
Posts: 2

Rep: Reputation: 0
I'm having the same problem. Let me know if you found a solution.

Thanks,
 
Old 06-25-2004, 03:34 AM   #8
jacky
LQ Newbie
 
Registered: May 2004
Posts: 21

Rep: Reputation: 15
try to modify your /etc/fstab like this

/dev/hda1 /windows/C vfat noauto,users,umask=000 0 0

any user can mount the /windows/C .
 
Old 06-25-2004, 01:53 PM   #9
tweezerz
LQ Newbie
 
Registered: Jun 2004
Posts: 2

Rep: Reputation: 0
I see where my problem is different. I was using smb instead of vfat. Instead of using umask you have to use dmask and fmask:

//winmachine/windir /mnt/windir smb noauto,credentials=/etc/samba/smb.info,workgroup=workgroup,owner,dmask=777,fmask=777 0 0

We're on an internal network where security is a very minor issue.

I appreciate the help,

Z
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
non root samba write permission Lazarus Linux - Software 8 05-29-2005 04:57 AM
share read and write permission to users suguname Mandriva 3 01-18-2005 12:53 AM
no write permission? santasballz Linux - Newbie 1 02-12-2004 11:26 PM
No Write Permission... cabrone Linux - Newbie 4 09-15-2003 02:44 PM
vfat partition - write permission for users group digitized_funk Linux - Newbie 8 03-19-2003 07:30 AM


All times are GMT -5. The time now is 04:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration