LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 09-11-2004, 08:38 PM   #1
AshleyK
Member
 
Registered: Sep 2003
Location: Northants, UK
Distribution: RedHat 8, Damn Small
Posts: 39

Rep: Reputation: 15
upgrade to mysql4 failure on RH8


I'm running RH8 on a machine that is used as an Apache-Mysql-PHP server. I want to upgrade the current version of mysql to v4 and have downloaded the RPM and run the rpm program

rpm -U MySQL-server-4.0.21-0.i386.rpm

I get the following error message;
warning: MySQL-server-4.0.21-0.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.1017-3
libmysqlclient.so.10 is needed by (installed) php-mysql-4.2.2-8.0.8

current versions are;
kernel 2.4
mysql 3.23.58
php 4.2.2-8
apache (httpd) 2.0.40

Can anyone suggest what I do next please?

Regards
Ashley
 
Old 09-11-2004, 09:53 PM   #2
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
go download the binary. they work just fine
 
Old 09-12-2004, 03:47 AM   #3
AshleyK
Member
 
Registered: Sep 2003
Location: Northants, UK
Distribution: RedHat 8, Damn Small
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by odious1
go download the binary. they work just fine
I thought the RPM contained the binary. Mysql have a tarball for self compilation or the rpm. Where can I get this binary?

Ashley
 
Old 09-12-2004, 11:26 PM   #4
odious1
Member
 
Registered: Jun 2003
Location: Virginia, USA
Distribution: Slackware
Posts: 252

Rep: Reputation: 30
You can download and unpack this; should be ready to go.

http://dev.mysql.com/downloads/mysql/4.0.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing MySQL4.1 and Installing MySQL4.0.* critical Linux - Software 2 08-04-2005 11:26 PM
upgrade RH8 to RH9 - upgrade or clean install PAB Linux - General 0 03-13-2004 04:55 PM
Linux noob, RH8 install failure Eastree Red Hat 4 01-29-2004 03:51 PM
RH8 First Boot Failure LinuxNooBee Linux - Newbie 3 03-21-2003 04:11 PM
Boot up failure! RH8.0 ShadowGod Linux - Newbie 3 01-09-2003 11:50 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration